ATI X1650 Pro Video Card not working

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

ATI X1650 Pro Video Card not working

Postby Harley51 » Wed Oct 24, 2007 1:38

Has anyone made this card work. Boots into black screen with liveCD.
Harley51
Baby Hen
 
Posts: 16
Joined: Wed Oct 24, 2007 1:32

Re: ATI X1650 Pro Video Card not working

Postby ajez » Wed Oct 24, 2007 9:20

what version of sabayon? 32 or 64 bit? i had problems on 64bit with dvi cable (i have a x800) .. u should try some boot code if u r not using dvi cable. boot code are Here

or u can try to boot in "safe mode" (scroll down on boot menu)

after installation we should try updating the new ati drivers out from today that enables ati cards to use aiglx
--
Core Beta/Site,Blog,Forum Admin
Image
ajez
The Blamed One
 
Posts: 506
Joined: Mon Oct 16, 2006 17:17
Location: Venezia - /dev/null

Re: ATI X1650 Pro Video Card not working

Postby ipellant » Tue Jan 15, 2008 3:43

This thread may be a bit old, but I have just spent a few weeks batling different Linux distros after buying an X1650 Pro AGP card. Before removing the old Radeon 7200 AGP card, sabayon booted off the live DVD (Linux User magazine distro). The new X1650 card would fail to boot about half way through. Lock up with a repeat beat from the sound card.

I tried every Linux I could find. Only Debian, openSUSE 10.3 and Ubuntu 7.10 would boot with the X1650. (BTW: the computer also runs Win 2K and Win XP, which have no problems with the card.) However, no amount of hair pulling would get the ATI drivers to support 3D acceleration. The Mesa drivers would not release for the fglrx drivers to load. Diagnostic with 'demsg | grep agp' indicated that the AGP aperture was not being assigned (that was on openSUSE and Ubuntu). The Gigabyte BIOS did not list any AGP options... that was until I found off their web site, that the AGP configuration is "Advanced" and needed a <Ctrl> <F1> at the main BIOS page to reveal it. Initial AGP Aperture was 32MB. BIOS allowed 512MB (the X1650 on board memory). Setting the aperture in BIOS suddenly enabled full 3D acceleration in Ubuntu. And then in openSUSE).

The finale is that with the aperture set, sabayon now boots fully off the live DVD... an installation is now underway.

SO: note to sabayon developers: the bootup will lock up if an AGP aperture cannot be set. This hang occurs with sabayon and Mandriva. openSUSE, Ubuntu and Debian do not hang. "Bug" is in hardware detection and recovery.

Note to ATI AGP card users: set the aperture in BIOS before trying sabayon. If you can't find AGP settings in the BIOS, check the manufacturers web site... maybe try <Ctrl> <F1>.
ipellant
Baby Hen
 
Posts: 1
Joined: Tue Jan 15, 2008 3:19


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

cron