Page 1 of 1

Cannot mount sd card reader

PostPosted: Fri Oct 12, 2007 5:11
by steveyeager
I have an HP Pavilion notebook, DV6113US. How can I mount my usb card reader? I plug it in and it's like comes on and stays, so it is recognized and is getting power. But it is not on the list of mnt and not in media or dev. So, how can I get it to mount?

Re: Cannot mount sd card reader

PostPosted: Fri Oct 12, 2007 8:48
by WarraWarra
Not sure at all but I think having something photo editing or kde photo something would install a possible missing ??? and then inserting this it ends up auto mounting it same as a camera and asks about open with this ?? software.

Most of it is in the kernel so it should work.

I saw you mentioned it gets power can you see it in "lspci" as root in terminal / konsole ?
I had to on my laptop bios enable the memory card slots adapter to get my firewire to work that uses the same controller chip as the memory cards and then only my cameras showed up. Might have to do something similar of not showing in "lspci" or edit /etc/mtab , /etc/fstab but might need to check gentoo.org forums out / wiki for more info.

I think mine last mounted it by default on SL 3.4 loop 2 or 3 not sure .

Best of luck.

Re: Cannot mount sd card reader

PostPosted: Fri Oct 12, 2007 12:05
by joost
Perhaps posting a bit more info might help out.

Plugin the device, then as root:

Code: Select all
dmesg | tail

To get info on what happened when you plugged it in.

Code: Select all
lsusb

To see how the USB device is listed.

and perhaps a

Code: Select all
lsmod

Re: Cannot mount sd card reader

PostPosted: Mon Oct 15, 2007 22:48
by steveyeager
Thanks for the response. I will try what you have said and get back with you.

In the meantime, I have discovered a few interesting things.

1) If I use the default windows manager, the desktop looks great and the 3D desktop works great. However, this is the environment that will not load the usb devices. I also cannot get the menu to come up correctly. If I hover over the claw icon for the menu, it begins rotating. As soon as I click it, it stops rotating, the dvd rotates for a moment, but after several minutes, I get no menu and the taskbars will not respond to any mouse or key input. Any window currently open still works.

2) If I attempt the accellerated manager, it claims I have no 3d support and takes me to desktop without compiz but some other manager. This environment, the menus work great and the usb devices also auto mount.

Any thoughts on how to resolve this?

Re: Cannot mount sd card reader

PostPosted: Tue Oct 16, 2007 21:23
by steveyeager
Very curious. I am using the sabayon 3.4f dvd image I downloaded. Booting from it causes some major errors. Clicking the network icon to configure my wireless locks that app - other things respond but a window indicating the wireless is configuring is stuck at 28% and never returns. Clicking the menu freezes the toolbar. So, testing here is almost impossible.

I remembered I got some things to work, so I booted from the sabayon 3.4f mini edition. Everything works here. Wireless configures, 3d for kde works, usb devices automount always. I will try my firewire pci-express card tonight. I will install and try the hibernate and suspend options.

I don't know how to test the dvd's problem, but I am past it with the mini.