intel 945gm and 1200x800 resolutions

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
steven_abel
Baby Hen
Posts: 10
Joined: Wed Oct 25, 2006 13:39

intel 945gm and 1200x800 resolutions

Post by steven_abel » Thu Sep 06, 2007 12:46

High folks,

I'm having problems getting my inbuilt 945gm to give me the
correct resolution in SL3.4e - i.e. 1200x800 on my vaio SZ.
The strange thing is that I use the xorg.conf file from SL3.3 which worked fine.
Now I get only the 1024x768 resolution on the left of the screen.

I guess this is something to do with 915resolution support in SL3.3 being
removed in favour of the inbuilt intel driver -- which doesn't work apparently!
This is true for the liveCD as well as many happy hours spent fiddling with xorg.conf
once installed.

Other problems - I had that gnome crashing on logout problem and had to
remove compiz and replace it with beryl.

Thanks for any help

steven_abel
Baby Hen
Posts: 10
Joined: Wed Oct 25, 2006 13:39

[SOLVED] Re: intel 945gm and 1200x800 resolutions

Post by steven_abel » Sat Sep 08, 2007 22:13

I solved this problem ... by installing Ubuntu instead! Sorry guys. I've been using SL since version 3.2
but 3.4 was the end for me. I've really enjoyed my time with SL and Gentoo but I have to say with this release
I really don't know what SL is for any more. People wanting a full gentoo experience can just choose
gentoo itself , and people wanting an instant install will probably not want to spend days tweaking their
systems just to get them running. In addition I have to say (sorry again) that apps in Ubuntu open
noticeably faster than in a straight off SL install, so you don't even get the potential performance benefits of portage
unless you reinstall everything. For reference here are the problems that I encountered
on a macbook pro and a sony vaio -

1) macbook pro keybd not working on boot screen
2) mbp locks at grey screen - given the claim "extra support for macs" I naturally
thought I would be able to boot it!.
3) kde (still) starts with a hugely unpleasant and bellowing anthem.
4) compiz fusion crashes on logging out of gnome - forcing me to press the off button (ctrl-alt-del doesn't work).
5) Gnome logout option message has never (I repeat NEVER) worked when compiz/beryl was in operation
6) Sony vaio resolution when using the native intel driver was not detected correctly - I guess this applies for any 1280x800 laptop! - no amount of tweaking using 915resolution etc could repair this one
7) Macbook keyboard light was full on all the time.
8) beagle tended to go haywire and hogg all the CPU's - maybe this is a problem with beagle though
9) lots of other stuff I can't recall - but since no-one reads these messages anyway I'll stop there

Note that that none of this shonkiness happens in Ubuntu. I can't help feeling that this sort of
experience would drive newbies (I've used linux for 10 years or so in case you're wondering)
straight back to windows or OSX or wherever they came from.

Post Reply