nvidia driver fails for kernel 4.19 [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
msdobrescu
Old Dear Hen
Posts: 700
Joined: Sun Aug 21, 2011 8:48

nvidia driver fails for kernel 4.19 [Solved]

Post by msdobrescu » Sat Jan 26, 2019 23:45

Hello, seems there is something wrong with nvidia driver and the kernel 4.19.
I have a 560 Ti video card and nvidia driver 390.87 (as it is the last that supports it, AFAIK).

The X server does not start anymore:

Code: Select all

[    82.421] 
X.Org X Server 1.20.3
X Protocol Version 11, Revision 0
[    82.421] Build Operating System: Linux 4.9.0-sabayon x86_64 Gentoo
[    82.421] Current Operating System: Linux MYC 4.19.0-sabayon #1 SMP Fri Jan 18 11:22:34 UTC 2019 x86_64
[    82.421] Kernel command line: BOOT_IMAGE=/boot/kernel-genkernel-x86_64-4.19.0-sabayon root=UUID=b37e853f-a647-4536-a52d-6145effa7d95 ro splash dolvm quiet
[    82.421] Build Date: 27 October 2018  02:21:32PM
[    82.421]  
[    82.422] Current version of pixman: 0.34.0
[    82.422] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    82.422] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    82.423] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Jan 27 00:12:07 2019
[    82.484] (==) Using config file: "/etc/X11/xorg.conf"
[    82.484] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    82.484] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    82.604] (==) ServerLayout "Main Layout"
[    82.604] (**) |-->Screen "Screen 0" (0)
[    82.604] (**) |   |-->Monitor "Generic Monitor"
[    82.605] (**) |   |-->Device "SabayonVga0"
[    82.605] (**) Option "AllowMouseOpenFail" "true"
[    82.605] (==) Automatically adding devices
[    82.605] (==) Automatically enabling devices
[    82.605] (==) Automatically adding GPU devices
[    82.605] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    82.649] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    82.649] 	Entry deleted from font path.
[    82.660] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/Type1/,
	/usr/share/fonts/100dpi/,
	/usr/share/fonts/75dpi/
[    82.660] (**) ModulePath set to "/usr/lib64/opengl/nvidia,/usr/lib64/xorg/modules"
[    82.660] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    82.660] (II) Loader magic: 0x560f42ff1d00
[    82.660] (II) Module ABI versions:
[    82.660] 	X.Org ANSI C Emulation: 0.4
[    82.660] 	X.Org Video Driver: 24.0
[    82.660] 	X.Org XInput driver : 24.1
[    82.660] 	X.Org Server Extension : 10.0
[    82.661] (++) using VT number 1

[    82.661] (--) controlling tty is VT number 1, auto-enabling KeepTty
[    82.666] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[    82.673] (--) PCI:*([email protected]:0:0) 10de:1200:1458:3515 rev 161, Mem @ 0xf8000000/33554432, 0xd8000000/134217728, 0xd4000000/67108864, I/O @ 0x00009c00/128, BIOS @ 0x????????/131072
[    82.673] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    82.673] (II) LoadModule: "extmod"
[    82.673] (II) Module "extmod" already built-in
[    82.673] (II) LoadModule: "i2c"
[    82.673] (II) Module "i2c" already built-in
[    82.673] (II) LoadModule: "ddc"
[    82.673] (II) Module "ddc" already built-in
[    82.673] (II) LoadModule: "vbe"
[    82.744] (II) Loading /usr/lib64/xorg/modules/libvbe.so
[    82.754] (II) Module vbe: vendor="X.Org Foundation"
[    82.754] 	compiled for 1.20.3, module version = 1.1.0
[    82.754] 	ABI class: X.Org Video Driver, version 24.0
[    82.755] (II) LoadModule: "dri"
[    82.755] (II) Module "dri" already built-in
[    82.755] (II) LoadModule: "glx"
[    82.755] (II) Loading /usr/lib64/opengl/nvidia/extensions/libglx.so
[    83.005] (II) Module glx: vendor="NVIDIA Corporation"
[    83.005] 	compiled for 4.0.2, module version = 1.0.0
[    83.005] 	Module class: X.Org Server Extension
[    83.014] (II) NVIDIA GLX Module  390.87  Tue Aug 21 16:10:56 PDT 2018
[    83.016] (II) LoadModule: "synaptics"
[    83.016] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[    83.038] (II) Module synaptics: vendor="X.Org Foundation"
[    83.038] 	compiled for 1.20.3, module version = 1.9.1
[    83.038] 	Module class: X.Org XInput Driver
[    83.038] 	ABI class: X.Org XInput driver, version 24.1
[    83.038] (II) LoadModule: "nvidia"
[    83.061] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[    83.108] (II) Module nvidia: vendor="NVIDIA Corporation"
[    83.108] 	compiled for 4.0.2, module version = 1.0.0
[    83.108] 	Module class: X.Org Video Driver
[    83.110] (II) NVIDIA dlloader X Driver  390.87  Tue Aug 21 15:44:49 PDT 2018
[    83.110] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    83.111] (II) Loading sub module "fb"
[    83.111] (II) LoadModule: "fb"
[    83.111] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    83.119] (II) Module fb: vendor="X.Org Foundation"
[    83.119] 	compiled for 1.20.3, module version = 1.0.0
[    83.119] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    83.119] (II) Loading sub module "wfb"
[    83.119] (II) LoadModule: "wfb"
[    83.119] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    83.123] (II) Module wfb: vendor="X.Org Foundation"
[    83.123] 	compiled for 1.20.3, module version = 1.0.0
[    83.123] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    83.123] (II) Loading sub module "ramdac"
[    83.123] (II) LoadModule: "ramdac"
[    83.123] (II) Module "ramdac" already built-in
[    83.169] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[    83.169] (EE) NVIDIA:     system's kernel log for additional error messages and
[    83.169] (EE) NVIDIA:     consult the NVIDIA README for details.
[    83.169] (EE) No devices detected.
[    83.169] (EE) 
Fatal server error:
[    83.169] (EE) no screens found(EE) 
[    83.169] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    83.169] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    83.169] (EE) 
[    83.170] (EE) Server terminated with error (1). Closing log file.
Please help.
Last edited by msdobrescu on Sun Feb 24, 2019 8:17, edited 1 time in total.

msdobrescu
Old Dear Hen
Posts: 700
Joined: Sun Aug 21, 2011 8:48

Re: nvidia driver fails for kernel 4.19

Post by msdobrescu » Mon Jan 28, 2019 18:45

Hi, actually, there is no nvidia driver 390 for kernel 4.19:

Code: Select all

equo search nvidia-drivers-390
╠  @@ Searching...
╠      @@ Package: x11-drivers/nvidia-drivers-390.87-r1#4.14.0-sabayon branch: 5, [sabayonlinux.org] 
╠          Available:     version: 390.87-r1 ~ tag: 4.14.0-sabayon ~ revision: 6
╠          Installed:     version: Not installed ~ tag: n/a ~ revision: n/a
╠          Slot:          0,4.14.0-sabayon
╠          Homepage:      http://www.nvidia.com/ 
╠                         http://www.nvidia.com/Download/Find.aspx 
╠          Description:   NVIDIA X11 userspace libraries 
╠                         and applications 
╠          License:       GPL-2 NVIDIA-r2
╠      @@ Package: x11-drivers/nvidia-drivers-390.87-r1#4.18.0-sabayon branch: 5, [sabayonlinux.org] 
╠          Available:     version: 390.87-r1 ~ tag: 4.18.0-sabayon ~ revision: 5
╠          Installed:     version: 390.87-r1 ~ tag: 4.18.0-sabayon ~ revision: 5
╠          Slot:          0,4.18.0-sabayon
╠          Homepage:      http://www.nvidia.com/ 
╠                         http://www.nvidia.com/Download/Find.aspx 
╠          Description:   NVIDIA X11 userspace libraries 
╠                         and applications 
╠          License:       GPL-2 NVIDIA-r2
╠      @@ Package: x11-drivers/nvidia-drivers-390.87-r1#4.4.0-sabayon branch: 5, [sabayonlinux.org] 
╠          Available:     version: 390.87-r1 ~ tag: 4.4.0-sabayon ~ revision: 4
╠          Installed:     version: Not installed ~ tag: n/a ~ revision: n/a
╠          Slot:          0,4.4.0-sabayon
╠          Homepage:      http://www.nvidia.com/ 
╠                         http://www.nvidia.com/Download/Find.aspx 
╠          Description:   NVIDIA X11 userspace libraries 
╠                         and applications 
╠          License:       GPL-2 NVIDIA-r2
╠      @@ Package: x11-drivers/nvidia-drivers-390.87-r1#4.9.0-sabayon branch: 5, [sabayonlinux.org] 
╠          Available:     version: 390.87-r1 ~ tag: 4.9.0-sabayon ~ revision: 5
╠          Installed:     version: Not installed ~ tag: n/a ~ revision: n/a
╠          Slot:          0,4.9.0-sabayon
╠          Homepage:      http://www.nvidia.com/ 
╠                         http://www.nvidia.com/Download/Find.aspx 
╠          Description:   NVIDIA X11 userspace libraries 
╠                         and applications 
╠          License:       GPL-2 NVIDIA-r2
╠   Keywords:  nvidia-drivers-390
╠   Found:     4 entries

msdobrescu
Old Dear Hen
Posts: 700
Joined: Sun Aug 21, 2011 8:48

Re: nvidia driver fails for kernel 4.19

Post by msdobrescu » Sun Feb 10, 2019 20:56

Hi, request added here: https://bugs.sabayon.org/show_bug.cgi?id=5749
No resolution so far...

joost
Sagely Hen
Posts: 2732
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: nvidia driver fails for kernel 4.19

Post by joost » Sun Feb 10, 2019 23:47

On 4.19 and 4.20 kernel there is no legacy support for these old cards. I guess you must use the open source (nouveau) drivers for this, or stick with an older kernel.
Image
My blog | Twitter | Please support Sabayon: Image

msdobrescu
Old Dear Hen
Posts: 700
Joined: Sun Aug 21, 2011 8:48

Re: nvidia driver fails for kernel 4.19

Post by msdobrescu » Mon Feb 11, 2019 4:37

Why? I've tried Nouveau, and doesn't work properly.

joost
Sagely Hen
Posts: 2732
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: nvidia driver fails for kernel 4.19

Post by joost » Mon Feb 11, 2019 10:19

Then use an older kernel.
Image
My blog | Twitter | Please support Sabayon: Image

msdobrescu
Old Dear Hen
Posts: 700
Joined: Sun Aug 21, 2011 8:48

Re: nvidia driver fails for kernel 4.19

Post by msdobrescu » Mon Feb 11, 2019 12:30

How long would this work in Sabayon?

I've found this, I'll try tonight to patch the nvidia drivers. I've found this and this.
If there's only a type naming issue, I might make it work, as others. Not nice, though.


msdobrescu
Old Dear Hen
Posts: 700
Joined: Sun Aug 21, 2011 8:48

Re: nvidia driver fails for kernel 4.19

Post by msdobrescu » Mon Feb 11, 2019 19:41

Hi, this solves the build: https://forums.gentoo.org/viewtopic-t-1 ... art-0.html
Would somebody implement this for Sabayon too?

msdobrescu
Old Dear Hen
Posts: 700
Joined: Sun Aug 21, 2011 8:48

Re: nvidia driver fails for kernel 4.19

Post by msdobrescu » Sun Feb 24, 2019 8:17

Hi, the drivers are back! Thank you!

Post Reply