python-updater: can't emerge blocked packages.

Anything that pertains to Portage

Moderator: Moderators

python-updater: can't emerge blocked packages.

Postby edgevision » Wed Aug 29, 2007 4:53

So I built Sabayon Core with XFCE. Somewhere along the way, Python got updated to 2.5.1-r2 and informed me that I had to run python-updater to re-emerge my Python apps. First, it kept saying it couldn't find certain ebuilds to emerge.. like subversion, etc. So I emerged them all manually.

Now, when I run python-updater, it returns this:

Code: Select all
[email protected] /media/Storage/data/iso $ sudo python-updater
 * Starting Python Updater from 2.4 to 2.5 :
 * Searching for packages with files in /usr/lib/python2.4 /usr/lib32/python2.4 /usr/lib64/python2.4 ..
 * Adding to list: =net-zope/zopeinterface-3.0.1-r1
 * Adding to list: =sys-libs/libcap-1.10-r10
 * Adding to list: =sys-libs/cracklib-2.8.10
 * Adding to list: =app-admin/gamin-0.1.9
 * Adding to list: =app-admin/webapp-config-1.50.16
/usr/sbin/python-updater: line 181: /var/db/pkg/app-admin/liboobs-2.18.1/SLOT: No such file or directory
 * Adding to list: =media-libs/lcms-1.16
 * Adding to list: =sys-apps/file-4.21-r1
 * Adding to list: =dev-python/pyparted-1.7.0
 * Adding to list: =dev-python/pyopenssl-0.6-r1
 * Adding to list: =dev-python/pygobject-2.12.3
 * Adding to list: =dev-python/configobj-4.4.0
 * Adding to list: =dev-python/pyxml-0.8.4
 * Adding to list: =dev-python/cddb-py-1.4
 * Adding to list: =dev-python/soappy-0.12.0
 * Adding to list: =dev-python/Louie-1.1
 * Adding to list: =dev-python/pycairo-1.4.0
 * Adding to list: =dev-python/twisted-web-0.7.0
 * Adding to list: =dev-python/python-ldap-2.3.1
 * Adding to list: =dev-python/elementtree-1.2.6
 * Adding to list: =dev-python/numeric-24.2-r4
 * Adding to list: =dev-python/pythondialog-2.7
 * Adding to list: =dev-python/pycrash-0.4_pre3
 * Adding to list: =dev-python/pycrypto-2.0.1-r5
 * Adding to list: =dev-python/fpconst-0.7.3
 * Adding to list: =dev-python/pyopengl-2.0.1.09-r1
 * Adding to list: =dev-python/dbus-python-0.80.2
 * Adding to list: =dev-python/pysqlite-2.3.5
 * Adding to list: =dev-python/Coherence-0.2.1
 * Adding to list: =dev-python/ctypes-1.0.1-r1
 * Adding to list: =dev-python/pyrex-0.9.5.1a
 * Adding to list: =dev-python/python-fchksum-1.7.1
 * Adding to list: =dev-python/urlgrabber-3.0.0
 * Adding to list: =dev-python/id3-py-1.2
 * Adding to list: =dev-python/nevow-0.9.0
 * Adding to list: =dev-python/nevow-0.9.0
 * Adding to list: =dev-python/setuptools-0.6_rc5
 * Adding to list: =dev-python/egenix-mx-base-2.0.6
 * Adding to list: =dev-python/egenix-mx-base-2.0.6
 * Adding to list: =dev-python/sip-4.5.2-r1
 * Adding to list: =dev-python/twisted-2.5.0
 * Adding to list: =dev-python/m2crypto-0.17-r1
 * Adding to list: =net-fs/samba-3.0.24-r3
 * Adding to list: =net-print/hplip-1.6.10
 * Adding to list: =app-portage/porthole-0.5.0
 * Adding to list: =app-portage/layman-1.0.99
 * Adding to list: =dev-libs/libdnet-1.11
 * Adding to list: =dev-libs/libxml2-2.6.28
 * Adding to list: =dev-libs/libxslt-1.1.20
 * Adding to list: =dev-libs/newt-0.52.2
 * Adding to list: =dev-libs/beecrypt-4.1.2-r2
 * Adding to list: =dev-util/scons-0.96.96

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] dev-util/pkgconfig-0.22 [0.21-r1] USE="(-hardened)" 983 kB
[ebuild     U ] dev-libs/expat-2.0.1 [2.0.0] 436 kB
[ebuild     U ] sys-devel/gnuconfig-20070724 [20070118] 40 kB
[ebuild     U ] app-misc/pax-utils-0.1.16 [0.1.15] USE="-caps" 64 kB
[ebuild     U ] sys-devel/gcc-config-1.4.0-r1 [1.3.16] 0 kB
[ebuild     U ] app-portage/portage-utils-0.1.28 [0.1.26] 78 kB
[ebuild     U ] media-sound/alsa-headers-1.0.14 [1.0.14_rc3] 2,540 kB
[ebuild     U ] sys-libs/timezone-data-2007g [2007e] USE="nls" 344 kB
[ebuild     U ] app-arch/cpio-2.9 [2.7-r2] USE="nls" 741 kB
[ebuild     U ] dev-db/sqlite-3.4.1 [3.3.12] USE="-debug -doc -nothreadsafe -soundex% -tcl" 2,186 kB
[ebuild  N    ] app-text/poppler-data-0.1  2,558 kB
[ebuild     U ] net-print/foomatic-db-ppds-20070508 [20060720] 15,408 kB
[ebuild   R   ] dev-libs/libdnet-1.11  USE="python" 436 kB
[ebuild     U ] sys-devel/gettext-0.16.1-r1 [0.16.1] USE="nls -doc -emacs -nocxx" 8,340 kB
[ebuild     U ] sys-kernel/linux-headers-2.6.22-r2 [2.6.19.2-r2] 4,599 kB
[ebuild     U ] media-libs/libpng-1.2.19 [1.2.16] USE="mmx%* -doc" 636 kB
[ebuild  N    ] dev-java/java-config-wrapper-0.14  8 kB
[ebuild     U ] sys-devel/m4-1.4.10 [1.4.9] USE="nls -examples" 722 kB
[ebuild     U ] sys-apps/sysvinit-2.86-r9 [2.86-r8] USE="(-ibm) (-selinux) -static" 101 kB
[ebuild     U ] sys-apps/findutils-4.3.8-r1 [4.3.2-r1] USE="nls (-selinux) -static" 1,766 kB
[ebuild     U ] sys-devel/binutils-config-1.9-r4 [1.9-r3] 0 kB
[ebuild     U ] sys-devel/binutils-2.17.50.0.18 [2.17] USE="nls -multislot (-multitarget) -test -vanilla" 13,607 kB
[ebuild     U ] sys-apps/debianutils-2.23.1 [2.17.5] USE="-static" 133 kB
[ebuild     U ] media-libs/freetype-2.3.5-r1 [2.3.4] USE="X%* zlib -bindist -debug -doc" 1,449 kB
[ebuild  N    ] dev-perl/perl-tk-804.027  5,871 kB
[ebuild     U ] sys-apps/man-pages-2.64 [2.44] USE="nls" 1,799 kB
[ebuild     U ] sys-apps/diffutils-2.8.7-r2 [2.8.7-r1] USE="nls -static" 1,038 kB
[ebuild     U ] sys-devel/autoconf-2.61-r1 [2.61] USE="-emacs" 1,365 kB
[ebuild     U ] sys-devel/libtool-1.5.24 [1.5.23b] USE="-vanilla%" 2,852 kB
[ebuild     U ] sys-apps/attr-2.4.38 [2.4.32] USE="nls" 111 kB
[ebuild     U ] app-crypt/mit-krb5-1.5.3 [1.5.2-r2] USE="ipv6 -doc -krb4 -tcl" 9,873 kB
[ebuild  N    ] x11-misc/read-edid-1.4.1-r1  63 kB
[ebuild     U ] sys-apps/acl-2.2.44 [2.2.39-r1] USE="nls -nfs" 150 kB
[ebuild     U ] net-misc/rsync-2.6.9-r3 [2.6.9-r2] USE="acl* ipv6 -static -xinetd" 793 kB
[ebuild     U ] media-libs/alsa-lib-1.0.14a-r1 [1.0.14_rc3] USE="midi%* -alisp% -debug -doc" ALSA_PCM_PLUGINS="adpcm%* alaw%* copy%* dshare%* dsnoop%* extplug%* file%* hooks%* ladspa%* lfloat%* linear%* meter%* mulaw%* multi%* null%* rate%* route%* share%* shm%*" 768 kB
[ebuild  N    ] x11-apps/xprop-1.0.2  USE="-debug" 98 kB
[ebuild  N    ] x11-misc/xdg-utils-1.0.2  USE="-doc" 276 kB
[ebuild     U ] sys-libs/glibc-2.6.1 [2.5-r1] USE="nls -debug -glibc-compat20 -glibc-omitfp (-hardened) (-multilib) -profile (-selinux) (-build%) (-nptl%*) (-nptlonly%*)" 16,005 kB
[ebuild     U ] dev-libs/glib-2.12.13 [2.12.11] USE="-debug -doc (-hardened)" 2,870 kB
[ebuild     U ] net-libs/gnutls-1.6.3 [1.6.2] USE="nls zlib -doc" 4,186 kB
[ebuild     U ] dev-libs/liboil-0.3.12 [0.3.11] USE="-doc" 792 kB
[ebuild   R   ] app-admin/gamin-0.1.9  USE="-debug" 0 kB
[ebuild   R   ] dev-python/python-fchksum-1.7.1  27 kB
[ebuild  N    ] dev-java/java-config-2.0.33-r1  25 kB
[ebuild     U ] dev-python/setuptools-0.6_rc6 [0.6_rc5] 243 kB
[ebuild   R   ] dev-python/pyxml-0.8.4  718 kB
[ebuild   R   ] dev-python/elementtree-1.2.6  41 kB
[ebuild   R   ] net-zope/zopeinterface-3.0.1-r1  USE="-doc" 106 kB
[ebuild  N    ] sys-apps/groff-1.18.1.1  USE="X cjk" 2,333 kB
[ebuild  N    ] dev-java/java-config-1.3.7  15 kB
[ebuild  N    ] dev-java/sun-jdk-1.6.0.02  USE="X alsa -doc -examples -jce (-nsplugin)" 50,768 kB
[ebuild  N    ] virtual/jdk-1.6.0  0 kB
[ebuild  N    ] virtual/jre-1.6.0  0 kB
[ebuild   R   ] sys-libs/cracklib-2.8.10  USE="nls python" 565 kB
[ebuild     U ] sys-libs/pam-0.99.8.1 [0.99.7.1] USE="cracklib%* nls (-selinux) -vim-syntax" 886 kB
[ebuild   R   ] sys-apps/file-4.21-r1  USE="python" 0 kB
[ebuild   R   ] dev-python/pygobject-2.12.3  USE="-debug -doc" 332 kB
[ebuild   R   ] dev-python/numeric-24.2-r4  USE="-debug -doc -lapack" 727 kB
[ebuild   R   ] dev-python/pycairo-1.4.0  USE="-examples" 0 kB
[ebuild   R   ] dev-python/configobj-4.4.0  USE="-doc" 168 kB
[ebuild   R   ] dev-python/fpconst-0.7.3  10 kB
[ebuild   R   ] dev-python/Louie-1.1  22 kB [1]
[ebuild   R   ] dev-python/pyrex-0.9.5.1a  USE="-examples" 179 kB
[ebuild  N    ] dev-python/celementtree-1.0.5-r1  USE="-doc" 0 kB
[ebuild  N    ] app-text/poppler-0.5.4-r2  USE="cjk jpeg zlib" 1,038 kB
[ebuild     U ] sys-apps/lm_sensors-2.10.4 [2.10.3] USE="-sensord" 911 kB
[ebuild     U ] dev-python/pycrypto-2.0.1-r6 [2.0.1-r5] USE="-bindist -gmp -test" 151 kB
[ebuild   R   ] sys-libs/libcap-1.10-r10  USE="python" 39 kB
[ebuild   R   ] app-admin/webapp-config-1.50.16  102 kB
[ebuild   R   ] media-libs/lcms-1.16  USE="jpeg python tiff zlib" 891 kB
[ebuild   R   ] dev-python/cddb-py-1.4  39 kB
[ebuild   R   ] dev-python/pycrash-0.4_pre3  23 kB
[ebuild   R   ] dev-python/pycrypto-2.0.1-r5  USE="-bindist -gmp -test" 0 kB
[ebuild   R   ] dev-python/pyopengl-2.0.1.09-r1  USE="-doc" 0 kB
[ebuild   R   ] dev-python/dbus-python-0.80.2  USE="-test%" 443 kB
[ebuild   R   ] dev-python/pysqlite-2.3.5  USE="-examples" 0 kB
[ebuild   R   ] dev-python/ctypes-1.0.1-r1  USE="-doc" 376 kB
[ebuild   R   ] dev-python/urlgrabber-3.0.0  77 kB
[ebuild   R   ] dev-python/id3-py-1.2  17 kB
[ebuild   R   ] dev-python/setuptools-0.6_rc5  240 kB
[ebuild   R   ] dev-python/egenix-mx-base-2.0.6  574 kB
[ebuild   R   ] dev-python/sip-4.5.2-r1  USE="-debug" 408 kB
[ebuild   R   ] app-portage/porthole-0.5.0  USE="nls -debug" 0 kB
[ebuild   R   ] app-portage/layman-1.0.99  34 kB
[ebuild   R   ] dev-libs/beecrypt-4.1.2-r2  USE="java python -doc -nocxx -threads" 757 kB
[ebuild   R   ] dev-util/scons-0.96.96  429 kB
[ebuild     U ] sys-libs/ncurses-5.6-r2 [5.6-r1] USE="gpm unicode -bootstrap -build -debug -doc -minimal -nocxx -profile% -trace" 2,353 kB
[ebuild     U ] app-shells/bash-3.2_p17-r1 [3.2_p15-r1] USE="nls -afs -bashlogger -plugins% -vanilla" 2,522 kB
[ebuild     U ] sys-libs/gpm-1.20.1-r6 [1.20.1-r5] USE="(-selinux)" 560 kB
[ebuild     U ] sys-apps/coreutils-6.9-r1 [6.9] USE="acl* nls (-selinux) -static -xattr" 5,307 kB
[ebuild     U ] sys-libs/readline-5.2_p7 [5.2_p2] 2,008 kB
[ebuild  NS   ] sys-devel/gcc-4.2.0  USE="fortran gcj gtk mudflap nls openmp (-altivec) -bootstrap -build -doc (-hardened) -ip28 -ip32r10k (-multilib) -multislot (-n32) (-n64) -nocxx -objc -objc++ -objc-gc -test -vanilla" 43,093 kB
[ebuild     U ] dev-util/dialog-1.1.20070704 [1.1.20070409] USE="unicode -examples" 359 kB
[ebuild     U ] dev-libs/libxml2-2.6.29 [2.6.28] USE="ipv6 python readline -debug -doc -test" 4,610 kB
[ebuild     U ] sys-apps/parted-1.8.8 [1.8.6] USE="nls readline -debug -device-mapper (-selinux)" 1,518 kB
[ebuild   R   ] dev-python/pythondialog-2.7  29 kB
[ebuild   R   ] dev-libs/libxml2-2.6.28  USE="ipv6 python readline -debug -doc -test" 4,606 kB
[ebuild  N    ] media-libs/gstreamer-0.10.14  1,958 kB
[ebuild   R   ] dev-libs/libxslt-1.1.20  USE="crypt python -debug" 3,604 kB
[ebuild     U ] sys-apps/baselayout-1.12.10-r4 [1.12.10-r3] USE="unicode -bootstrap -build -static" 214 kB
[ebuild     U ] sys-fs/udev-115 [109-r1] USE="(-selinux)" 195 kB
[ebuild     U ] dev-lang/ruby-1.8.6_p36-r4 [1.8.6] USE="cjk%* ipv6 -debug -doc -examples -rubytests% -socks5 -threads -tk" 4,645 kB
[ebuild     U ] dev-libs/openssl-0.9.8e-r2 [0.9.8e] USE="(sse2) zlib -bindist -emacs -test" 3,264 kB
[ebuild     U ] net-nds/openldap-2.3.37 [2.3.35-r1] USE="berkdb crypt gdbm ipv6 kerberos perl readline samba ssl tcpd -debug -minimal -odbc -overlays -sasl (-selinux) -slp -smbkrb5passwd" 3,711 kB
[ebuild     U ] app-misc/ca-certificates-20070303-r1 [20061027.2] 95 kB
[ebuild     U ] dev-util/git-1.5.3_rc5-r1 [1.5.1.2] USE="gtk perl -bash-completion -curl -doc -emacs -mozsha1 (-ppcsha1) -tk -webdav" 1,449 kB
[ebuild     U ] dev-lang/python-2.4.4-r5 [2.4.4-r4] USE="berkdb gdbm ipv6 ncurses readline ssl tk -bootstrap -build -doc -examples -nocxx -nothreads -ucs2" 0 kB
[ebuild   R   ] dev-python/pyopenssl-0.6-r1  USE="-doc" 276 kB
[ebuild   R   ] dev-python/m2crypto-0.17-r1  USE="-doc" 368 kB
[ebuild     U ] net-analyzer/net-snmp-5.4.1 [5.4] USE="X ipv6 lm_sensors perl ssl tcpd -diskio -doc -elf -mfd-rewrites -minimal -rpm (-selinux) -sendmail -smux" 5,003 kB
[ebuild   R   ] dev-python/twisted-2.5.0  USE="crypt gtk -serial" 2,002 kB
[ebuild     U ] sys-apps/util-linux-2.13 [2.12r-r6] USE="nls -old-linux% (-selinux) (-crypt%*) (-old-crypt%) (-perl%*) (-static%)" 2,640 kB
[ebuild   R   ] dev-python/soappy-0.12.0  USE="ssl -examples" 173 kB
[ebuild   R   ] dev-python/python-ldap-2.3.1  USE="ssl -doc -examples -sasl" 0 kB
[ebuild     U ] app-arch/rpm2targz-9.0-r6 [9.0-r5] 3 kB
[ebuild   R   ] dev-python/twisted-web-0.7.0  258 kB
[ebuild   R   ] dev-python/nevow-0.9.0  USE="-doc" 466 kB
[ebuild   R   ] dev-python/pyparted-1.7.0  313 kB
[ebuild   R   ] dev-libs/newt-0.52.2  USE="gpm -tcl" 277 kB
[ebuild     U ] net-print/foomatic-filters-3.0.20070501 [3.0.20060720] USE="cups" 163 kB
[ebuild     U ] net-print/foomatic-filters-ppds-20070501 [20060720] 12,144 kB
[ebuild     U ] net-print/cups-1.2.12 [1.2.10] USE="X dbus jpeg ldap nls pam ppds samba ssl tiff -php -png* -slp" 3,700 kB
[ebuild   R   ] net-fs/samba-3.0.24-r3  USE="acl cups kerberos ldap oav pam python readline -async -automount -caps -doc -examples -fam -quotas (-selinux) -swat -syslog -winbind" LINGUAS="-ja -pl" 0 kB
[ebuild   R   ] net-print/hplip-1.6.10  USE="X cups ppds snmp -foomaticdb* -qt3* -scanner*" 10,315 kB
[ebuild  N    ] media-libs/gst-plugins-base-0.10.14  USE="X alsa oss -debug -esd -xv" 1,588 kB
[ebuild  N    ] media-plugins/gst-plugins-x-0.10.12  1,427 kB
[ebuild  N    ] media-plugins/gst-plugins-oss-0.10.5  1,325 kB
[ebuild  N    ] media-plugins/gst-plugins-alsa-0.10.14  0 kB
[ebuild  N    ] dev-python/gst-python-0.10.6  USE="-doc" 563 kB
[ebuild   R   ] dev-python/Coherence-0.2.1  131 kB [1]
[blocks B     ] <net-print/hplip-1.7.4a-r1 (is blocking net-print/cups-1.2.12)
[blocks B     ] >=sys-apps/util-linux-2.13_pre (is blocking sys-process/schedutils-1.5.0)
[blocks B     ] <sys-fs/device-mapper-1.02.19-r1 (is blocking sys-fs/udev-115)
[blocks B     ] sys-apps/setarch (is blocking sys-apps/util-linux-2.13)
[blocks B     ] <sys-apps/baselayout-2.0.0_rc (is blocking sys-apps/makedev-3.23.1)
[blocks B     ] sys-process/schedutils (is blocking sys-apps/util-linux-2.13)

Total: 130 packages (60 upgrades, 20 new, 1 in new slot, 49 reinstalls, 6 blocks), Size of downloads: 298,976 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/portage/local/layman/sabayon

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Blocked packages.. some of them critical to the system, that can't be removed, and some that are co-existing, even though they're supposed to be blocked..?

What do I do from here? I can't update my python modules and none of my python applications work, including Porthole. I'm surprised portage even works since it's written in python. I can't seem to revert to 2.4.4 because then python-updater says it can't find a version to update?

I'm lost, and getting increasingly frustrated. Hopefully someone can give me a hand with this.
edgevision
Growing Hen
 
Posts: 180
Joined: Tue Jun 26, 2007 18:40
Location: New Brunswick, Canada

Re: python-updater: can't emerge blocked packages.

Postby edgevision » Wed Aug 29, 2007 6:51

UPDATE: Slowly going through the list of packages suggested by python-updater, remerging one-by-one manually. Don't know why python-updater couldn't do this itself. So far so good, except for avahi.
edgevision
Growing Hen
 
Posts: 180
Joined: Tue Jun 26, 2007 18:40
Location: New Brunswick, Canada

Re: python-updater: can't emerge blocked packages.

Postby Necoro » Wed Aug 29, 2007 7:48

edgevision wrote:UPDATE: Slowly going through the list of packages suggested by python-updater, remerging one-by-one manually. Don't know why python-updater couldn't do this itself. So far so good, except for avahi.

Don't forget to use the "--oneshot" option for emerge to not add each package to the world file.

To the blocked packages:
- hplip can be unmerged and later remerged
- makedev can be unmerged - it is completely useless

For setarch and schedutils - no idea

edit:/ your python-updater wants to install python-2.4.4-r5 ... this is really strange ;)
User avatar
Necoro
Advanced Hen
 
Posts: 242
Joined: Mon Apr 23, 2007 22:47
Location: Munich (Germany)

Re: python-updater: can't emerge blocked packages.

Postby edgevision » Wed Aug 29, 2007 12:09

Each package would already be in the world file though, these are all packages that have already been installed that need to be re-emerged. Still chugging along, working on glibc now.. :roll:

No idea why it wants to go down to 2.4.4-r5 for Python. Again, friggin weird.

As I progress down the list (I'm emerging them in the order python-updater listed them) the reported "blocked" packages are actually disappearing each time python-updater -p is run... this is so odd. This system is pretty much vanilla too, I installed Sabayon Core, emerged xorg-x11, and emerged xfce..

Shouldn't be happening.
edgevision
Growing Hen
 
Posts: 180
Joined: Tue Jun 26, 2007 18:40
Location: New Brunswick, Canada

Re: python-updater: can't emerge blocked packages.

Postby Necoro » Wed Aug 29, 2007 17:17

edgevision wrote:Each package would already be in the world file though, these are all packages that have already been installed that need to be re-emerged. Still chugging along, working on glibc now.. :roll:

Installed and "in world file" are not the same ... you never want libraries and stuff to be listed in the world file ...
User avatar
Necoro
Advanced Hen
 
Posts: 242
Joined: Mon Apr 23, 2007 22:47
Location: Munich (Germany)

Re: python-updater: can't emerge blocked packages.

Postby edgevision » Wed Aug 29, 2007 18:08

Ahh ok, I misunderstood your post. Thank you. :) I'm at work now but I'll post again shortly with an update.
edgevision
Growing Hen
 
Posts: 180
Joined: Tue Jun 26, 2007 18:40
Location: New Brunswick, Canada

Re: python-updater: can't emerge blocked packages.

Postby edgevision » Wed Aug 29, 2007 20:11

As I type this, I'm re-installing Sabayon Core. A companion of mine (a Gentoo enthusiast) pointed out that python-updater wanted me to upgrade gcc-4.1.2 to 4.2.0... this would have broken a lot of packages and would be a huge waste of time. I'm giving it another go, and this time, I don't plan on updating my python past 2.4.4.. I guess my biggest question is, why. Why did updating my python break my system, and why when I follow the standard procedure for updating python did it want to emerge all of those packages?

I'm wondering if this is specific to Sabayon Core.
edgevision
Growing Hen
 
Posts: 180
Joined: Tue Jun 26, 2007 18:40
Location: New Brunswick, Canada

Re: python-updater: can't emerge blocked packages.

Postby Necoro » Wed Aug 29, 2007 20:26

I think that this is really a Sabayon problem. Me as a Gentoo User did not have any problem with python-updater, as I run "emerge -uNDav world" nearly once a day. Thus python-updater did not want to update anything but just did plain rebuilds.
In Sabayon you now have a problem as several critical updates fall together...
User avatar
Necoro
Advanced Hen
 
Posts: 242
Joined: Mon Apr 23, 2007 22:47
Location: Munich (Germany)

Re: python-updater: can't emerge blocked packages.

Postby wolfden » Wed Aug 29, 2007 21:59

edgevision wrote:As I type this, I'm re-installing Sabayon Core. A companion of mine (a Gentoo enthusiast) pointed out that python-updater wanted me to upgrade gcc-4.1.2 to 4.2.0... this would have broken a lot of packages and would be a huge waste of time. I'm giving it another go, and this time, I don't plan on updating my python past 2.4.4.. I guess my biggest question is, why. Why did updating my python break my system, and why when I follow the standard procedure for updating python did it want to emerge all of those packages?

I'm wondering if this is specific to Sabayon Core.


check your world file
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: python-updater: can't emerge blocked packages.

Postby edgevision » Wed Aug 29, 2007 22:40

There are huge differences between the portage configuration on Core and regular installs, notably in make.conf and package.mask, as well as the world file. I'm going to assume these all played a part in what happened, but still, I should be able to upgrade Python on a fresh Core install of Sabayon without breaking the system.

This time around, I decided to install Sabayon with GNOME and then emerge XFCE afterwards. I would highly suggest that the dev team have a look at Core and how it functions. I'm using it on another server right now, luckily I never tried to upgrade python on that box so for now I'm adding >dev-lang/python to /etc/portage/package.mask.
edgevision
Growing Hen
 
Posts: 180
Joined: Tue Jun 26, 2007 18:40
Location: New Brunswick, Canada

Next

Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest