Page 1 of 1

My little problem

PostPosted: Thu Aug 16, 2007 0:26
by keon
Hello guys,

I am relatively new to Sabayon, Ive used ubuntu for around a year and decided it was time for a change. I just installed Sabayon 3.26 on my laptop when I decided to run "emerge --sync && emerge -uDN world" (I picked this up from the gentoo handbook). Sabayon gave me some commands to replace a make.profile, and as far as I know they were successful. After updating the make.profile, I decided to run
Code: Select all
emerge --sync && emerge -uDN world
again. When I ran
Code: Select all
emaint --check world
it gave me a list of programs that needed to be installed. When I tried to install the programs it gave me this
Code: Select all
localhost mcmahon # emaint --check world
Checking world for problems

'gnome-base/gnome-vfs' is not installed
'gnome-base/gnome-common' is not installed
'gnome-base/gnome-print' is not installed
'gnome-base/gnome-libs' is not installed
'x11-themes/gnome-themes-extras' is not installed
'gnome-base/gnome-keyring' is not installed
'sys-data/sabayon-version' has a category that is not listed in /etc/portage/categories


Finished
localhost mcmahon # emerge gnome-base/gnome-vfs gnome-base/gnome-common gnome-base/gnome-print gnome-base/gnome-libs x11-themes/gnome-themes-extras gnome-base/gnome-keyring
Calculating dependencies -!!! A file listed in the Manifest could not be found: /usr/portage/local/layman/sabayon/net-misc/networkmanager-openvpn/networkmanager-openvpn-0.3.3.ebuild
 \
!!! All ebuilds that could satisfy ">=sys-apps/dbus-0.94" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/dbus-1.0.2-r2 (masked by: package.mask, package.mask)
/etc/portage/package.mask:
#=media-sound/jack-audio-connection-kit-0.102.20

- sys-apps/dbus-1.0.2-r1 (masked by: package.mask, package.mask)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "dev-libs/dbus-glib-0.73" [ebuild])

localhost mcmahon # emaint --check world
Checking world for problems

'gnome-base/gnome-vfs' is not installed
'gnome-base/gnome-common' is not installed
'gnome-base/gnome-print' is not installed
'gnome-base/gnome-libs' is not installed
'x11-themes/gnome-themes-extras' is not installed
'gnome-base/gnome-keyring' is not installed
'sys-data/sabayon-version' has a category that is not listed in /etc/portage/categories


Finished
localhost mcmahon #       







What should I do?

I told sabayon not to install gnome during the installation process; and when I ran
Code: Select all
etc-update
I don't believe that I updated any of the configuration files. I'm not knowledgeable at Gentoo, but I'm ready to learn!

PostPosted: Thu Aug 16, 2007 1:04
by wolfden
3.26?

Get the latest version. 3.26 is going to be a very difficult to update period cause it is so old

Good idea.

PostPosted: Thu Aug 16, 2007 1:09
by keon
That sounds like an awesome idea, but I can only use a mini cd.
When is the 3.4e mini cd scheduled to come out? I have a 3.3 mini cd but if there is a newer version coming out....
What makes the kde menu different in 3.26 than in 3.3? Is it because I am using the DVD version in 2.26?

PostPosted: Thu Aug 16, 2007 1:19
by wolfden
3.26 is just too old

3.4 mini will be out when it is out, no date has been given

Ok

PostPosted: Thu Aug 16, 2007 1:36
by keon
Ok then, thanks for the help :wink:
I'm install 3.3 mini as of right now. I'll let you guys know how it goes.