Page 1 of 4

Baselayout conflicting packages [Solved]

Posted: Tue Aug 07, 2007 1:51
by smolloy
When trying to emerge world I get the following error message,

Code: Select all

Calculating world dependencies -
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

('installed', '/', 'sys-apps/baselayout-1.13.0_alpha12', 'nomerge') pulled in by
  ('installed', '/', 'sys-apps/einit-modules-gentoo-9999-r3', 'nomerge')

('ebuild', '/', 'sys-apps/baselayout-1.12.10-r4', 'merge') pulled in by
  ('ebuild', '/', 'sys-fs/udev-114', 'merge')
  ('installed', '/', 'sys-apps/module-init-tools-3.2.2-r3', 'nomerge')
It looks like two different versions of baselayout are being pulled in by other packages. How should I go about getting around this problem? Should I unmerge one of the offending packages (and, if so, which one)? Or can this be solved with package.mask? Should I just unmerge einit-modules-gentoo?

Thanks for your help.

Posted: Tue Aug 07, 2007 3:27
by smolloy

With a couple of hours of posting a problem on this forum, I manage to figure it out myself. Again! :D

I had a look at the output of "emerge -ptvuDN --world", and started emerging packages one by one. About half way through this process, I decided to try the emerge world again. This time it gave a different error -- something about baselayout being masked. So I unmasked it (maybe not a very smart idea, but we'll see what happens), and now it seems to be emerging just fine!

Posted: Tue Aug 07, 2007 4:00
by WarraWarra
Unmask = fine = safe.

Not sure but "emerge --regen" might be able to fix the top error as it does the same as "emerge --sync" except it does not connect to gentoo and does not get the package list file.

You can also try "emerge -e world" as this should think the tree / something is empty and so ignore the errors.

Think dep -a or dep -w could also fix this someone that knows the correct procedure will post.

3.4e does not allow for "dep -w" not sure why yet.

Have you had a look at the wiki on top if this page or the gentoo wiki.

Posted: Tue Aug 07, 2007 4:07
by wolfden
what in the world version are you updating?

dep -w works in 3.4

Posted: Tue Aug 07, 2007 4:19
by smolloy
I redirected the output of "emerge -ptvuDN --world" to a file, and have posted it here.

Posted: Tue Aug 07, 2007 5:11
by wolfden
you still didn't say what version u are updating

when world updating you have to work with what portage is telling you and do it

Posted: Tue Aug 07, 2007 5:16
by smolloy
Sorry, I'm not sure I understand. I thought you were asking about which version of a package I was updating.

You're asking which version of Sabayon I'm updating? 3.3 x86_64

EDIT:: But just to be clear, I fixed this problem a couple of posts ago.

Posted: Tue Aug 07, 2007 5:39
by dukdukgoos
From you posted output, it almost looks like the sabayon overlay is messed up or not added. Did you try adding/synching it with layman?

Posted: Tue Aug 07, 2007 5:54
by smolloy
I emerge world and layman -S every night using this dumb little script -- click me

I noticed that the output from emerge stating which overlay packages were from changed after an update to portage a while ago.

Posted: Tue Aug 07, 2007 6:46
by smolloy
Dammit. The links I posted won't work, cos I've screwed up apache.