GUI Package Manager ~Portato~ Old Support Thread

Anything that pertains to Portage

Moderator: Moderators

Re: GUI Package Manager ~Portato~

Postby sjieke » Tue Aug 21, 2007 21:31

Hello,

I recently world updated through the command line and now I can't get portato to run anymore. If I run it from the CLI (as root) I get the following error:
Code: Select all
'gtk' should be installed, but cannot be imported. This is definitly a bug. (No module named vte)


I tried rebuilding portato and portatosourceview, rebuild vte, unmerge portato and portatosourceview. Emerge them again, but nothing helps. Revdep-rebuild also shows nothing broken. Any ideas...
sjieke
Technological Hen
 
Posts: 321
Joined: Thu Mar 01, 2007 10:46
Location: Maldegem, Belgium

Re: GUI Package Manager ~Portato~

Postby Necoro » Tue Aug 21, 2007 21:37

sjieke wrote:Hello,

I recently world updated through the command line and now I can't get portato to run anymore. If I run it from the CLI (as root) I get the following error:
Code: Select all
'gtk' should be installed, but cannot be imported. This is definitly a bug. (No module named vte)


I tried rebuilding portato and portatosourceview, rebuild vte, unmerge portato and portatosourceview. Emerge them again, but nothing helps. Revdep-rebuild also shows nothing broken. Any ideas...

"x11-libs/vte" has to be built with "python" useflag. (I am curious why the portato ebuild isn't complaining about this Oo)
User avatar
Necoro
Advanced Hen
 
Posts: 242
Joined: Mon Apr 23, 2007 22:47
Location: Munich (Germany)

Re: GUI Package Manager ~Portato~

Postby sjieke » Tue Aug 21, 2007 22:27

"x11-libs/vte" has to be built with "python" useflag. (I am curious why the portato ebuild isn't complaining about this Oo)


I rebuild vte and made sure the python useflag was enabled
Code: Select all
Calculating dependencies... done!
[ebuild   R   ] x11-libs/vte-0.16.8  USE="opengl python -debug -doc" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No]   

Then I rebuild portato but the error message stays. Could it be another package that needs rebuilding with the python useflag?
sjieke
Technological Hen
 
Posts: 321
Joined: Thu Mar 01, 2007 10:46
Location: Maldegem, Belgium

Re: GUI Package Manager ~Portato~

Postby Necoro » Tue Aug 21, 2007 23:01

Hmm ... vte-0.16.8 is masked on my system. Dunno why it is unmasked for you, but as Gentoo bug #189556 it is (also) due to python related mess. Thus I would blame this vte version ... try it with a lower one:
Code: Select all
emerge -av "<vte-0.16.8"
User avatar
Necoro
Advanced Hen
 
Posts: 242
Joined: Mon Apr 23, 2007 22:47
Location: Munich (Germany)

Re: GUI Package Manager ~Portato~

Postby Necoro » Wed Aug 22, 2007 0:58

Yes it is really related to this. Someone has unmasked this version w/o fixing the issue. I filed a bug. Please downgrade vte.
User avatar
Necoro
Advanced Hen
 
Posts: 242
Joined: Mon Apr 23, 2007 22:47
Location: Munich (Germany)

Re: GUI Package Manager ~Portato~

Postby sjieke » Thu Aug 23, 2007 17:20

Ok, that did the trick.

In /etc/portage/packages.unmask there was an entry ">x11-libs/vte-0.16.0"
I needed to remove that line and also add "=x11-libs/vte-0.16.8" to /etc/portage/packages.mask to prevent further updates
sjieke
Technological Hen
 
Posts: 321
Joined: Thu Mar 01, 2007 10:46
Location: Maldegem, Belgium

Re: GUI Package Manager ~Portato~

Postby Necoro » Thu Aug 23, 2007 20:33

Ok ... today python-2.5 has been unmasked. With python-2.5, vte-0.16.8 does work.

If you upgrade your python version, do not forget to run python-updater.
User avatar
Necoro
Advanced Hen
 
Posts: 242
Joined: Mon Apr 23, 2007 22:47
Location: Munich (Germany)

Re: GUI Package Manager ~Portato~

Postby sjieke » Thu Aug 23, 2007 20:41

Guess I like to update to much. So I updated again today and portato is broken again :roll:
The error this time is
Code: Select all
'gtk' should be installed, but cannot be imported. This is definitly a bug. (No module named gtk)

I guess my python bindings are broken. I tried to re-emerge pygtk but that didnt help.
The packages that got updated are
Code: Select all
Thu Aug 23 18:27:41 2007 >>> sys-devel/gcc-config-1.4.0
     Thu Aug 23 18:28:37 2007 >>> app-arch/tar-1.18-r2
     Thu Aug 23 18:29:40 2007 >>> sys-apps/parted-1.8.8
     Thu Aug 23 18:30:15 2007 >>> net-misc/rsync-2.6.9-r3
     Thu Aug 23 18:30:20 2007 >>> app-admin/eselect-emacs-1.2
     Thu Aug 23 18:30:27 2007 >>> sys-kernel/genkernel-3.4.9_pre1
     Thu Aug 23 18:32:19 2007 >>> gnome-base/orbit-2.14.8-r2
     Thu Aug 23 18:32:55 2007 >>> app-editors/vim-core-7.1.087
     Thu Aug 23 18:35:42 2007 >>> dev-lang/python-2.5.1-r2
     Thu Aug 23 18:35:51 2007 >>> media-libs/mutagen-1.12
     Thu Aug 23 18:37:13 2007 >>> app-editors/vim-7.1.087
     Thu Aug 23 18:38:01 2007 >>> gnome-extra/libgsf-1.14.5
     Thu Aug 23 18:40:04 2007 >>> kde-base/kpdf-3.5.7-r2
     Thu Aug 23 18:40:57 2007 >>> net-misc/networkmanager-0.6.5_p20070823
     Thu Aug 23 18:43:27 2007 >>> media-gfx/sane-backends-1.0.18-r4
     Thu Aug 23 18:45:24 2007 >>> app-cdr/k9copy-1.1.3
     Thu Aug 23 18:46:56 2007 >>> media-gfx/f-spot-0.4.0
     Thu Aug 23 18:47:19 2007 >>> sys-fs/udev-114-r2
     Thu Aug 23 18:47:41 2007 >>> sys-fs/multipath-tools-0.4.7-r2                                                                                           

Then (after my diner) I did a revdep-rebuild. This pulled in the following packages
Code: Select all
Thu Aug 23 20:30:13 2007 >>> dev-python/pyparted-1.7.0
     Thu Aug 23 20:30:46 2007 >>> dev-java/swt-3.3
     Thu Aug 23 20:31:30 2007 >>> sys-block/gparted-0.3.3
     Thu Aug 23 20:33:08 2007 >>> sys-apps/hal-0.5.9.1-r7                                                                                                   


Maybe also important is that etc-proposals also failes to start the gui, the messages from there are
Code: Select all
qt4 frontend failed to start: Could not find qt4-bindings.
gtk2 frontend failed to start: Could not find gtk-bindings.


Maybe someone has an idea which upgrade broke it, because I fail to find the reason and a solution

Lucky for me that I know how to use the CLI... :mrgreen:

Thx
sjieke
Technological Hen
 
Posts: 321
Joined: Thu Mar 01, 2007 10:46
Location: Maldegem, Belgium

Re: GUI Package Manager ~Portato~

Postby Necoro » Thu Aug 23, 2007 21:56

What did you update? - If you updated python: run python-updater as I wrote above ...

edit:/ Yes - you updated it ... after python-updater has finished, it should work fine
User avatar
Necoro
Advanced Hen
 
Posts: 242
Joined: Mon Apr 23, 2007 22:47
Location: Munich (Germany)

Re: GUI Package Manager ~Portato~

Postby wadpro » Fri Aug 24, 2007 14:48

Necoro wrote:
wadpro wrote:
Necoro wrote:Which version do you run?


i dunno. is there any way install the latest version of portato? i tried the command "emerge portato" and portato installed to my computer but as i said before it doesnt work.

by the way, i use 3.4e version of sabayon.


do "layman -S && emerge --sync && emerge -uav portato" to get the last version (should be 0.8.1 for you) ... anyway - could you just open a terminal and run "portato" as root and possibly pasting an error message?


I did what you said and portato packeges were uptadet. However I cant still run portato! :x
I click on its icon and enter my pass but nothing happens.
wadpro
Baby Hen
 
Posts: 15
Joined: Mon Aug 20, 2007 17:58

PreviousNext

Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest