Page 1 of 2

Emerge broken

Posted: Mon Jun 24, 2019 21:14
by Omnomnom9
Hi,

it seems that my emerge is somewhat broken.

if I try "emerge --oneshot portage" I get the following error:

Code: Select all

emerge --oneshot portage

 * IMPORTANT: 24 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!
[ebuild     U  ] dev-python/setuptools-41.0.1 [41.0.0] PYTHON_TARGETS="python3_5* -python3_6*" 
[ebuild     U  ] dev-python/certifi-2018.11.29 [2018.8.24] PYTHON_TARGETS="python3_5* -python3_6*" 
[ebuild   R    ] dev-python/pyblake2-1.1.2  PYTHON_TARGETS="python3_5* -python3_6*" 
[ebuild   R    ] app-portage/gemato-14.1  PYTHON_TARGETS="python3_5* -python3_6*" 
[ebuild     U  ] sys-apps/portage-2.3.67 [2.3.62] PYTHON_TARGETS="python3_5* -python3_6*" 

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/setuptools:0

  (dev-python/setuptools-41.0.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/setuptools-34[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (app-portage/gemato-14.1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                    
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pyblake2-1.1.2:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                         
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/certifi-2018.11.29:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                             
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (app-portage/gemato-14.1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                               

  (dev-python/setuptools-41.0.0:0/0::gentoo, installed) pulled in by
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/certifi-2018.8.24:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
    dev-python/setuptools[python_targets_python3_5(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-util/meson-0.50.1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                      
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (sys-apps/file-5.36:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                         

dev-python/certifi:0

  (dev-python/certifi-2018.11.29:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/certifi-2016.9.26[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/setuptools-41.0.1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     

  (dev-python/certifi-2018.8.24:0/0::gentoo, installed) pulled in by
    >=dev-python/certifi-2016.9.26[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,python_targets_python3_7(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/setuptools-41.0.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- net-im/discord-bin-0.0.9::gentoo (masked by: all-rights-reserved license(s))
A copy of the 'all-rights-reserved' license is located at '/usr/portage/licenses/all-rights-reserved'.

- x11-themes/sabayon-artwork-grub-14-r1::sabayon-distro (masked by: CCPL-Attribution-ShareAlike-3.0 license(s))
- app-arch/p7zip-16.02-r4::gentoo (masked by: unRAR license(s))
A copy of the 'unRAR' license is located at '/usr/portage/licenses/unRAR'.

- x11-drivers/nvidia-userspace-430.14::sabayon-distro (masked by: NVIDIA-r2 license(s))
A copy of the 'NVIDIA-r2' license is located at '/usr/portage/licenses/NVIDIA-r2'.

- sys-devel/binutils-2.29.1-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <[email protected]>, Andreas K. Hüttel <[email protected]>,
# Matthias Maier <[email protected]> (21 May 2017 and later updates)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

- x11-themes/iottinka-artwork-1.0-r1::sabayon (masked by: as-is license(s))
- app-crypt/shim-signed-0.2::sabayon (masked by: as-is license(s))
- media-sound/spotify-1.1.5-r1::gentoo (masked by: Spotify license(s))
A copy of the 'Spotify' license is located at '/usr/portage/licenses/Spotify'.

- dev-lang/python-3.6.6::gentoo (masked by: package.mask)
/etc/portage/package.mask/00-sabayon.package.mask:
# Temp mask

- sys-kernel/linux-firmware-20190502::gentoo (masked by: linux-firmware no-source-code license(s))
A copy of the 'linux-firmware' license is located at '/usr/portage/licenses/linux-firmware'.

A copy of the 'no-source-code' license is located at '/usr/portage/licenses/no-source-code'.

- sys-apps/hbaapi-2.2::sabayon (masked by: as-is license(s))
- x11-themes/sabayon-artwork-plymouth-default-17::sabayon-distro (masked by: CCPL-Attribution-ShareAlike-3.0 license(s))
- sys-firmware/bluez-firmware-1.2::gentoo (masked by: as-is license(s))
- app-arch/unrar-5.7.4::gentoo (masked by: unRAR license(s))
- x11-themes/sabayon-artwork-wallpapers-18.04::sabayon-distro (masked by: CCPL-Attribution-ShareAlike-3.0 license(s))
- media-sound/teamspeak-client-3.2.5::gentoo (masked by: teamspeak3 || ( ) license(s))
A copy of the 'teamspeak3' license is located at '/usr/portage/licenses/teamspeak3'.

- x11-themes/sabayon-artwork-plymouth-base-14::sabayon-distro (masked by: CCPL-Attribution-ShareAlike-3.0 license(s))
- games-util/steam-launcher-1.0.0.56::steam-overlay (masked by: ValveSteamLicense license(s))
- x11-themes/sabayon-artwork-extra-13::sabayon-distro (masked by: CCPL-Attribution-ShareAlike-3.0 license(s))
- app-dicts/aspell-nl-0.50.2::gentoo (masked by: freedist license(s))
A copy of the 'freedist' license is located at '/usr/portage/licenses/freedist'.

- x11-themes/sabayon-artwork-isolinux-14-r1::sabayon-distro (masked by: CCPL-Attribution-ShareAlike-3.0 license(s))
- sys-boot/plymouth-0.9.4-r1::sabayon-distro (masked by: package.mask)
/etc/portage/package.mask/00-sabayon.package.mask:
# 2014-08-02 Fabio Erculiani: plymouth 0.9.0 simply does not work

- x11-themes/sabayon-artwork-cursor-14::sabayon-distro (masked by: CCPL-Attribution-ShareAlike-3.0 license(s))
- sys-firmware/ipw2200-firmware-3.1::gentoo (masked by: ipw2200-fw license(s))
A copy of the 'ipw2200-fw' license is located at '/usr/portage/licenses/ipw2200-fw'.

- sys-firmware/ipw2100-firmware-1.3::gentoo (masked by: ipw2100-fw license(s))
A copy of the 'ipw2100-fw' license is located at '/usr/portage/licenses/ipw2100-fw'.

- x11-themes/sabayon-artwork-core-14-r2::sabayon-distro (masked by: CCPL-Attribution-ShareAlike-3.0 license(s))
- sys-kernel/linux-sabayon-4.17.2::sabayon-distro (masked by: linux-firmware license(s))
- x11-drivers/nvidia-drivers-430.14::sabayon-distro (masked by: NVIDIA-r2 license(s))
- sys-devel/binutils-2.30-r4::gentoo (masked by: package.mask)
- dev-libs/libx86emu-1.1::gentoo (masked by: as-is license(s))
- sys-kernel/linux-sabayon-4.20.17::sabayon-distro (masked by: linux-firmware license(s))
- x11-themes/sabayon-artwork-sddm-default-15-r2::sabayon-distro (masked by: CCPL-Attribution-ShareAlike-3.0 license(s))
- media-fonts/corefonts-1-r7::gentoo (masked by: MSttfEULA license(s))
A copy of the 'MSttfEULA' license is located at '/usr/portage/licenses/MSttfEULA'.

- dev-util/nvidia-cuda-sdk-9.2.88::gentoo (masked by: CUDPP license(s))
A copy of the 'CUDPP' license is located at '/usr/portage/licenses/CUDPP'.

- media-libs/faac-1.29.9.2::gentoo (masked by: MPEG-4 license(s))
A copy of the 'MPEG-4' license is located at '/usr/portage/licenses/MPEG-4'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Re: Emerge broken

Posted: Tue Jun 25, 2019 13:07
by Alexander88207
Hello Omnomnom9,

You dont need to update portage with "emerge --oneshot portage". Portage get updates by Entropy
Image

Re: Emerge broken

Posted: Tue Jun 25, 2019 15:22
by joost
I think your problem is this:

https://github.com/Sabayon/build/commit ... 0db78f95d6

See https://www.gentoo.org/support/news-ite ... cense.html

Besides that, mixing Entropy and Portage is not supported.

Re: Emerge broken

Posted: Sat Sep 07, 2019 6:00
by Omnomnom9
Hi,

I tried to add that line to make.conf, but get the following error: "/etc/portage/make.conf", line 58: Invalid token 'ACCEPT_LICENSE' (not '=')

Thanks

Re: Emerge broken

Posted: Sat Sep 07, 2019 10:36
by sabayonino
ACCEPT_LICENSE="* [email protected]"

Re: Emerge broken

Posted: Sat Sep 07, 2019 13:13
by Omnomnom9
Still the same error.

Code: Select all

GENTOO_MIRRORS="ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ rsync://gentoo.bloodhost.ru/gentoo-distfiles ftp://gentoo.mirrors.tds.net/gentoo ftp://ftp.halifax.rwth-aachen.de/gentoo/ rsync://mirror.neolabs.kz/gentoo http://ftp.gentoo.bg/ http://ftp.cc.uoc.gr/mirrors/linux/gentoo/ ftp://ftp.cc.uoc.gr/mirrors/linux/gentoo/ ftp://mirrors.tera-byte.com/pub/gentoo" +
ACCEPT_LICENSE="* [email protected]"
USE_PYTHON="2.7"

Re: Emerge broken

Posted: Sat Sep 07, 2019 16:37
by sabayonino
EULA licenses are disable ([email protected]) and are required from some packages

You can ACCEPT all licenses

Code: Select all

ACCEPT_LICENSE="*"

Re: Emerge broken

Posted: Sat Sep 07, 2019 17:26
by Omnomnom9

Code: Select all

APACHE2_MPMS="prefork"
GENTOO_MIRRORS="ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ rsync://gentoo.bloodhost.ru/gentoo-distfiles ftp://gentoo.mirrors.tds.net/gentoo ftp://ftp.halifax.rwth-aachen.de/gentoo/ rsync://mirror.neolabs.kz/gentoo http://ftp.gentoo.bg/ http://ftp.cc.uoc.gr/mirrors/linux/gentoo/ ftp://ftp.cc.uoc.gr/mirrors/linux/gentoo/ ftp://mirrors.tera-byte.com/pub/gentoo" + ACCEPT_LICENSE="*"


USE_PYTHON="2.7"
same error

Re: Emerge broken

Posted: Sat Sep 07, 2019 17:34
by sabayonino
please , check the correct syntax in the /etc/portage/make.conf

You have an syntax error at the end of the GENTOO_MIRRORS line (same here.)
1 parameter/variable per line "not +" must be included (+ syntax means diff syntax)

Code: Select all

GENTOO_MIRRORS="ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ rsync://gentoo.bloodhost.ru/gentoo-distfiles ftp://gentoo.mirrors.tds.net/gentoo ftp://ftp.halifax.rwth-aachen.de/gentoo/ rsync://mirror.neolabs.kz/gentoo http://ftp.gentoo.bg/ http://ftp.cc.uoc.gr/mirrors/linux/gentoo/ ftp://ftp.cc.uoc.gr/mirrors/linux/gentoo/ ftp://mirrors.tera-byte.com/pub/gentoo" 


ACCEPT_LICENSE="*"

see https://wiki.gentoo.org/wiki//etc/portage/make.conf

but why do you want to update portage ?
Portage should be update by entropy for newbies that don't know how portage works (and not for only portage)

Re: Emerge broken

Posted: Sat Sep 07, 2019 18:37
by Omnomnom9
I just need it for the newest version of firefox which isn't available through limbo at the moment.