Emerge broken

Anything that pertains to Portage

Moderator: Moderators

User avatar
sabayonino
Sagely Hen
Posts: 3389
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Emerge broken

Post by sabayonino » Sat Sep 07, 2019 19:03

No need to update portage !

Pay attention : New firefox need dev-lang/rust update .
It takes very long time to compile...

Code: Select all

# emerge firefox 
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/nspr-4.22 [4.21]
[ebuild  N     ] media-libs/dav1d-0.4.0  USE="10bit 8bit asm" ABI_X86="32 (64) (-x32)" 
[ebuild     U  ] dev-lang/rust-1.37.0 [1.34.2]
[ebuild  N     ] media-libs/libaom-1.0.0-r2  USE="-doc -examples" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="mmx sse sse2 -avx -avx2 -sse3 -sse4_1 -ssse3" 
[ebuild     U  ] virtual/cargo-1.37.0 [1.34.2]
[ebuild     U  ] virtual/rust-1.37.0 [1.34.2]
[ebuild     U  ] www-client/firefox-69.0 [68.0.2] USE="system-av1*" L10N="it*" 
or try firefox-bin

Code: Select all

# emerge firefox-bin
[ebuild  N     ] www-client/firefox-bin-69.0  USE="ffmpeg pulseaudio startup-notification (-selinux)" L10N="it -ach -af -an -ar -ast -az -be -bg -bn -br -bs -ca -cak -cs -cy -da -de -dsb -el -en-CA -en-GB -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fy -ga -gd -gl -gn -gu -he -hi -hr -hsb -hu -hy -ia -id -is -ja -ka -kab -kk -km -kn -ko -lij -lt -lv -mk -mr -ms -my -nb -nl -nn -oc -pa -pl -pt-BR -pt-PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv -ta -te -th -tr -uk -ur -uz -vi -xh -zh-CN -zh-TW" 

Omnomnom9
Young Hen
Posts: 28
Joined: Sun Oct 23, 2016 20:54

Re: Emerge broken

Post by Omnomnom9 » Sat Sep 07, 2019 20:30

Installed the firefox-bin, but now I have 2 version firefox and firefox (bin). So, do I have to either compile the version or wait for firefox to be in the limbo / weekly repo?

Stupot
Sagely Hen
Posts: 1745
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Emerge broken

Post by Stupot » Mon Sep 09, 2019 20:13


Post Reply