libav upgrade

Anything that pertains to Portage

Moderator: Moderators

libav upgrade

Postby rdnetto » Tue Mar 17, 2015 16:35

Hi,
So as of 3 days ago, mplayer2 was marked for removal. Mpv is the replacement for it, but only the newer versions (0.8) support being used with Smplayer (the version in entropy is 0.3). Unfortunately, the newer versions of mpv require libav 10, and upgrading from libav 9 is painful.
I've added libav 10+ to package.keywords, but I'm not able to get it to install.

Code: Select all
$ sudo emerge -av  \=media-video/smplayer-14.9.0.6690-r1 \=media-video/libav-10.5 \=media-video/vlc-2.2.0_rc2
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] media-video/libav-10.5:0/10 [9.17:0/9] USE="X aac alsa amr bzip2 cpudetection encode faac gpl gsm hardcoded-tables ieee1394 jack jpeg2k mp3 network openssl pulseaudio rtmp sdl speex ssl theora threads truetype v4l vaapi vdpau vorbis vpx x264 xvid zlib (-altivec) -cdio -custom-cflags -debug -doc -fdk -frei0r (-neon) -opus -oss -pic -schroedinger -static-libs {-test} -tools (-vis) -wavpack% -webp% (-3dnow%) (-3dnowext%) (-avx%) (-bindist%) (-mmx%*) (-mmxext%) (-ssse3%)" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="3dnow%* 3dnowext%* mmx%* mmxext%* -avx% -avx2% -ssse3%" 4,542 KiB
[ebuild     U  ] media-video/mpv-0.8.2 [0.3.11-r1] USE="X alsa bluray cli%* dvb dvd enca encode iconv jack joystick jpeg lcms libass libav mpg123 openal opengl pulseaudio sdl v4l xinerama xscreensaver xv -bs2b -cdio* -doc-pdf -dvdnav -egl% -ladspa -libcaca -libguess -libmpv% -lirc -lua -luajit -oss -pvr -samba (-selinux) -vaapi -vdpau -vf-dlopen -wayland (-portaudio%) (-postproc%*) (-quvi%*) (-radio%) (-shm%*) (-vcd%)" 2,696 KiB
[ebuild   R    ] media-video/vlc-2.2.0_rc2:0/5-7::sabayon  USE="X a52 aalib alsa avahi avcodec avformat bidi bluray cdda cddb dbus dts dvb dvbpsi dvd encode ffmpeg flac fontconfig gcrypt gnutls httpd ieee1394 jack jpeg libass libav libnotify live lua matroska mp3 mpeg musepack ncurses ogg opengl png postproc pulseaudio qt4 rtsp samba sdl skins speex swscale taglib theora truetype udev upnp v4l vaapi vlm vorbis x264 x265 xcb xml xv (-altivec) -atmo (-audioqueue) -chromaprint -dc1394 -debug -directfb (-directx) (-dxva2) -faad -fdk -fluidsynth -gme -gnome -growl -kate -kde -libcaca -libsamplerate -libtar -libtiger -linsys -lirc (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-media-library) -modplug -mtp (-neon) -omxil -opencv -optimisememory -opus -projectm -qt5 -rdp -run-as-root -schroedinger -sdl-image -sftp -shout -sid -svg {-test} -tremor -twolame -vcdx -vdpau -vnc -vpx -wma-fixed -zvbi" CPU_FLAGS_X86="mmx sse" 20,334 KiB
[ebuild  N     ] media-video/smplayer-14.9.0.6690-r1  USE="bidi qt4 -autoshutdown -debug -qt5 -streaming" LINGUAS="ar bg ca cs da de en_GB en_US es et eu fi fr gl hr hu it ja ko lt mk nl pl pt pt_BR sk sr sv tr zh_CN zh_TW -ar_SY -el_GR -he_IL -ka -ku -ms_MY -ro_RO -ru_RU -sl_SI -sq_AL -th -uk_UA -vi_VN" 3,724 KiB

Total: 4 packages (2 upgrades, 1 new, 1 reinstall), Size of downloads: 31,295 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-video/libav:0

  (media-video/libav-10.5:0/10::gentoo, ebuild scheduled for merge) pulled in by
    =media-video/libav-10.5 (Argument)
    >=media-video/libav-10:0=[encode?,threads,vaapi?,vdpau?] required by (media-video/mpv-0.8.2:0/0::gentoo, ebuild scheduled for merge)
    ^^                  ^^^^^                                                                                                                                                                                     

  (media-video/libav-9.17:0/9::gentoo, installed) pulled in by
    <media-video/libav-10:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r3:0.10/0.10::gentoo, installed)
    ^                  ^^^^^                                                                                                                                                                                                                                                                                                                                         
    >=media-video/libav-9.12:0/9=[abi_x86_32(-),abi_x86_64(-)] required by (media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r3:0.10/0.10::gentoo, installed)
                            ^^^^^                                                                                                                                                               
    (and 4 more with the same problems)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


I've tried with --backtrack, --deep, etc. but nothing seems to resolve it. Masking libav 9 doesn't help either.

gst-plugins-ffmpeg is pulled in by gst-plugins-meta, which is installed in the 0.10 and 1.0 slots. Both of these are needed (0.10 for Clementine, 1.0 for everything else).

Does anyone have any idea how to fix/workaround this?
rdnetto
Young Hen
 
Posts: 27
Joined: Sun Jun 23, 2013 10:06


Re: libav upgrade

Postby rdnetto » Wed Mar 18, 2015 8:26

Thanks, that was exactly what I needed to know. Looks like I'll just need to patch Clementine to use Gstreamer 1.0.
rdnetto
Young Hen
 
Posts: 27
Joined: Sun Jun 23, 2013 10:06

Re: libav upgrade

Postby rdnetto » Wed Mar 18, 2015 16:10

For the benefit of anyone else who runs into this problem, you can workaround it by emerging the master branch of Clementine (pending [url=this patch]https://bugs.gentoo.org/show_bug.cgi?id=543692[/url]), and uninstalling gst-plugins-ffmpeg.
rdnetto
Young Hen
 
Posts: 27
Joined: Sun Jun 23, 2013 10:06


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest