Installing wine old stable

Anything that pertains to Portage

Moderator: Moderators

Installing wine old stable

Postby xpto » Tue Aug 06, 2013 20:28

Hello,
How can i install these package https://packages.sabayon.org/show/wine, ... 5,standard ?
'emerge --search wine' finds wine version 1.7.0
I tried emerge app-emulation/wine-1.4.1 but it doesn't find it.
I'm using entropy as package manager.
I installed deps after emerge --pretend wine.
I installed murmur using portage before.

The main reason i want to install these wine version its I have one problem with wine-1.4.1 manually build:
I cant install GTA SA, though I have used wine-1.4.1 on PlayOnLinux and its ok. Also, I have used wine-1.4.1 on other distro and its ok.
I want stand alone wine because PlayOnLinux isn't support by wine team.
xpto
Baby Hen
 
Posts: 12
Joined: Tue Jul 09, 2013 0:52


Re: Installing wine old stable

Postby joost » Tue Aug 06, 2013 22:14

I recommend installing playonlinux. This program has some presets for games that are known to work with Wine version whatever. It grabs the snapshot version of Wine for each game to make sure it works.
joost
Sagely Hen
 
Posts: 2582
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Installing wine old stable

Postby xpto » Tue Aug 06, 2013 23:31

Thank you. Now I have wine-1.4.1 on my sabayon.

I didn't want use PlayOnLinux because its not supported my wine. I'm trying to narrow a regression and i must use wine alone.
But i installed wine-1.4.1 but it gives me a similar error. I can't install GTA SA. I don't know were is the problem - is my computer compiling it wrong, since I know GTA SA works on this wine version?
when i did ./configure:
configure: OpenCL 32-bit development files not found, OpenCL won't be supported.
configure: libhal 32-bit development files not found, no legacy dynamic device support.
configure: gstreamer-0.10 base plugins 32-bit development files not found, gstreamer support disabled
configure: OSS sound system found but too old (OSSv4 needed), OSS won't be supported.
configure: libcapi20 32-bit development files not found, ISDN won't be supported.

but i thing those things would not affect GTA SA installation.
xpto
Baby Hen
 
Posts: 12
Joined: Tue Jul 09, 2013 0:52

Remove wine old stable

Postby xpto » Sat Aug 31, 2013 12:58

I wanted to remove wine.
I did
Code: Select all
equo remove --ask wine
equo recue spmsync
equo unmask ">app-emulation/wine-1.4.1"


This is the way its suppose to do, or i should have removed with portage?

If i just wanted to upgrade wine i should only
Code: Select all
equo unmask ">app-emulation/wine-1.4.1"
equo install wine
xpto
Baby Hen
 
Posts: 12
Joined: Tue Jul 09, 2013 0:52


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest