Page 1 of 1

revdep-rebuild: failed to emerge gcc 4.6.3 [Solved]

Posted: Sun Mar 31, 2013 17:19
by sabayanus
I solved it, it was fault of memory!

Hi, i'm trying to fix the broken libraries/packeages in my system with revdep-rebuild, and I get this error message:

Code: Select all

 * Messages for package sys-devel/gcc-4.6.3:

 * LTO support is still experimental and unstable.
 * Any bugs resulting from the use of LTO will not be fixed.
 * ERROR: sys-devel/gcc-4.6.3 failed (compile phase):
 *   emake failed with bootstrap-lean
 * Call stack:
 *, line   93:  Called src_compile
 *   environment, line 4157:  Called toolchain_src_compile
 *   environment, line 4817:  Called gcc_do_make
 *   environment, line 2456:  Called die
 * The specific snippet of code:
 * If you need support, post the output of `emerge --info '=sys-devel/gcc-4.6.3'`,
 * the complete build log and the output of `emerge -pqv '=sys-devel/gcc-4.6.3'`.
 * Please include /var/tmp/portage/sys-devel/gcc-4.6.3/work/build/gcc-build-logs.tar.bz2 in your bug report
 * The complete build log is located at '/var/tmp/portage/sys-devel/gcc-4.6.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/gcc-4.6.3/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-devel/gcc-4.6.3/work/build'
 * S: '/var/tmp/portage/sys-devel/gcc-4.6.3/work/build'
 * revdep-rebuild failed to emerge all packages.
 * you have the following choices:
 * - If emerge failed during the build, fix the problems and re-run revdep-rebuild.
 * - Use /etc/portage/package.keywords to unmask a newer version of the package.
 *   (and remove 5_order.rr to be evaluated again)
 * - Modify the above emerge command and run it manually.
 * - Compile or unmerge unsatisfied packages manually,
 *   remove temporary files, and try again.
 *   (you can edit package/ebuild list first)
 * To remove temporary files, please run:
 * rm /var/cache/revdep-rebuild/*.rr
My CFLAGS: CFLAGS="-O2 -march=x86-64 -pipe -ggdb "
Does someone knows how should I procced?

revdep-rebuild: failed to emerge gcc 4.6.3, again

Posted: Sun Mar 31, 2013 20:26
by sabayanus
Here is the error I get from it:
Just for the record I have installed:
base-gcc for 4.6.3 and for 4.5.4, witch are ones equo don't let me remove.
And I have:
gcc 4.6.3
I get these errors when I execute revdep-rebuild, trying to fix libraries...