multiple issues with: sci-geosciences/qgis

Anything that pertains to Portage

Moderator: Moderators

multiple issues with: sci-geosciences/qgis

Postby qpx » Sun Dec 30, 2012 17:56

i want to emerge qgis-1.7.4 with portage on my sabayon machine.
Code: Select all
~ # cat /etc/sabayon-release
Sabayon Linux amd64 10
~ # uname -a
Linux host 3.7.0-sabayon #1 SMP Thu Dec 20 07:12:55 UTC 2012 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 5200+ AuthenticAMD GNU/Linux

but it seems version 1.7.4 has unmet dependencies:
Code: Select all
!!! The following update has been skipped due to unsatisfied dependencies:


emerge: there are no ebuilds to satisfy "<dev-python/PyQt4-4.9[X,sql,svg]".
(dependency required by "sci-geosciences/qgis-1.7.4[python]" [ebuild])

that's the first issue: where can i find dev-python/PyQt4 < 4.9 with[X,sql,svg] to install qgis-1.7.4?

and the second is that the older release version 1.7.0 fails to compile.
Code: Select all
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sci-geosciences/qgis-1.7.0  USE="grass* python*"
Code: Select all
[ 85%] Built target qgis
make: *** [all] Error 2
emake failed
 * ERROR: sci-geosciences/qgis-1.7.0 failed (compile phase):
 *   Make failed!
 * Call stack:
 *, line   93:  Called src_compile
 *   environment, line 5422:  Called cmake-utils_src_compile
 *   environment, line 1369:  Called _execute_optionaly 'src_compile'
 *   environment, line  422:  Called enable_cmake-utils_src_compile
 *   environment, line 1608:  Called cmake-utils_src_make
 *   environment, line 1394:  Called die
 * The specific snippet of code:
 *               emake VERBOSE=1 "$@" || die "Make failed!";

any ideas? i need the use flags +grass and +python. this is my aim: How to correctly install QGIS with plugins and GRASS-integration in Linux?.

any ideas?

attached logs:
emerge --info :
emerge -pqv :
build log :
environment file :
Baby Hen
Posts: 4
Joined: Sat Oct 06, 2012 20:45

Re: multiple issues with: sci-geosciences/qgis

Postby qpx » Mon Dec 31, 2012 0:36

sabayonino wrote:did you try

Code: Select all
#  emerge "<dev-python/PyQt4-4.9"



yes. there is no version lower than 4.9 in portage.

Code: Select all
~ # emerge "<dev-python/PyQt4-4.9"
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "<dev-python/PyQt4-4.9".

Baby Hen
Posts: 4
Joined: Sat Oct 06, 2012 20:45

Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest