emerge -uDn world after fresh install throws up conflicts

Anything that pertains to Portage

Moderator: Moderators

Post Reply
logicalguy
Baby Hen
Posts: 5
Joined: Fri Oct 16, 2009 10:52

emerge -uDn world after fresh install throws up conflicts

Post by logicalguy » Fri Oct 16, 2009 11:02

Hi all,
Just did a fresh install of 5-oh yesterday and it installed beautifully. First thing I did was remove entropy cuz I like gentoo and want to stick to portage. I did an

Code: Select all

emerge -uDn system
with no problems, but

Code: Select all

emerge -uDn world
throws up a whole bunch of conflicts. Looks like all the packages involved are conflicting with each other -- how bizarre!!

Code: Select all

[blocks b     ] <x11-libs/qt-sql-4.5.3 ("<x11-libs/qt-sql-4.5.3" is blocking x11-libs/qt-gui-4.5.3-r1, x11-libs/qt-opengl-4.5.3, x11-libs/qt-core-4.5.3-r1, x11-libs/qt-script-4.5.3, x11-libs/qt-dbus-4.5.3, x11-libs/qt-svg-4.5.3, x11-libs/qt-test-4.5.3, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-webkit-4.5.3)                                                    
[ebuild     U ] x11-libs/qt-script-4.5.3 [4.5.2] USE="iconv -debug -pch" 0 kB [0]                                                                                                   
[blocks b     ] <x11-libs/qt-script-4.5.3 ("<x11-libs/qt-script-4.5.3" is blocking x11-libs/qt-gui-4.5.3-r1, x11-libs/qt-opengl-4.5.3, x11-libs/qt-core-4.5.3-r1, x11-libs/qt-dbus-4.5.3, x11-libs/qt-svg-4.5.3, x11-libs/qt-test-4.5.3, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5.3)                                                 
[ebuild     U ] x11-libs/qt-test-4.5.3 [4.5.2] USE="iconv -debug -pch" 0 kB [0]                                                                                                     
[blocks b     ] <x11-libs/qt-test-4.5.3 ("<x11-libs/qt-test-4.5.3" is blocking x11-libs/qt-gui-4.5.3-r1, x11-libs/qt-opengl-4.5.3, x11-libs/qt-core-4.5.3-r1, x11-libs/qt-script-4.5.3, x11-libs/qt-dbus-4.5.3, x11-libs/qt-svg-4.5.3, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5.3)                                                   
[ebuild     U ] x11-libs/qt-dbus-4.5.3 [4.5.2] USE="-debug -pch" 0 kB [0]                                                                                                           
[blocks b     ] <x11-libs/qt-dbus-4.5.3 ("<x11-libs/qt-dbus-4.5.3" is blocking x11-libs/qt-gui-4.5.3-r1, x11-libs/qt-opengl-4.5.3, x11-libs/qt-core-4.5.3-r1, x11-libs/qt-script-4.5.3, x11-libs/qt-svg-4.5.3, x11-libs/qt-test-4.5.3, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5.3)                                                   
[ebuild     U ] x11-libs/qt-gui-4.5.3-r1 [4.5.2-r2] USE="accessibility cups dbus glib gtk mng qt3support tiff xinerama -debug -nas -nis -pch -raster" 0 kB [0]                      
[blocks b     ] <x11-libs/qt-gui-4.5.3 ("<x11-libs/qt-gui-4.5.3" is blocking x11-libs/qt-opengl-4.5.3, x11-libs/qt-core-4.5.3-r1, x11-libs/qt-script-4.5.3, x11-libs/qt-dbus-4.5.3, x11-libs/qt-svg-4.5.3, x11-libs/qt-test-4.5.3, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5.3)                                                       
[ebuild     U ] x11-libs/qt-qt3support-4.5.3 [4.5.2] USE="accessibility kde -debug -pch -phonon" 0 kB [0]                                                                           
[blocks b     ] <x11-libs/qt-qt3support-4.5.3 ("<x11-libs/qt-qt3support-4.5.3" is blocking x11-libs/qt-gui-4.5.3-r1, x11-libs/qt-opengl-4.5.3, x11-libs/qt-core-4.5.3-r1, x11-libs/qt-script-4.5.3, x11-libs/qt-dbus-4.5.3, x11-libs/qt-svg-4.5.3, x11-libs/qt-test-4.5.3, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5.3)                                             
[ebuild  N    ] dev-util/cmake-2.6.4-r3  USE="qt4 -emacs -vim-syntax" 3,209 kB [0]                                                                                                  
[ebuild     U ] x11-libs/qt-svg-4.5.3 [4.5.2] USE="iconv -debug -pch" 0 kB [0]                                                                                                      
[blocks b     ] <x11-libs/qt-svg-4.5.3 ("<x11-libs/qt-svg-4.5.3" is blocking x11-libs/qt-opengl-4.5.3, x11-libs/qt-core-4.5.3-r1, x11-libs/qt-script-4.5.3, x11-libs/qt-dbus-4.5.3, x11-libs/qt-gui-4.5.3-r1, x11-libs/qt-test-4.5.3, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5.3)                                                    
[ebuild     U ] x11-libs/qt-opengl-4.5.3 [4.5.2] USE="qt3support -debug -pch" 0 kB [0]                                                                                              
[blocks b     ] >x11-libs/qt-webkit-4.5.2-r9999 (">x11-libs/qt-webkit-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                        
[blocks b     ] <x11-libs/qt-opengl-4.5.3 ("<x11-libs/qt-opengl-4.5.3" is blocking x11-libs/qt-gui-4.5.3-r1, x11-libs/qt-core-4.5.3-r1, x11-libs/qt-script-4.5.3, x11-libs/qt-dbus-4.5.3, x11-libs/qt-svg-4.5.3, x11-libs/qt-test-4.5.3, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5.3)                                                 
[ebuild     U ] dev-libs/soprano-2.3.1 [2.3.0-r1] USE="clucene dbus raptor redland -debug -doc -java" 1,875 kB [0]                                                                  
[ebuild     U ] kde-base/oxygen-icons-4.3.2-r1 [4.3.1-r1] USE="(-kdeprefix)" 117,524 kB [1]                                                                                         
[ebuild     U ] x11-libs/qt-webkit-4.5.3 [4.5.2-r1] USE="kde -debug -pch" 0 kB [0]                                                                                                  
[blocks b     ] >x11-libs/qt-svg-4.5.2-r9999 (">x11-libs/qt-svg-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                        
[blocks b     ] >x11-libs/qt-dbus-4.5.2-r9999 (">x11-libs/qt-dbus-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                       
[blocks b     ] <x11-libs/qt-webkit-4.5.3 ("<x11-libs/qt-webkit-4.5.3" is blocking x11-libs/qt-gui-4.5.3-r1, x11-libs/qt-opengl-4.5.3, x11-libs/qt-core-4.5.3-r1, x11-libs/qt-script-4.5.3, x11-libs/qt-dbus-4.5.3, x11-libs/qt-svg-4.5.3, x11-libs/qt-test-4.5.3, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-sql-4.5.3)                                                 
[blocks b     ] >x11-libs/qt-core-4.5.2-r9999 (">x11-libs/qt-core-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-sql-4.5.2)                                       
[blocks b     ] >x11-libs/qt-sql-4.5.2-r9999 (">x11-libs/qt-sql-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2)                                        
[blocks b     ] >x11-libs/qt-opengl-4.5.2-r9999 (">x11-libs/qt-opengl-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                     
[blocks b     ] >x11-libs/qt-test-4.5.2-r9999 (">x11-libs/qt-test-4.5.2-r9999" is blocking x11-libs/qt-opengl-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                       
[blocks b     ] >x11-libs/qt-gui-4.5.2-r9999 (">x11-libs/qt-gui-4.5.2-r9999" is blocking x11-libs/qt-opengl-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                           
[blocks b     ] >x11-libs/qt-qt3support-4.5.2-r9999 (">x11-libs/qt-qt3support-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)                                 
[blocks b     ] >x11-libs/qt-script-4.5.2-r9999 (">x11-libs/qt-script-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-opengl-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-test-4.5.2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)


Can anyone help, please??!!!!!!!

Thev00d00
Generally Awesome (tm)
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom
Contact:

Re: emerge -uDn world after fresh install throws up conflicts

Post by Thev00d00 » Fri Oct 16, 2009 11:36

If your going to use Emerge you should learn about it first. This is a pretty simple block but im not going to tell you what to do as I think you should be able to find out yourself using the various resources available to you, such as the wiki.
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me

bluecrxnc
Young Hen
Posts: 34
Joined: Tue Apr 28, 2009 18:53
Location: North Carolina, USA
Contact:

Re: emerge -uDn world after fresh install throws up conflicts

Post by bluecrxnc » Sun Oct 18, 2009 2:54

^Agreed.

Also, use the "

Code: Select all

" blocks to format that mess so it is easier to read  8)
Image -> 5.0 Gnome
Image -> 3800+ (2.01 GHz)
Image
~ Portage User ~

ajez
The Blamed One
Posts: 506
Joined: Mon Oct 16, 2006 17:17
Location: Venezia - /dev/null
Contact:

Re: emerge -uDn world after fresh install throws up conflicts

Post by ajez » Sun Oct 18, 2009 12:20

logicalguy wrote:Hi all,
Just did a fresh install of 5-oh yesterday and it installed beautifully. First thing I did was remove entropy cuz I like gentoo and want to stick to portage.
so learn to use portage :)

I learnt to use it googling and looking howtos on www.gentoo-wiki.org or forums of gentoo.org
U'll not learn if u ask US to solve YOUR problems at all :P
--
Core Beta/Site,Blog,Forum Admin
Image

obnascar
Simple Hen
Posts: 47
Joined: Fri Jul 13, 2007 4:34
Location: Memphis, Tn

Re: emerge -uDn world after fresh install throws up conflicts

Post by obnascar » Sun Oct 18, 2009 14:25

Is entropy the same thing as Sulfur or are they two separate package managers......this is confusing to me.
"I haven't lost my mind, it is backed up on disk somewhere"

ajez
The Blamed One
Posts: 506
Joined: Mon Oct 16, 2006 17:17
Location: Venezia - /dev/null
Contact:

Re: emerge -uDn world after fresh install throws up conflicts

Post by ajez » Sun Oct 18, 2009 15:22

obnascar wrote:Is entropy the same thing as Sulfur or are they two separate package managers......this is confusing to me.
entropy is the package manager (like portage)
sulfur and equo are the programs to install packages trought entropy (like emerge)
--
Core Beta/Site,Blog,Forum Admin
Image

Fitzcarraldo
Sagely Hen
Posts: 8195
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: emerge -uDn world after fresh install throws up conflicts

Post by Fitzcarraldo » Sun Oct 18, 2009 18:58

obnascar wrote:Is entropy the same thing as Sulfur or are they two separate package managers......this is confusing to me.
Have a look at the SL Wiki article Entropy and all should become clear. There are several articles in the Wiki that are essential reading in order to understand the package managers.

logicalguy
Baby Hen
Posts: 5
Joined: Fri Oct 16, 2009 10:52

Re: emerge -uDn world after fresh install throws up conflicts

Post by logicalguy » Tue Oct 20, 2009 13:43

well after poking around a bit I stumbled across this article which made me realize that my make.conf was configured to install test packages, which I don't really want. I'd rather stick with stable packages. So followed the steps in the guide and all the conflicts went away. Guess over time things will sort themselves out, as the article suggests. Here's the article:
http://wiki.sabayonlinux.org/index.php? ... e_Packages

Well, we shall see what happens now.

Still haven't figured out those cyclic blocks yet, though.

Fitzcarraldo
Sagely Hen
Posts: 8195
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: emerge -uDn world after fresh install throws up conflicts

Post by Fitzcarraldo » Tue Oct 20, 2009 16:56

Bravo for trying out the procedure in the SL Wiki article; that's the way to learn things. Regarding the blocks, apart from the SL Wiki articles on Portage have you read the sections in the Gentoo Handbook on Portage and blocks? It's all good stuff and may help to make things clearer. It definitely requires some hard work to learn the ins and outs of Portage, but it's worth it in the end. Rome wasn't built in a day, so keep plodding away at it and be prepared for things to break along the way. You'll learn a lot if you stick with it.

logicalguy
Baby Hen
Posts: 5
Joined: Fri Oct 16, 2009 10:52

Re: emerge -uDn world after fresh install throws up conflicts

Post by logicalguy » Wed Oct 21, 2009 12:36

Well lots of work still needs to be done. After following the instructions in http://wiki.sabayonlinux.org/index.php? ... e_Packages I've come up with some new issues...

I need to set up my ATI card so I decided to download the kernel sources to do so. Now because all unstable packages are masked I cannot download the sabayon-sources package because it is masked by the amd64 keyword. So now what? I guess I could unmask this package and carry on, but I don't know if that's the recommended way to do it.

Alternatively, I guess I could try and uninstall all qt packages and install it all over again, followed by a

Code: Select all

revdep-rebuild
and

Code: Select all

emerge -e
and

Code: Select all

emerge -uDn
... I don't know if it'll work. I can't think of anything else to get rid of those blocks. See, all these months I've been using gentoo the blocks I've had are simple, 1-to-1 blocks where I have to mask or uninstall one package and then it gets solved. but in the above case, its a situation where

Code: Select all

emerge world
is trying to install, say, 3 packages - A, B, and C, and A is blocked by B and C, B is blocked by C and A, and C is blocked by A and B!! I haven't a clue how to proceed in such a case. Reading about portage and use flags and masking, etc., etc. hasn't given me any hints. I've come across a 2 or 3 other posts of this same problem on googling, but nobody seems to have responded to them.

Anyway, we will see!!

Post Reply