Gnome Do

Anything that pertains to Portage

Moderator: Moderators

Gnome Do

Postby silentswarm » Sun Sep 20, 2009 0:39

this program looks amazing but i just installed sabayon yesterday and am just getting use to the gentoo i used ubuntu before. so i know a little bit about linux but not enough so try not to talk way over my head.

but when i do my emerge gnome-do gnome-do-plugins it gets stuck on this one

>>> Emerging (1 of 23) dev-lang/mono-2.4.2.3
* mono-2.4.2.3.tar.bz2 RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* Determining the location of the kernel source code
* Unable to find kernel sources at /usr/src/linux
* Please make sure that /usr/src/linux points at your running kernel,
* (or the kernel you wish to build against).
* Alternatively, set the KERNEL_DIR environment variable to the kernel sources location
* Could not find a usable .config in the kernel source directory.
* Please ensure that /usr/src/linux points to a configured set of Linux sources.
* If you are using KBUILD_OUTPUT, please set the environment var so that
* it points to the necessary object directory so that it might find .config.
*
* ERROR: dev-lang/mono-2.4.2.3 failed.
* Call stack:
* ebuild.sh, line 49: Called pkg_setup
* mono-2.4.2.3.ebuild, line 49: Called linux_chkconfig_present 'SYSVIPC'
* linux-info.eclass, line 277: Called require_configured_kernel
* linux-info.eclass, line 264: Called die
* The specific snippet of code:
* die "Kernel not configured; no .config found in ${KV_OUT_DIR}"
* The die message:
* Kernel not configured; no .config found in
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/lib/entropy/logs/dev-lang:mono-2.4.2.3:20090919-180109.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-lang/mono-2.4.2.3/temp/die.env'.
*

>>> Failed to emerge dev-lang/mono-2.4.2.3, Log file:

>>> '/var/lib/entropy/logs/dev-lang:mono-2.4.2.3:20090919-180109.log'


i thought it might have something to do with me using the kde but i wasn't sure
silentswarm
Baby Hen
 
Posts: 6
Joined: Sun Sep 20, 2009 0:09

Re: Gnome Do

Postby micia » Sun Sep 20, 2009 13:33

Can you post the output of:
Code: Select all
eselect kernel list


Keep in mind that if emerge gives you problems, you
can always use equo/sulfur.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Gnome Do

Postby silentswarm » Mon Sep 21, 2009 5:15

i did get type that code i don't have any available i did a system update right after i installed i kinda get what the equo is it a package manager i get that so how do i use it?
silentswarm
Baby Hen
 
Posts: 6
Joined: Sun Sep 20, 2009 0:09

Re: Gnome Do

Postby micia » Mon Sep 21, 2009 6:59

First of all install the kernel:

Code: Select all
uname -a


this will tell you which kernel you have installed, for example you could
get:
Code: Select all
2.6.29-sabayon


So install that version using equo:
Code: Select all
equo install --ask linux-sabayon-2.6.29

You could be propted for some config file update, in this case
follow the instructions that equo will give you.

Notice that in this example we are using the 2.6.29 version as an example,
you could have a different kernel.
Now run the:
Code: Select all
eselect kernel list

again.

You could get something like:
Code: Select all
eselect kernel list
Available kernel symlink targets:
  [1]   linux-2.6.29-sabayon


As you can see, 1 corresponds to the kernel that we want as the current
one, so select it:
Code: Select all
eselect kernel set 1


now eselect kernel list should look like:
Code: Select all
eselect kernel list
Available kernel symlink targets:
  [1]   linux-2.6.29-sabayon *


Now you can use emerge -av gnome-do without any problem, I think.


It is a little too long to explain how to use equo/sulfur, but there is a
wiki page that explains it, so take a look:
http://wiki.sabayonlinux.org/index.php?title=Entropy
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Gnome Do

Postby wolfden » Mon Sep 21, 2009 8:05

moved topic to correct forum, please post in the correct forums
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Gnome Do

Postby silentswarm » Mon Sep 21, 2009 19:29

k did all that you said and this is what i got.

[email protected] ~ $ uname -a
Linux netbook 2.6.29-sabayon #1 SMP Thu Jun 11 13:49:49 UTC 2009 i686 Intel(R) Atom(TM) CPU N280 @ 1.66GHz GenuineIntel GNU/Linux
[email protected] ~ $ equo install --ask linux-sabayon-2.6.29
>> Repository sabayonlinux.org hasn't been downloaded yet.
>> Repository sabayonlinux.org is not available. Cannot validate
>> !!! Please update your repositories now in order to remove this message!
>> Running with --pretend ...
>> !!! No match for linux-sabayon-2.6.29 in repositories.
>> No packages found.
>> @@ Caching complete.
[email protected] ~ $ eselect kernel list
Available kernel symlink targets:
(none found)
[email protected] ~ $ eselect kernel set 1
!!! Error: Target "1" doesn't appear to be valid!
Killed
[email protected] ~ $


for some reason i have no idea why when i go to my Repositories it shows it downloading the sabayon.org but then it comes up with this Repositories synchronization ...
[svn.sabayonlinux.org:1026] Successfully connected to host
[svn.sabayonlinux.org:1026] Successfully disconnected from host
(1/1) Sabayon Linux Official Repository
Database URL: http://svn.sabayonlinux.org/entropy/sta ... base/x86/4
Database local path: /var/lib/entropy/client/database/x86/sabayonlinux.org/standard/x86/4
Database EAPI: 3
Downloading repository database ...
Attention: database does not exist online.
Repository sabayonlinux.org hasn't been downloaded yet.
Repository sabayonlinux.org is not available. Cannot validate
Please update your repositories now in order to remove this message!


what ever i do i can't seem to update the repository it just stops in the middle of downloading
silentswarm
Baby Hen
 
Posts: 6
Joined: Sun Sep 20, 2009 0:09

Re: Gnome Do

Postby micia » Mon Sep 21, 2009 20:22

That is pretty strange, try to update repositories using:
Code: Select all
equo update --force


if it still complains try to reinstall entropy using emerge:
Code: Select all
layman --sync sabayon
emerge -av entropy sulfur


then try again:
Code: Select all
equo update --force


if you succeed reinstall the kernel, as above.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Gnome Do

Postby silentswarm » Mon Sep 21, 2009 22:08

uh no luck what is wrong?

got this when i tried to force update

[email protected] ~ $ equo update --force
>> Repository sabayonlinux.org hasn't been downloaded yet.
>> Repository sabayonlinux.org is not available. Cannot validate
>> !!! Please update your repositories now in order to remove this message!
>> @@ Repositories synchronization ...
>> [svn.sabayonlinux.org:1026] Successfully connected to host
>> [svn.sabayonlinux.org:1026] Successfully disconnected from host
>> # (1/1) Sabayon Linux Official Repository
>> # Database URL: http://svn.sabayonlinux.org/entropy/sta ... base/x86/4
>> # Database local path: /var/lib/entropy/client/database/x86/sabayonlinux.org/standard/x86/4
>> # Database EAPI: 3
>> Downloading repository database ...
>> Attention: database does not exist online.
>> Repository sabayonlinux.org hasn't been downloaded yet.
>> Repository sabayonlinux.org is not available. Cannot validate
>> !!! Please update your repositories now in order to remove this message!
[email protected]

then this

[email protected] ~ $ layman --sync sabayon
* Failed to update the overlay list from: http://www.gentoo.org/proj/en/overlays/ ... global.txt
* Error was:
* Failed to temporarily cache overlays list in /usr/local/portage/layman/cache_65bd38402ac8431067b54904bd2ed2d1.xml
* Error was:
* [Errno 13] Permission denied: '/usr/local/portage/layman/cache_65bd38402ac8431067b54904bd2ed2d1.xml'
* Running command "cd "/usr/local/portage/layman/sabayon" && /usr/bin/git pull"...
error: cannot open .git/FETCH_HEAD: Permission denied

*
* Errors:
* ------
*
* Failed to sync overlay "sabayon".
* Error was: Syncing overlay "sabayon" returned status 256!
silentswarm
Baby Hen
 
Posts: 6
Joined: Sun Sep 20, 2009 0:09

Re: Gnome Do

Postby micia » Mon Sep 21, 2009 22:14

You should use equo and emerge as root when updating repositories
or installing, sorry for not specifying that... :oops:

[EDIT] and eselect too.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Gnome Do

Postby silentswarm » Mon Sep 21, 2009 23:18

i did the above and it worked untill

netbook jeff # equo update --force
Traceback (most recent call last):
File "/usr/bin/equo", line 33, in <module>
from entropy.core import SystemSettings
ImportError: cannot import name SystemSettings



i need this because i can't seem to install anything and it is really cramping my style i haven't really done much and installed it only a few days ago so i am not sure whats going on.
silentswarm
Baby Hen
 
Posts: 6
Joined: Sun Sep 20, 2009 0:09

Next

Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: Stupot and 2 guests