Traceback problem? Python problem? [Solved]

Anything that pertains to Portage

Moderator: Moderators

Post Reply
Simple Hen
Posts: 92
Joined: Sun Mar 16, 2008 5:51

Traceback problem? Python problem? [Solved]

Post by tman7510 » Thu Jun 04, 2009 21:12

I'm not sure this is in the write section of the forum but I'm thinking it has something to do with python. I checked on my python version 2.5 but I have 2.6 emerged from some updated package I guess. Anyhow, here are some of the errors I'm getting and after googling the errors I'm guessing my python version has to be updated?
raceback (most recent call last):
File "/usr/bin/ccsm", line 30, in <module>
import pygtk
ImportError: No module named pygtk
pygtk has been emerged

Traceback (most recent call last):
File "/usr/lib/entropy/spritz/", line 34, in <module>
from entropyConstants import *
ImportError: No module named entropyConstants
sprits is installed

Traceback (most recent call last):
File "/usr/bin/portato", line 94, in <module>
File "/usr/bin/portato", line 49, in main
from portato.gui import run
File "/usr/lib/python2.6/site-packages/portato/gui/", line 16, in <module>
from .exception_handling import register_ex_handler
File "/usr/lib/python2.6/site-packages/portato/gui/", line 16, in <module>
import gtk, pango, gobject
ImportError: No module named gtk
Error in atexit._run_exitfuncs:
Traceback (most recent call last):
File "/usr/lib/python2.6/", line 24, in _run_exitfuncs
func(*targs, **kargs)
File "/usr/lib/python2.6/site-packages/portato/", line 134, in close
if self._sig is not None:
AttributeError: 'PListener' object has no attribute '_sig'
Error in sys.exitfunc:
Traceback (most recent call last):
File "/usr/lib/python2.6/", line 24, in _run_exitfuncs
func(*targs, **kargs)
File "/usr/lib/python2.6/site-packages/portato/", line 134, in close
if self._sig is not None:
AttributeError: 'PListener' object has no attribute '_sig

portato has been re emerged. I hear python 2.6 is unstable and not to try a pythonupdate but how else can I fix these errors.
Last edited by tman7510 on Fri Jun 05, 2009 20:17, edited 1 time in total.

Old Dear Hen
Posts: 477
Joined: Sun Mar 15, 2009 10:35
Location: Back in the 'swamp land' Moe, Australia 38°10′20″S 146°16′04″E

Re: Traceback problem? Python problem?

Post by joeoden » Thu Jun 04, 2009 22:42

tman7510 wrote:File "/usr/lib/entropy/spritz/", line 34, in <module>
I'm not sure if this is your problem, spritz has been renamed to sulfur

I still have heaps to learn, but having fun
Desktop ASUS M2N-MX SE Plus, AMD 64 X2 Dual Core 5200, 4 Gb RAM, GeForce 9500 1GB
Notebook HP CQ61-311AX, AMD CPU M320, 4 Gb RAM, Radeon HD 4300 512 MB
Wireless AR9285, Audio ATI SBx00 (IDT 92hd75B2x5)
Some mistakes are too much fun to only make once!

User avatar
Advanced Hen
Posts: 242
Joined: Mon Apr 23, 2007 22:47
Location: Munich (Germany)

Re: Traceback problem? Python problem?

Post by Necoro » Thu Jun 04, 2009 23:55

You forgot to run python-updater

Do not be fooled by python being slotted - though it is possible to run different python-versions, it is not possible to have all the python packages installed for both versions.

So you either stick with python-2.5 and get rid of 2.6 - or you move on to 2.6 and get rid of 2.5... For both ways you need to reinstall the packages you installed with the "wrong" python version.

Simple Hen
Posts: 92
Joined: Sun Mar 16, 2008 5:51

Re: Traceback problem? Python problem?

Post by tman7510 » Fri Jun 05, 2009 20:16

Problem Solved. I had to set my config back to 2.5 and then remerge the packages. I figured python was the problem but I did'nt know how to change python versions without pythonupdater. So I did some my research and just used eselect before remerging a few packages and that fixed it. :)

Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Traceback problem? Python problem? [Solved]

Post by wolfden » Fri Jun 05, 2009 20:37

fixed title to [Solved], not [SOLVED] as per

Baby Hen
Posts: 1
Joined: Sat Jun 06, 2009 2:58

Re: Traceback problem? Python problem? [Solved] OR NOT

Post by csm_walkabout » Sat Jun 06, 2009 3:13

I got this problem by updating entrophy as recommended - now I have:

sabayon-doc chris # spritz
Traceback (most recent call last):
File "/usr/lib/entropy/spritz/", line 33, in <module>
from entropyConstants import *
ImportError: No module named entropyConstants
sabayon-doc chris #

delightfully helpful comment each time I try to run spritz.

Emerge doesn't work
rev-rebuild fails...
I'm i going down in a screaming heap - YES - I install 4.1 sabayon for something modern but it fails to update itself!!!!!!!!!!!!!!!


Sagely Hen
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: Traceback problem? Python problem? [Solved]

Post by WarraWarra » Sat Jun 06, 2009 10:48

LOL Python is like a gun if you rub it the wrong way you loose a tow or your head, know your python and it will serve you well LOL.

There is a reason why the skilled guy's said anyone should not do this but can if they want to and know what they are doing with python.

Okay as he mentioned you need to update to the version of python you want to use then python-updater and reinstall the "world" to get it to work with the new version, yes this can be fun and slow as it has to be done using emerge.

After going to 2.6 you will not be able to use equo entropy tree as it is python 2.5 so you will have to know what you are doing and fix the problems yourself using emerge / portage.
= advanced gentoo user skills needed. Python can be a nightmare for even extremely advanced gentoo users.

I did not post the complete python process doing it the right way + updated to SL ways and programs as it is not intended for anyone to use. For those that want and can hotwire the gentoo old python update guides they do not need my python update guide / they can tell me a lot of things I should know. :oops:

Back to current problem.
Yes you can recover been there done that.
You would need to browse or cd to the /var/lib/entropy/packages/x86/4/ and look for app-admin:equo-0.95.8~0.tbz2 or the equo one in /usr/portage/distfiles

You would want to tar extract the equo to the root folder so it can force it into place / replace equo files already there as your installed equo is likely linked or somethinged to python 2.6.* and does not want to work with 2.5.4-r2
I am just sucking my thumb here but think this is the cause. 2.6 anything will work in 2.5 enviroment or should and not the other way around.

Fixes worked for me when I used emerge / portage instead of equo as I had no idea how well equo will work with this process so did not try it.

Side note:
I played with pyhon as I can afford to format and start over and be back a bit later to fully working gentoo / SL with a stage3 build or SL reinstall / update.

Example of fix edit as is appropriate to your situation.

Code: Select all

tar xvfjp /var/lib/entropy/packages/x86/4/app-admin:equo-0.95.8~0.tbz2 -C /
I actually did this with portage instead of equo to get emerge to work and then installed equo using "emerge equo" to get any available copy of equo installed and then using equo that is then build against 2.5 to update and install it's newer version of equo and reinstall all / world to fix what is needed including the kernel that I up'd to py2.6 and "modules-rebuild rebuild"

Not sure how deep you python'd it. My SL gnome 4.1 with python 2.6.2 or 2.5.4 worked fine just more effort on 2.6 and source compiles until you haveyour own bin tree going.

This "fix what is needed" see the SL 4 to SL 4.1 topic for the steps to follow including
revdep-rebuild -iv
emerge @preserve-rebuild
and anything else you want to use to fix what is needed.

Using all this and a lot of coffee it can be done in anywhere from 3 hours to 3 days, it all depends if you had gotten everyting ready for if S*** happens like first installed "mc" and possibly did "equo update" as well as "emerge --sync" to have the needed files available and or have cloned / backup copies of /usr/portage and /var/lib/entropy after they where updated.

Either way you need to get emerge or equo files to be replaced and then use them emerge or equo to fix and redo what is needed to get it to work. Mine ended up working perfectly. This will put hair on your chest if you have hair on your chest or not LOL.

If you can, just reinstall as it takes 15 to 30 mins but first copy /var/lib/entropy and /usr/portage if you have a slow internet to save time during update process and copy them back to be reused as they are already updated.

Untested alternative google for "gentoo newroot" or "emerge root=" to get more info:
You might be able to if all else fails use the untested method of livedvd boot then do not chroot but edit make.conf on the live dvd to show root=/mnt/sl and then
root=/mnt/sl emerge equo
/mnt/sl is where your hard drive with sabayon installed is mounted, works similar to "newroot" option on this method.

This will then use livedvd working / good equo or emerge, preferably emerge to install equo to the mounted sl installed hard drive and replace what is needed there then reboot and try to use equo to fix the install back to life.

Remeber to mount the installed hd to any place and then change /mnt/sl to where you have the hard drive / sl partition mounted.

You can even take this idea a step further by using "root=/mnt/sl emerge equo" and then if possible using

Code: Select all

root=/mnt/sl equo update
root=/mnt/sl equo install equo entropy sulfur layman portage python 
root=/mnt/sl equo conf update 
root=/mnt/sl python-updater
This could work and pigs could fly but we will only know once someone has tried it and found a modified working way to do this.

Hope this helps.

Post Reply