Page 1 of 1

Help installing mysql again

Posted: Sat Feb 21, 2009 23:02
by quadomatic
I was trying to install mysql for mythtv, and I started having issues with the root user not existing or something, and so I couldn't set the root user.

I uninstalled mythtv via portato. Now when I try to emerge mysql, I get this:

Code: Select all

localhost aneesh # emerge dev-db/mysql
Calculating dependencies... done!     
[ebuild  N    ] dev-db/mysql-5.0.76  USE="berkdb perl ssl -big-tables -cluster -debug -embedded -extraengine -latin1 -max-idx-128 -minimal (-selinux) -static" 
[ebuild  N    ] virtual/mysql-5.0                                                                                                                              
[ebuild  N    ] dev-db/mysql-community-5.0.75-r1  USE="berkdb perl ssl -big-tables -cluster -debug -embedded -extraengine -latin1 -max-idx-128 -minimal (-selinux) -static" 
[blocks B     ] dev-db/mysql-community ("dev-db/mysql-community" is blocking dev-db/mysql-5.0.76)                                                                           
[blocks B     ] dev-db/mysql ("dev-db/mysql" is blocking dev-db/mysql-community-5.0.75-r1)                                                                                  

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.                 

  ('ebuild', '/', 'dev-db/mysql-5.0.76', 'merge') pulled in by
    =dev-db/mysql-5.0* required by ('ebuild', '/', 'virtual/mysql-5.0', 'merge')
    =dev-db/mysql-5.0* required by ('ebuild', '/', 'dev-db/mysql-community-5.0.75-r1', 'merge')
    dev-db/mysql                                                                               


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):    

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
Is there any way to fix this so I can install emerge mysql?

Re: Help installing mysql again

Posted: Sat Feb 21, 2009 23:08
by wolfden
moved to correct forum

are you following the mythtv guide?
http://en.gentoo-wiki.com/wiki/MythTV