Help n00b guy emerge freemind "Solved"

Anything that pertains to Portage

Moderator: Moderators

Help n00b guy emerge freemind "Solved"

Postby pookito » Tue Nov 18, 2008 23:36

Hi everyone, this is my first post. So, I am trying to emergre freemind and this is what it comes on:


/usr/lib/portage/pym/portage_dep.py:39: DeprecationWarning: DEPRECATION NOTICE: The portage_dep module was replaced by portage.dep
/usr/lib/portage/pym/portage_dep.py:39: DeprecationWarning: DEPRECATION NOTICE: The portage_dep module was replaced by portage.dep
/usr/lib/portage/pym/portage_dep.py:39: DeprecationWarning: DEPRECATION NOTICE: The portage_dep module was replaced by portage.dep
* Using: sun-jdk-1.6
>>> Unpacking source...
>>> Unpacking gnu.regexp-1.1.4.tar.gz to /var/tmp/portage/dev-java/gnu-regexp-1.1.4-r2/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/dev-java/gnu-regexp-1.1.4-r2/work/gnu.regexp-1.1.4 ...
make -j2 -s -j1 JAVAC=/opt/sun-jdk-1.6.0.07/bin/javac JAVAFLAGS=-source 1.4 -target 1.4
* jar is not available for sun-jdk-1.6 on i686
* IMPORTANT: some Java tools are not available on some VMs on some architectures
make: *** [../lib/gnu-regexp-1.1.4.jar] Error 1
*
* ERROR: dev-java/gnu-regexp-1.1.4-r2 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3797: Called die
* The specific snippet of code:
* emake -j1 JAVAC="${JAVAC}" JAVAFLAGS="${JAVACFLAGS}" || die "emake failed";
* The die message:
* emake failed
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/lib/entropy/logs/dev-java:gnu-regexp-1.1.4-r2:20081118-061955.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-java/gnu-regexp-1.1.4-r2/temp/environment'.
*
!!! When you file a bug report, please include the following information:
GENTOO_VM=sun-jdk-1.6 CLASSPATH="" JAVA_HOME="/opt/sun-jdk-1.6.0.07"
JAVACFLAGS="-source 1.4 -target 1.4" COMPILER=""
and of course, the output of emerge --info


Now, based on this I am assuming that the problem is the VM which is not allowing me to emerge because jdk does not have jar, which is not available for the jdk-.6. My question is how do I go about it? I really need freemind, last time I had Sabayon I was able to compile it, but somehow I can not do it right now.
Last edited by pookito on Sun Oct 24, 2010 19:46, edited 1 time in total.
pookito
Baby Hen
 
Posts: 8
Joined: Tue Nov 18, 2008 22:29

Re: Help n00b guy emerge freemind

Postby xlnagla » Wed Nov 19, 2008 2:22

If you're using any Sabayon before 3.5.1, the sun-jdk-1.6 package is a tad broken. Use equo to pull in the new one -

# equo update && install sun-jdk-1.6.0.07-r1

That should fix your java vm home errors, by installing sun-jdk-1.6.0.07-r1

~xlnagla
xlnagla
Sagely Hen
 
Posts: 1078
Joined: Mon May 28, 2007 2:44


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest