emerge kate fails

Anything that pertains to Portage

Moderator: Moderators

emerge kate fails

Postby mpdefeo » Tue Nov 18, 2008 19:23

When I try to emerge -p kde-meta I get the following message

Code: Select all
localhost mike # emerge -p =kde-base/kde-meta-4.1.2

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=kde-base/kate-4.1.2:4.1".
(dependency required by "kde-base/kde-meta-4.1.2" [ebuild])
(dependency required by "=kde-base/kde-meta-4.1.2" [argument])


When I try to emerge kate i get this message

Code: Select all
localhost mike # emerge kate

 * IMPORTANT: 1 news items need reading for repository 'kde4-experimental'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild     U ] app-misc/strigi-0.5.11 [0.5.9] USE="-exif% -log%"
[ebuild     U ] media-libs/gstreamer-0.10.20 [0.10.19]
[ebuild     U ] media-libs/gst-plugins-base-0.10.20 [0.10.17]
[ebuild  N    ] x11-libs/qt-core-4.4.2  USE="qt3support ssl -debug -doc -glib -pch"
[ebuild  N    ] x11-libs/qt-test-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-script-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-dbus-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-sql-4.4.2  USE="qt3support sqlite -debug -firebird -mysql -odbc -pch -postgres"
[ebuild  N    ] kde-base/automoc-0.9.84
[ebuild  N    ] x11-libs/qt-gui-4.4.2  USE="accessibility cups dbus mng qt3support tiff xinerama -debug -glib -nas -nis -pch" INPUT_DEVICES="-wacom"
[ebuild  N    ] x11-libs/qt-qt3support-4.4.2  USE="accessibility -debug -pch"
[ebuild  N    ] x11-libs/qt-svg-4.4.2  USE="-debug -pch"
[ebuild  N    ] x11-libs/qt-opengl-4.4.2  USE="qt3support -debug -pch"
[ebuild  N    ] app-office/akonadi-server-1.0.0  USE="-mysql"
[ebuild  N    ] x11-libs/qt-webkit-4.4.2  USE="-debug -pch"
[ebuild     U ] dev-libs/soprano-2.1 [2.0.0] USE="sesame2%* -redland%"
[uninstall    ] x11-libs/qt-4.3.4-r1
[blocks b     ] x11-libs/qt-core ("x11-libs/qt-core" is blocking x11-libs/qt-4.3.4-r1)
[blocks b     ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-qt3support-4.4.2, x11-libs/qt-sql-4.4.2, x11-libs/qt-gui-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2, x11-libs/qt-webkit-4.4.2, x11-libs/qt-opengl-4.4.2)
[ebuild  N    ] media-sound/phonon-4.2.0  USE="gstreamer -debug"
[ebuild     U ] kde-base/kdelibs-4.1.3-r1 [4.0.5]
[ebuild     U ] kde-base/kdepimlibs-4.1.3 [4.0.5] USE="sasl* -ldap*"
[ebuild     U ] kde-base/libkworkspace-4.1.3 [4.0.5]
[ebuild     U ] kde-base/libtaskmanager-4.1.3 [4.0.5]
[ebuild     U ] kde-base/libplasma-4.1.3 [4.0.5]
[ebuild     U ] kde-base/kate-4.1.3 [4.0.5] USE="plasma%*"
[uninstall    ] kde-misc/kdnssd-avahi-0.1.2
[blocks b     ] <=kde-misc/kdnssd-avahi-0.1.2:0 ("<=kde-misc/kdnssd-avahi-0.1.2:0" is blocking kde-base/kdelibs-4.1.3-r1)
[blocks B     ] kde-base/phonon:kde-4 ("kde-base/phonon:kde-4" is blocking media-sound/phonon-4.2.0)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


When i download the kate-4.1.3:4.1.ebuild and try to manually emerge it i get this message

Code: Select all
localhost mike # ebuild /usr/portage/local/net-misc/kate/kate-4.1.3.ebuild manifest
 *
 * ERROR: net-misc/kate-4.1.3 failed.
 * Call stack:
 *               ebuild.sh, line 1857:  Called source '/usr/portage/local/net-misc/kate/kate-4.1.3.ebuild'
 *       kate-4.1.3.ebuild, line    8:  Called inherit 'kde4-meta'
 *               ebuild.sh, line 1220:  Called qa_source '/usr/portage/eclass/kde4-meta.eclass'
 *               ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-meta.eclass'
 *        kde4-meta.eclass, line   18:  Called inherit 'multilib' 'kde4-functions' 'kde4-base'
 *               ebuild.sh, line 1220:  Called qa_source '/usr/portage/eclass/kde4-base.eclass'
 *               ebuild.sh, line   37:  Called source '/usr/portage/eclass/kde4-base.eclass'
 *        kde4-base.eclass, line  166:  Called die
 * The specific snippet of code:
 *              die "kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild"
 *  The die message:
 *   kde4-base.eclass inherited but NEED_KDE not defined - broken ebuild
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 *


So my question is, how do i emerge kde-meta-4.1.3. I currently have 4.0.5 installed from entropy. I followed the 'how to' linked on this page viewtopic.php?f=53&t=14954 replacing kde-meta-4.1.2 with kde-meta4.1.3
mpdefeo
Young Hen
 
Posts: 38
Joined: Tue Nov 18, 2008 19:17

Re: emerge kate fails

Postby wolfden » Tue Nov 18, 2008 23:54

you need to clean up and get rid of the other kde stuff first

it also looks like you need to sync as 4.1.3 is in portage and should auto pull
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: emerge kate fails

Postby mpdefeo » Wed Nov 19, 2008 0:37

Thank you for the reply wolfden. I am freshly synced and kde-4.1.3 did auto pull. This is a problem that I had previously when trying to emerge kde-4.1.2 which I gave up on, and that I currently have trying to emerge kde-4.1.3 which I am not quite ready to give up on. What do you mean that I have to clean up other KDE stuff. Right now all I have is KDE-3.5.9 and KDE-4.0.5.
mpdefeo
Young Hen
 
Posts: 38
Joined: Tue Nov 18, 2008 19:17

Re: emerge kate fails

Postby wolfden » Wed Nov 19, 2008 2:56

clean up = remove

you will want to for sure remove 4.0.5

Your post is confusing as your bring up stuff from the past with 4.1.2 that apparently has no bearing on this?? So your current issue is 4.1.3 wont install?

Did you read the link that the error gave you?
http://www.gentoo.org/doc/en/handbook/h ... =1#blocked

You are mixing package managers? You know this isn't recommended?
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: emerge kate fails

Postby chsims1 » Wed Nov 19, 2008 8:46

More information about sorting those blocked packages (for your 'emerge kate') is given on the Gentoo forums.
chsims1
Growing Hen
 
Posts: 128
Joined: Wed Mar 07, 2007 8:53
Location: UK

Re: emerge kate fails

Postby mpdefeo » Wed Nov 19, 2008 14:51

Thank you for your advice. Just to clarify here is a rundown of what I have done, and what I am trying to do.

*I installed Sabayon from a live DVD
*I equo isntalled kde-4.0.5
*I tried to update to kde-4.1.2 by running

Code: Select all
emerge kde-meta


Which gave me errors about kate-4.1.2:4.1. I decided that I would wait untill kde-4.1.2 went into entropy. I then changed my mind a few months later and tried to install kde-4.1.3 through portage, however

Code: Select all
emerge kde-meta
still gave me the same errors...so here I am.

Now when you say I need to remove packages, do you mean i should
Code: Select all
equo remove kde-meta4.0.5


Will this take care of my dependency problem as well as the problem with kate? Should I also equo remove all packages I installed while using kde-meta-4.0.5, if so what about packages that were emerged under kde-meta-4.0.5?

No when you say I should not mix package managers, do you mean that I should use exclusivly portage, or entropy, but not both?

I apologize for not being clear, and I appreciate your advice.
mpdefeo
Young Hen
 
Posts: 38
Joined: Tue Nov 18, 2008 19:17


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest