Updated Portato to 0.11.1 no more works [Solved]

Anything that pertains to Portage

Moderator: Moderators

Updated Portato to 0.11.1 no more works [Solved]

Postby albfneto » Fri Sep 26, 2008 8:20

i have Sabayon 3.5 in a notebook.
after i emerged portato with emerge command, from portato 10 to 11...
Portato no more works, not open, and gives many python errors....
and some errors that it was not possible open GUI graphical plugins...
emerge ppython to the last version 2.5.2 cannot solved the problem...
portage-emerge commands, works well,
other GUIs for Portage, as Porthole and Kuroo also works well...
In the same system, Entropy-Equo-Spritz works..
For this i see that the problem is only in the Portato client.
Last edited by albfneto on Tue Sep 30, 2008 16:53, edited 2 times in total.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1711
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Updated Portato no more works

Postby wolfden » Fri Sep 26, 2008 12:56

post the errors
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Updated Portato no more works

Postby albfneto » Sat Sep 27, 2008 3:26

when i try to run portato, with su, passw. and portato cammands, teh following messages were received:


fcfrp62 albfneto # portato
* Setting Portage System (__init__.py:56)
* Starting Portato v. 0.11.1 (portato:55)
* Listener has not been started. (plistener.py:94)
* Plugin 'EtcProposals' loaded. (plugin.py:372)
* Plugin 'Notify' loaded. (plugin.py:372)
* Plugin 'ReloadPortage' loaded. (plugin.py:372)
* Plugin 'GPytage' loaded. Plugin has unresolved dependencies - disabled! (plugin.py:372)
* Exception:
Traceback (most recent call last):
File "/usr/bin/portato", line 99, in <module>
main()
File "/usr/bin/portato", line 63, in main
run()
File "/usr/lib/python2.5/site-packages/portato/gui/__init__.py", line 26, in run
m = MainWindow(s)
File "/usr/lib/python2.5/site-packages/portato/gui/windows/main.py", line 630, in __init__
self.build_cat_list()
File "/usr/lib/python2.5/site-packages/portato/gui/windows/main.py", line 773, in build_cat_list
self.fill_cat_store(store)
File "/usr/lib/python2.5/site-packages/portato/gui/windows/main.py", line 797, in fill_cat_store
if not self.cfg.get_boolean("collapseCats", "GUI"):
File "/usr/lib/python2.5/site-packages/portato/config_parser.py", line 350, in get_boolean
val = self._access(key, section)
File "/usr/lib/python2.5/site-packages/portato/config_parser.py", line 300, in _access
raise KeyNotFoundException("Key '%s' not found in section '%s' in file '%s'." % (key, section, self.file))
KeyNotFoundException: "Key 'collapsecats' not found in section 'GUI' in file '/etc/portato/portato.cfg'."

Portato version: 0.11.1
Python version: 2.5.2 (r252:60911, Sep 26 2008, 00:39:44)
[GCC 4.2.3 (Gentoo 4.2.3 p1.0)]
Used backend: Portage 2.1.5.3
pygtk: 2.12.1 (using GTK+: 2.12.12)
pygobject: 2.14.1 (using GLib: 2.16.6) (exception_handling.py:127)

and Portato not open
The other GUIs, Kuroo, Porthole and Himerge working...
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1711
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Updated Portato no more works

Postby albfneto » Sun Sep 28, 2008 20:12

i tried to re-install portato with emerge command, also downgrade to 0.11.
seems to me that the not opening, is mainly due to the error message:
listener nor open...
i will also contact Necoro. Is the developer or Portato.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1711
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Updated Portato no more works

Postby wolfden » Sun Sep 28, 2008 20:43

he usually checks this forum so was hoping he would see it
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Updated Portato no more works

Postby albfneto » Mon Sep 29, 2008 22:19

Today, i tried emerging portato, in other comp.
Now, the problem also occurs.
Both in Sabayon 32, or 64 bits and Gentoo 2008, 64 Bits.
resuming, appears to be a bug of Portato.
The comp had the 0.10 version (working)..
but 0.11 and 0.11.1 no works, not open!
Downgrade again to the 0.10 , now works, but...
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1711
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Portato 0.10 works Updated Portato to 0.11.1 no more works

Postby Stupot » Mon Sep 29, 2008 22:53

After you emerged to the newest version of python, did you run the python updater?

Your situation looks familiar to what some gentoo people had.

http://forums.gentoo.org/viewtopic-t-50 ... t-425.html
Stupot
Sagely Hen
 
Posts: 1545
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Portato 0.10 works Updated Portato to 0.11.1 no more works

Postby albfneto » Tue Sep 30, 2008 0:10

Yes, do the error continues...
also emerge gpytage cannot solve the problem.
I have this problem in gentoo also.
really in 3 linuxes:

in sabayon 3.5 32 bits, in a Semprom.
in Sabayon 3.5, 64 and Gentoo 2008, 64 bits in a AMD 64 athlon machine,
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1711
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Updated Portato to 0.11.1 no more works [Solved]

Postby albfneto » Tue Sep 30, 2008 16:55

Problem Solved!

it is simple:

after emerging the new Portato, run (logged as root)

emerge -av python
dispatch-conf or etc-update, to update the config files..

Thanks to Necoro, the developer of Portato.
Last edited by albfneto on Tue Sep 30, 2008 23:10, edited 1 time in total.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1711
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Updated Portato no more works

Postby Necoro » Tue Sep 30, 2008 17:36

wolfden wrote:he usually checks this forum so was hoping he would see it

Was more or less offline the last couple of days ;). But albfneto contacted me via PM and we solved it.

(I really should output some hints instead of just printing plain tracebacks. This KeyNotFoundException comes quite some times, so it would really be useful to print the "Have you run etc-update/dispatch-conf?" by default :))
User avatar
Necoro
Advanced Hen
 
Posts: 242
Joined: Mon Apr 23, 2007 22:47
Location: Munich (Germany)


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest