If merging kde-meta-3.5.10-r1 fails due to artsplugin-xine

Anything that pertains to Portage

Moderator: Moderators

If merging kde-meta-3.5.10-r1 fails due to artsplugin-xine

Postby Fitzcarraldo » Wed Sep 24, 2008 0:08

If you are trying to install the latest version of KDE 3.5 series (e.g. by merging kde-meta-3.5.10-r1) and it fails because artsplugin-xine will not build, then do the following:

Code: Select all
# emerge -1v xine-lib
# emerge -1v artsplugin-xine

Then you can merge kde-meta again and it should succeed.

I also suggest that you do:
Code: Select all
# equery depends xine-lib

to find out which packages depend on xine-lib and then re-merge them too. In my case these were, in addition to artsplugin-xine, amarok, kaffeine, kmplayer, mandvd and xine-ui. But it depends what you have installed on your PC.

If you have not yet installed the latest version of KDE 3.5 series and plan to do so, then do the above anyway so that the build of kde-meta does not fail partway through.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest