Multiple versions within a single package slot!!

Anything that pertains to Portage

Moderator: Moderators

Multiple versions within a single package slot!!

Postby tman7510 » Mon Sep 08, 2008 4:11

I need some help here. I've never run into this before so I'm wondering how to correct this. I tried to mask some of the but it didn't seem to do anything. Anybody have any suggestions?

!!! Multiple versions within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/com_err:0

('installed', '/', 'sys-libs/com_err-1.40.8', 'nomerge') pulled in by
@world
('installed', '/', 'sys-fs/e2fsprogs-1.40.8', 'nomerge')

('ebuild', '/', 'sys-libs/com_err-1.40.11', 'merge') pulled in by
('installed', '/', 'app-crypt/mit-krb5-1.6.3-r2', 'nomerge')
@world
('ebuild', '/', 'sys-libs/ss-1.40.11', 'merge')

sys-libs/ss:0

('installed', '/', 'sys-libs/ss-1.40.8', 'nomerge') pulled in by
@world
('installed', '/', 'sys-fs/e2fsprogs-1.40.8', 'nomerge')

('ebuild', '/', 'sys-libs/ss-1.40.11', 'merge') pulled in by
('installed', '/', 'app-crypt/mit-krb5-1.6.3-r2', 'nomerge')
@world

x11-libs/qt:4

('installed', '/', 'x11-libs/qt-4.3.4-r1', 'nomerge') pulled in by
@world
('ebuild', '/', 'app-misc/strigi-0.5.10', 'merge')

('ebuild', '/', 'x11-libs/qt-4.4.1', 'merge') pulled in by
@world
('ebuild', '/', 'media-video/manencode-1.0', 'merge')
('installed', '/', 'kde-base/kdelibs-4.0.5', 'nomerge')
(and 1 more)
tman7510
Simple Hen
 
Posts: 92
Joined: Sun Mar 16, 2008 5:51

Re: Multiple versions within a single package slot!!

Postby wolfden » Mon Sep 08, 2008 5:42

Well you need to satisfy the various versions

See info on com_err, e2fsprogs, ss :
http://forums.gentoo.org/viewtopic-t-704561.html
http://bugs.gentoo.org/show_bug.cgi?id=234907#c7

mitkrb5
http://forums.gentoo.org/viewtopic-t-70 ... tkrb5.html

You just got to work through versions, this happens frequently with bleeding edge stuff
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Multiple versions within a single package slot!!

Postby daniel.santos » Fri Oct 17, 2008 23:07

You forgot to mention strigi. I'm struggling with this too because I'm using ~amd64 keyword. My *guess* right now is that I need to do something about strigi? This is what I'm getting right now:

[blocks B ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-assistant-4.4.2, x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-sql-4.4.2, x11-libs/qt-gui-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2, x11-libs/qt-webkit-4.4.2, x11-libs/qt-opengl-4.4.2)

Total: 335 packages (51 upgrades, 123 new, 156 in new slots, 5 reinstalls, 1 uninstall), Size of downloads: 535,599 kB
Conflict: 2 blocks (1 unsatisfied)
Portage tree and overlays:
[0] /usr/portage
[1] /usr/portage/local/layman/zugaina
[2] /usr/portage/local/layman/pro-audio

!!! Multiple versions within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt:4

('installed', '/', 'x11-libs/qt-4.3.5', 'nomerge') pulled in by
('ebuild', '/', 'app-misc/strigi-0.5.11', 'merge')
@world

('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge') pulled in by
@world
('ebuild', '/', 'net-dns/avahi-0.6.23', 'merge')
('ebuild', '/', 'app-text/poppler-bindings-0.10.0-r1', 'merge')
(and 4 more)
daniel.santos
Baby Hen
 
Posts: 1
Joined: Fri Oct 17, 2008 22:38

Re: Multiple versions within a single package slot!!

Postby Fitzcarraldo » Fri Oct 17, 2008 23:34

^I had something similar a few days ago (i.e. Portage moaning about qt). I just did an:

Code: Select all
emerge -1v qt

The latest version of qt merged and then I was able to merge the packages I was trying to merge before, whatever they were.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7978
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest