The portage_dep module was replaced by portage.dep ???

Anything that pertains to Portage

Moderator: Moderators

The portage_dep module was replaced by portage.dep ???

Postby joe3 » Sun Sep 07, 2008 6:49

OK Now I'm sure I saw this warning scroll by before... But I don't have a clue what it's about...

But when I emerge something or other I sometimes see this scroll by:

/usr/lib64/portage/pym/portage_dep.py:39: DeprecationWarning: DEPRECATION NOTICE: The portage_dep module was replaced by portage.dep

I'm not all that sure I should try to do anything about it though.

I mean the only thing I'd ever did to/for portage was to emerge portage when I got a message recommending I do so after an:

emerge --sync && layman -S

I would have thought emerging it would have taken care of any depreciated components???

But the term "DeprecationWarning" makes me nervous that eventually part of portage might stop working???

--
joe3
joe3
Advanced Hen
 
Posts: 200
Joined: Sun May 06, 2007 21:28

Re: The portage_dep module was replaced by portage.dep ???

Postby wolfden » Sun Sep 07, 2008 8:59

portage isn't going to stop working


emerging stuff displays a lot of various messages.
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests