emerge woes

Anything that pertains to Portage

Moderator: Moderators

emerge woes

Postby jarrett » Thu Aug 21, 2008 7:15

Hi all,

I followed this guide after installing the Sabayon 3.5 Pod release: http://wiki.sabayonlinux.org/index.php?title=En:HOWTO:_3.5_Pod_adding_portage
Emerge doesn't work at all after that, it started with saying that there was something wrong with cpp when I tried to install from portage, so I installed gcc, and after that everything went to the doghouse.
Example: emerge --sync
Code: Select all
sent 209 bytes  received 565 bytes  309.60 bytes/sec
total size is 32  speedup is 0.04
Traceback (most recent call last):
  File "/usr/bin/emerge", line 9205, in <module>
    retval = emerge_main()
  File "/usr/bin/emerge", line 9157, in emerge_main
    action_sync(settings, trees, mtimedb, myopts, myaction)
  File "/usr/bin/emerge", line 7275, in action_sync
    exitcode = portage.portage_exec.spawn(mycommand,
AttributeError: 'module' object has no attribute 'portage_exec'


Hope somebody can help me with this... equo still works of course, but it would be nice to have portage working as well..
Cheers!
jarrett
Baby Hen
 
Posts: 7
Joined: Thu Jul 10, 2008 7:19

Re: emerge woes!

Postby Thev00d00 » Thu Aug 21, 2008 10:42

tried a reinstall of gcc/portage?

Which versions of sabyaon, equo, portage, gcc, which arch?
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Re: emerge woes!

Postby jarrett » Thu Aug 21, 2008 12:18

yes i tried reinstalling it (with equo, as emerge does not work with anything).
Sabayon 3.5 Pod (2.6.25-sabayon-r1), equo 0.15.24.1, portage-2.1.5.3, gcc-4.3.1-r1
jarrett
Baby Hen
 
Posts: 7
Joined: Thu Jul 10, 2008 7:19

Re: emerge woes

Postby mdmarmer » Fri Aug 22, 2008 3:48

Have a look at the blog page here http://planet.sabayonlinux.org/
where it says
Note: if you want to use Portage instead of Entropy, you have to download one of the two files below, depending on your chosen architecture:
- Sabayon Pod x86 3.5 Portage db http://na.mirror.garr.it/mirrors/sabayonlinux/Sabayon-Linux-x86-3.5-Pod.portage.db.tar.bz2
- Sabayon Pod x86-64 3.5 Portage db http://na.mirror.garr.it/mirrors/sabayonlinux/Sabayon-Linux-x86_64-3.5-Pod.portage.db.tar.bz2
and unpack them to /var/db/pkg


Mine is working, and that's how I did it.

(I followed these steps

equo install layman libtool linux-sabayon gcc linux-headers glibc

then

emerge --sync && layman -S

emerge didn't work, so I edited make.conf
I added missing flags in make.conf :

jpeg ldap spell fam vorbis gstreamer encode mpeg truetype mad xml mikmod xv device-mapper

emerge still didn't work, so then I looked at the blog page, and I followed the instructions there. After I put that file in /var/db/pkg it worked right away).

See if this helps you -- I hope it does.

Mike
mdmarmer
Advanced Hen
 
Posts: 240
Joined: Thu Oct 19, 2006 1:46
Location: dayton OH usa

Re: emerge woes

Postby jarrett » Fri Aug 22, 2008 7:05

Already did that mate, and I tried doing it all over again just now.

emerge --sync exits with the same problem...

Thanks for the effort though...
jarrett
Baby Hen
 
Posts: 7
Joined: Thu Jul 10, 2008 7:19


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests