portage is broken [Solved]

Anything that pertains to Portage

Moderator: Moderators

portage is broken [Solved]

Postby deadfool » Wed Jul 30, 2008 18:20

i get this when ever doing a sync or emerge
Code: Select all
Traceback (most recent call last):
  File "/usr/bin/emerge", line 9205, in <module>
    retval = emerge_main()
  File "/usr/bin/emerge", line 9199, in emerge_main
    myopts, myaction, myfiles, spinner)
  File "/usr/bin/emerge", line 8458, in action_build
    mydepgraph = depgraph(settings, trees, myopts, myparams, spinner)
  File "/usr/bin/emerge", line 2030, in __init__
    pkg_cache=self._pkg_cache)
  File "/usr/bin/emerge", line 1203, in __init__
    self._pkg_cache[pkg] = pkg
  File "/usr/bin/emerge", line 5687, in __setitem__
    if visible(root_config.settings, v) and \
  File "/usr/bin/emerge", line 1297, in visible
    if pkgsettings._getMaskAtom(pkg.cpv, pkg.metadata):
AttributeError: 'config' object has no attribute '_getMaskAtom'


i tried the manual portage install here http://www.gentoo.org/proj/en/portage/d ... ortage.xml and it failed. i also removed it and then installed it with equo and it still says i have the old version
Last edited by deadfool on Wed Jul 30, 2008 20:35, edited 1 time in total.
deadfool
Growing Hen
 
Posts: 124
Joined: Thu Mar 27, 2008 3:56

Re: portage is broken

Postby Fitzcarraldo » Wed Jul 30, 2008 18:50

Merged portage-2.2_rc4 this morning without any problem and have just merged latest version of another package without a problem. Which version of portage have you currently got installed, and could you have done something recently that might have affected things?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: portage is broken

Postby deadfool » Wed Jul 30, 2008 20:04

Portage 2.2_rc1 (default-linux/x86/2007.0, gcc-4.2.3, glibc-2.7-r1, 2.6.21-ragnarok3 i686)

i havent changed python or portage in a while. i came back from class after a sync and this happened.

actually equo says 2.1.5.3 and i think thats it since i unmerged portage and installed it with equo after the manual fix didnt work
deadfool
Growing Hen
 
Posts: 124
Joined: Thu Mar 27, 2008 3:56

Re: portage is broken

Postby deadfool » Wed Jul 30, 2008 20:35

its solved there was a bad manifest
deadfool
Growing Hen
 
Posts: 124
Joined: Thu Mar 27, 2008 3:56


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron