Failed to upgrade. [Solved]

Anything that pertains to Portage

Moderator: Moderators

Failed to upgrade. [Solved]

Postby terryshania » Mon Jul 28, 2008 9:25

I am trying to upgrade from v3.4 to the latest distribution but am new to portage. Have tried but got the following:

Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) app-portage/conf-update-1.0 to /
>>> Downloading 'http://distfiles.gentoo.org/distfiles/conf-update-1.0.tar.bz2'
--17:25:18-- http://distfiles.gentoo.org/distfiles/c ... .0.tar.bz2
=> `/usr/portage/distfiles/conf-update-1.0.tar.bz2'
Resolving distfiles.gentoo.org... 216.165.129.135, 140.211.166.134, 156.56.247.195, ...
Connecting to distfiles.gentoo.org|216.165.129.135|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 17,344 (17K) [application/x-tar]

100%[===================================================================>] 17,344 25.03K/s

17:25:20 (25.00 KB/s) - `/usr/portage/distfiles/conf-update-1.0.tar.bz2' saved [17344/17344]

* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* checking conf-update-1.0.tar.bz2 ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking conf-update-1.0.tar.bz2 to /var/tmp/portage/app-portage/conf-update-1.0/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/app-portage/conf-update-1.0/work/conf-update-1.0 ...
core.c: In function ‘is_last_entry’:
core.c:35: internal compiler error: Illegal instruction
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
helpers.c: In function ‘count_array_items’:
helpers.c:326: internal compiler error: Illegal instruction
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
conf-update.c: In function ‘main’:
conf-update.c:3: internal compiler error: Illegal instruction
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
Preprocessed source stored into /var/tmp/portage/app-portage/conf-update-1.0/temp/cc6h0IvL.out file, please attach this to your bugreport.
make: *** [core.o] Error 1
make: *** Waiting for unfinished jobs....
Preprocessed source stored into /var/tmp/portage/app-portage/conf-update-1.0/temp/cc97wtbj.out file, please attach this to your bugreport.
make: *** [helpers.o] Error 1
Preprocessed source stored into /var/tmp/portage/app-portage/conf-update-1.0/temp/cciGkXHM.out file, please attach this to your bugreport.
make: *** [conf-update.o] Error 1
*
* ERROR: app-portage/conf-update-1.0 failed.
* Call stack:
* ebuild.sh, line 1648: Called dyn_compile
* ebuild.sh, line 988: Called qa_call 'src_compile'
* ebuild.sh, line 44: Called src_compile
* conf-update-1.0.ebuild, line 39: Called die
*
* emake failed
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/lib/entropy/logs/app-portage:conf-update-1.0:20080728-172518.log'.
*


Does this make any sense and if so, what do I have to do to upgrade.

thanks.
terryshania
Baby Hen
 
Posts: 18
Joined: Thu Mar 13, 2008 7:54

Re: Failed to upgrade.

Postby Thev00d00 » Mon Jul 28, 2008 10:13

To upgrade to 3.5 i would reccomend using either the live DVD or entopy.

To upgrade from the live dvd just run the installer and then choose upgrade and your installation.

To upgrade via entropy, use equo

Code: Select all
# equo update
# equo world
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Re: Failed to upgrade.

Postby wolfden » Mon Jul 28, 2008 11:00

if you are not a seasoned veteran - DO NOT attempt to world upgrade a 3.4 install - it will take days and than more days to fix the breakages and a few more days to get it booting, pretty soon a month will go by and you will be so ticked off you'll ignite your computer on fire which will in turn burn down your house and than you will be arrested for arson.

It's just not worth it. Even equo isn't for the faint of heart for 3.4
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Failed to upgrade.

Postby wolfden » Mon Jul 28, 2008 11:02

v00d00 wrote:To upgrade to 3.5 i would reccomend using either the live DVD or entopy.

To upgrade from the live dvd just run the installer and then choose upgrade and your installation.

To upgrade via entropy, use equo

Code: Select all
# equo update
# equo world


equo don't come with 3.4 and you also have to specify branch
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Failed to upgrade.

Postby terryshania » Mon Jul 28, 2008 11:18

thanks Wolfden. I certainly dont want to burn my computer, even though I sometimes feel like it so I will download the latest version of the OS and upgrade that way. much obliged for the quick response and advice. :D
terryshania
Baby Hen
 
Posts: 18
Joined: Thu Mar 13, 2008 7:54

Re: Failed to upgrade.

Postby Thev00d00 » Mon Jul 28, 2008 13:15

wolfden wrote:equo don't come with 3.4 and you also have to specify branch


There is only the 3.5 branch atm which is used by default, didnt 3.4e + f contain entropy anyway?
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Re: Failed to upgrade.

Postby wolfden » Mon Jul 28, 2008 20:23

it only had app-admin/equo-9999-r2 and with 3.4 u have to specify branch
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest