I can't update Sabayon [Solved]

Anything that pertains to Portage

Moderator: Moderators

I can't update Sabayon [Solved]

Postby symon1980 » Sun Jun 01, 2008 12:19

Hi peoples, i am new to Sabayon, i've come from mostly debian based distro's, and wanted to give source based a go :)
anyways, i installed sabayon 3.4 mini, and i've read over and over again about portage/emerge etc etc.... and have googled about the problem
i have and nothin has worked so far

anyways...
all i am trying to do is update my os, i have done emerge --sync and layman -S
I have read that after that, update the system with emerge -uDNav world

here is where i have a problem... i get this....

Calculating world dependencies /
!!! All ebuilds that could satisfy ">=dev-java/antlr-2.7.1" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-java/antlr-2.7.7 (masked by: required EAPI 1, supported EAPI 0)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "dev-java/gjdoc-0.7.9" [ebuild])



!!! Problem resolving dependencies for kde-base/kpf
!!! Depgraph creation failed.
localhost portage #


i have tried what somebody else suggested which was using the unmask option, and autounmask, etc etc. still doesn't work.
i have also tried updating portage like somebody else suggested. still not working.

Can anybody help me?
thanx.
symon1980
Baby Hen
 
Posts: 12
Joined: Sat May 31, 2008 13:59

Re: I can't update Sabayon

Postby wolfden » Sun Jun 01, 2008 18:30

3.4 is way to old to world update unless you really know portage. Packages are over a year old and many huge changes including python which is going to bust your entire system unless you know how to recover from it.

World updates are not for people that don't understand portage fully. You would be better off doing a gentoo stage 1 install than update 3.4 thru portage, it would be much quicker.

You may want to try entropy to update your system
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: I can't update Sabayon

Postby symon1980 » Mon Jun 02, 2008 17:04

yer, thanx. i decided to install 3.5 loop3, and i don't have this problem anymore.
but i do have 1 other problem. i'll post in the correct section for this issue.
thanx
symon1980
Baby Hen
 
Posts: 12
Joined: Sat May 31, 2008 13:59

Re: I can't update Sabayon [Solved]

Postby wolfden » Tue Jun 03, 2008 0:08

Thanks, marking solved than
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron