emerge -avuDN --world -> HAL blocking

Anything that pertains to Portage

Moderator: Moderators

Post Reply
lyhana8
Baby Hen
Posts: 3
Joined: Tue Jan 01, 2008 14:31
Location: france

emerge -avuDN --world -> HAL blocking

Post by lyhana8 » Thu Jan 03, 2008 22:01

Hi,
I encouter problem tryong to update my whole system ; I've modified the /etc/make.conf USE list like this :
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-Os -march=i586 -mno-tls-direct-seg-refs -mmmx -m32"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -s"
CHOST="i586-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
ACCEPT_KEYWORDS="~x86"
LINGUAS="en"
MAKEOPTS="-j2 -s "
PORTAGE_NICENESS="8"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/"
FEATURES="parallel-fetch"
CONFIG_PROTECT="/usr/kde/3.5/share/config/kdm/ /etc"
VIDEO_CARDS="fglrx vesa"
#"apm ark chips cirrus cyrix dummy fbdev fglrx glint i128 i740 i810 imstt mach64 mga neomagic nsc nv nvidia r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo epson"
USE="-arts a52 aac accessibility acpi alsa apache2 bash-completion bluetooth bzip2 cairo canna\
cddb cdparanoia cdr chasen cjk cups dbus directfb dri dvd dvdr dvdread encode exif ffmpeg fftw\
firefox foomaticdb ftp gd gif gimp -gnome gpm gstreamer gtk -hal iconv ieee1394 imagemagick immqt-bc ipv6 jabber\
javascript jingle jpeg kde -kdeenablefinal latex libcaca lm_sensors mad matroska mime mmx mng \
mozilla mp3 mpeg mplayer msn mysql mysqli networkmanager nls nptl ogg opengl openntpd pcre pdf \
php png posix qt3 qt4 reiserfs rss ruby samba scanner sensord spell sqlite3 sse sse2 svg svga \
svgz theora tidy unicode usb v4l v4l2 vhosts vnc vorbis wifi win32codecs wxwindows X x264 xcomposite \
xine xml xv xvid\
"
# hal
LINGUAS="en_US"
INPUT_DEVICES="evdev keyboard mouse synaptics wacom"
#acecad aiptek calcomp citron digitaledge dmc dynapro elo2300 elographics fpit hyperpen jamstudio joystick magellan microtouch mutouch palmax penmount spaceorb summa synaptics tek4957 wacom ur98 vmmouse void wacom"
source /usr/portage/local/layman/make.conf
LIRC_DEVICES="audio audio_alsa"
When I do an

Code: Select all

emerge -avuDN --world
or

Code: Select all

emerge -avuDN --world
, I get the following output :
# emerge -avuDN world

These are the packages that would be merged, in order:

Calculating world dependencies \
!!! All ebuilds that could satisfy ">=sys-apps/hal-0.5.10" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/hal-0.5.10 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Saleem Abdulrasool <[email protected]> (23 Nov 2007)
# Mask this until we get the input and mounting issues worked out


For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "app-misc/hal-info-20071011" [ebuild])



!!! Problem resolving dependencies for net-misc/networkmanager
!!! Depgraph creation failed.
I read that HAL was hard masked, so I change the use in my make.conf from 'hal' to '-hal' and get the same.
« share aware » « par Tajêt !»

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: emerge -avuDN --world -> HAL blocking

Post by wolfden » Fri Jan 04, 2008 1:53

so unmask it, but you don't want the latest version, you'll have to downgrade back to 0.5.9.1-r8

Post Reply