Trying to emerge eclipse

Anything that pertains to Portage

Moderator: Moderators

Trying to emerge eclipse

Postby Mr.Woo » Tue Dec 11, 2007 1:52

I was trying to emerge eclipse and I got this error. I have no idea what to do. I'm not even sure if this is the right place to be posting this problem but I thought it would be a good place to start.
Code: Select all
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
                      >> E R R O R <<
============================================================

/usr/bin/fastjar cf /var/tmp/portage/dev-java/antlr-2.7.7/work/antlr-2.7.7/antlr/antlr.jar antlr

============================================================
Got an error while trying to execute  command  above.  Error
messages (if any) must have shown before. The exit code was:
exit(1)
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
make[1]: *** [/var/tmp/portage/dev-java/antlr-2.7.7/work/antlr-2.7.7/antlr/antlr.jar] Error 1
make: *** [all] Error 1
 *
 * ERROR: dev-java/antlr-2.7.7 failed.
 * Call stack:
 *               ebuild.sh, line   35:  Called src_compile
 *             environment, line 4044:  Called die
 * The specific snippet of code:
 *       emake || diefunc "$FUNCNAME" "$LINENO" "$?" "compile failed";
 *  The die message:
 *   compile failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-java/antlr-2.7.7/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-java/antlr-2.7.7/temp/environment'.
 *
!!! When you file a bug report, please include the following information:
GENTOO_VM=sun-jdk-1.6  CLASSPATH="" JAVA_HOME="/opt/sun-jdk-1.6.0.03"
JAVACFLAGS="+ -source 1.3 -target 1.3" COMPILER=""
and of course, the output of emerge --info

 * Messages for package dev-java/antlr-2.7.7:

 *
 * ERROR: dev-java/antlr-2.7.7 failed.
 * Call stack:
 *               ebuild.sh, line   35:  Called src_compile
 *             environment, line 4044:  Called die
 * The specific snippet of code:
 *       emake || diefunc "$FUNCNAME" "$LINENO" "$?" "compile failed";
 *  The die message:
 *   compile failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-java/antlr-2.7.7/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-java/antlr-2.7.7/temp/environment'.
 *
Mr.Woo
Baby Hen
 
Posts: 11
Joined: Sat Jan 06, 2007 21:18

Re: Trying to emerge eclipse

Postby Fitzcarraldo » Tue Dec 11, 2007 18:13

Well, the error message is telling you the problem is with antlr. If you use the SL Forum Search facility using the keyword "antlr" you'll find an answer.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 8077
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Trying to emerge eclipse

Postby Mr.Woo » Wed Dec 12, 2007 6:13

The second post in this thread of the Gentoo forums solved my problem

http://forums.gentoo.org/viewtopic-t-525845.html
Mr.Woo
Baby Hen
 
Posts: 11
Joined: Sat Jan 06, 2007 21:18


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests