emerge --sync ends with error code 24 [Solved]

Anything that pertains to Portage

Moderator: Moderators

emerge --sync ends with error code 24 [Solved]

Postby Richlion » Sun Dec 02, 2007 19:38

Hi,

is there anything I can do about this? I am trying to update the Portage database using:
emerge --sync

This ended with an error today a few times:
Code: Select all
sent 183 bytes  received 3140977 bytes  35898.97 bytes/sec
total size is 172518704  speedup is 54.92
rsync warning: some files vanished before they could be transferred (code 24) at main.c(1388) [generator=2.6.9]

!!! Rsync has not successfully finished. It is recommended that you keep
!!! trying or that you use the 'emerge-webrsync' option if you are unable
!!! to use rsync due to firewall or other restrictions. This should be a
!!! temporary problem unless complications exist with your network
!!! (and possibly your system's filesystem) configuration.


Also this does not help, although there was one successful run:
emerge-webrsync

Thanks for any hints,
Richard.


PS. I went to the Gentoo forum and found some hints.

rm -rf /usr/portage/*
This solved my problem.
However, there was still a reference to a make.conf file in /etc/make.conf pointing to /usr/portage/local/layman...,
after I removed the line from /etc/make.conf emerge --sync went brilliantly without any errors.

No I am compiling my new Thunderbird.

Richard.
*** Sabyon user since 2006 ***
Sabayon Linux amd64 13.03 - x86_64 Pentium(R) Dual-Core CPU T4200 @ 2.00GHz
KDE 4.10.1 - on Acer Aspire 7730 zg 17" with Nvidia Geforce 9300M GS
Richlion
Technological Hen
 
Posts: 393
Joined: Sun Nov 11, 2007 2:19
Location: Manchester

Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests

cron