Sabayon Sources 2.6.22 problem

Anything that pertains to Portage

Moderator: Moderators

Sabayon Sources 2.6.22 problem

Postby PAdu92 » Thu Nov 22, 2007 20:13

Hi guys, I have a probleme on Sabayon 3.4 mini CD with the stock 2.6.22 kernel, I can't install some softs (virtualbox, nvidia-drivers...) because it can't find the kernel sources:
Code: Select all
 * The specific snippet of code:
 *      get_version || die "Unable to calculate Linux Kernel version"
 *  The die message:
 *   Unable to calculate Linux Kernel version


So I tried et emerge =sabayon-sources-2.6.22
but it can't find it, what package should I install to fix this?
PAdu92
Simple Hen
 
Posts: 41
Joined: Fri Aug 17, 2007 14:03

Re: Sabayon Sources 2.6.22 problem

Postby wolfden » Fri Nov 23, 2007 0:40

gonna have to upgrade your kernel
http://wiki.sabayonlinux.org/index.php? ... _genkernel
wolfden wolfden # eix sabayon-sources
[I] sys-kernel/sabayon-sources [1]
Available versions: (~)2.6.23-r1
Installed versions: 2.6.23-r1(07:13:45 AM 11/19/2007)(symlink -build)
Homepage: http://www.sabayonlinux.org
Description: Full sources including the Gentoo patchset and SabayonLinux ones for the . kernel tree


The thing is, SL is changing kernel names, so sabayon-sources will be linux-sabayon
wolfden wolfden # eix linux-sabayon
* sys-kernel/linux-sabayon [1]
Available versions:
(2.6.22) 2.6.22
(2.6.23) (~)2.6.23-r1
{dmraid grub no_sources only_sources source splash}
Homepage: http://www.sabayonlinux.org
Description: Official Sabayon Linux kernel images and sources

So it's up to you which one to go with, but u will need to upgrade or emerge one of em
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Sabayon Sources 2.6.22 problem

Postby PAdu92 » Fri Nov 23, 2007 11:31

thanks, I emerge =linux-sabayon-2.6.22 and it worked, but I still can't emerge nvidia-drivers:

Code: Select all
 * The specific snippet of code:
 *      get_version || die "Unable to calculate Linux Kernel version"
 *  The die message:
 *   Unable to calculate Linux Kernel version

That's pretty annoying bug, since I'm not good enough to compile the new kernel (last time I did it it worked but I did'nt have my keyboard to work, I'm stable with the 2.6.22 and I would like to keep it, is there another way to go?
PAdu92
Simple Hen
 
Posts: 41
Joined: Fri Aug 17, 2007 14:03

Re: Sabayon Sources 2.6.22 problem

Postby chsims1 » Fri Nov 23, 2007 11:45

It's not a bug; just that you haven't compiled the kernel. Try it, it's not difficult if you follow the Wiki carefully. :)
chsims1
Growing Hen
 
Posts: 128
Joined: Wed Mar 07, 2007 8:53
Location: UK

Re: Sabayon Sources 2.6.22 problem

Postby PAdu92 » Fri Nov 23, 2007 11:52

chsims1 wrote:It's not a bug; just that you haven't compiled the kernel. Try it, it's not difficult if you follow the Wiki carefully. :)

I consider this as a bug, since a normal user like me should'nt have to compile a kernel to get his softs to work on a stock install...
Especially as I'm using software RAID and i'm scared of screwing everything up
PAdu92
Simple Hen
 
Posts: 41
Joined: Fri Aug 17, 2007 14:03

Re: Sabayon Sources 2.6.22 problem

Postby wolfden » Fri Nov 23, 2007 13:20

that is why it is a mini, it doesn't come with sources for space

emerging doesn't compile
make sure
Code: Select all
eselect kernel list
is point to the right kernel also
if not use eselect kernel set (# needed)
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest