pilot-link handles UTF-8 conversions... no

Anything that pertains to Portage

Moderator: Moderators

pilot-link handles UTF-8 conversions... no

Postby Fitzcarraldo » Tue Oct 30, 2007 13:45

Trying to emerge latest evolution but it always fails because "pilot-link handles UTF-8 conversions... no". Googling shows it seems to be a common problem starting way back:

http://archives.gentoo.org/gentoo-dev/msg_93377.xml

I've not found an answer yet. Has anyone else encountered this and found a solution (other than removing the global USE flag "pda" from /etc/make.conf, which is no good if you might want to use a pda with evolution)?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: pilot-link handles UTF-8 conversions... no

Postby wolfden » Wed Oct 31, 2007 9:51

[I] mail-client/evolution
Available versions: (2.0) 2.8.3-r2 2.10.2 2.10.3 (~)2.12.0 (~)2.12.1
{bogofilter crypt dbus debug doc hal ipv6 kerberos krb4 ldap mono networkmanager nntp pda profile spell ssl}
Installed versions: 2.12.1(2.0)(06:33:09 PM 10/18/2007)(crypt dbus hal ipv6 kerberos ldap mono nntp pda ssl -debug -doc -krb4 -networkmanager -profile -spell)
Homepage: http://www.gnome.org/projects/evolution/
Description: Integrated mail, addressbook and calendaring functionality


Usually don't have a problem with evolution even tho I don't use it. Epiphany is usually the one you have to use -sandbox on to install
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: pilot-link handles UTF-8 conversions... no

Postby Fitzcarraldo » Wed Oct 31, 2007 11:58

Thanks for your reply. I had already tried FEATURES="-sandbox" on epiphany, then on both, then unemerged epiphany and tried to build evolution by itself, but still "no go", so I ended up removing the pda global USE flag from make.conf for the time being. The only thing I've not tried is passing "pda" to evolution as a local USE flag.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: pilot-link handles UTF-8 conversions... no

Postby Fitzcarraldo » Fri Nov 02, 2007 12:42

As I mentioned in my previous post, I removed "pda" from the list of global USE flags in my /etc/make.conf and got Evolution to build. Interestingly, I have just noticed that "pda" is listed as a USE flag in the Evolution I built when I check using eix:

[I] mail-client/evolution
Available versions: (2.0) 2.8.3-r2 2.10.2 2.10.3 (~)2.12.0 (~)2.12.1
{bogofilter crypt dbus debug doc hal ipv6 kerberos krb4 ldap mono networkmanager nntp pda profile spell ssl}
Installed versions: 2.12.1(2.0)(12:44:12 30/10/07)(crypt dbus hal ipv6 kerberos ldap mono nntp spell ssl -debug -doc -krb4 -networkmanager -pda -profile)
Homepage: http://www.gnome.org/projects/evolution/
Description: Integrated mail, addressbook and calendaring functionality

There's no entry for Evolution in /etc/portage/package.use, so I'm not sure why Evolution still has the pda flag listed. I've not tried it with a pda, though. Just thought I'd post this as, on the face of it, it seems odd.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron