Pit-falls installing GIMP 2.4.0?

Anything that pertains to Portage

Moderator: Moderators

ashley194
Technological Hen
Posts: 321
Joined: Mon Feb 19, 2007 21:54
Location: Manchester, UK.

Pit-falls installing GIMP 2.4.0?

Post by ashley194 » Wed Oct 24, 2007 22:09

Before I go ahead & update my GIMP, I performed 'emerge --pretend gimp', here's what I got...

Calculating dependencies... done!
[ebuild U ] dev-libs/glib-2.14.2 [2.12.11]
[ebuild U ] media-libs/libexif-0.6.16 [0.6.13-r2]
[ebuild U ] x11-libs/pango-1.18.3 [1.16.3]
[ebuild U ] x11-libs/gtk+-2.12.1 [2.10.11] USE="cups%*"
[ebuild U ] media-gfx/gimp-2.4.0 [2.3.15] USE="dbus%* -curl% -png*"

Last weekend I very foolishly updated Portage, that totally trashed my SL installation :? (I lost my compiz-fusion, forcing me into kwin :( ). Luckily I have grsync, so after 40 min's installing 3.4f x86_64; it was a simple case of rsyncing back to my SL /home/...

Just want to know of any potential pit-falls before I trash my SL installation for perhaps the dozenth time :oops:

Thanks :D

Stupot
Sagely Hen
Posts: 1819
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Pit-falls installing GIMP 2.4.0?

Post by Stupot » Wed Oct 24, 2007 23:28

I've never done any sort of damage by updating portage.

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: Pit-falls installing GIMP 2.4.0?

Post by wolfden » Wed Oct 24, 2007 23:50

umm yea, emerging portage is not going to trash your entire system

ashley194
Technological Hen
Posts: 321
Joined: Mon Feb 19, 2007 21:54
Location: Manchester, UK.

Re: Pit-falls installing GIMP 2.4.0?

Post by ashley194 » Thu Oct 25, 2007 6:48

Thanks for that advice. The last time I decided to update portage, it took ages, updating many other packages as well. So after a reboot, I was stuck in this horrible kwin. The only way I new out, was to re-install SL & start from base zero :( I've learnt my lesson, if it aint broke, don't fix it :lol:

So, any thought on the original question?

Thanks!

Stupot
Sagely Hen
Posts: 1819
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Pit-falls installing GIMP 2.4.0?

Post by Stupot » Thu Oct 25, 2007 18:01

Any time I've ever updated portage, it never installed tons of other packages. Maybe you're thinking of trying to update python or some other package?

ashley194
Technological Hen
Posts: 321
Joined: Mon Feb 19, 2007 21:54
Location: Manchester, UK.

Re: Pit-falls installing GIMP 2.4.0?

Post by ashley194 » Thu Oct 25, 2007 19:28

This is what I get, doing a 'pretend'. Think I'll leave it alone, never want to go back to kwin again :lol:

# emerge --pretend portage

These are the packages that would be merged, in order:

Calculating dependencies... done!

[ebuild U ] app-shells/bash-3.2_p17-r1 [3.2_p15-r1] USE="-plugins%"
[ebuild U ] sys-apps/portage-2.1.3.16 [2.1.3.4-r1] LINGUAS="-pl*"
*** Portage will stop merging at this point and reload itself,
then resume the merge.
[ebuild U ] dev-python/pycrypto-2.0.1-r6 [2.0.1-r5]

ashley194
Technological Hen
Posts: 321
Joined: Mon Feb 19, 2007 21:54
Location: Manchester, UK.

Re: Pit-falls installing GIMP 2.4.0?

Post by ashley194 » Fri Oct 26, 2007 7:01

Well I took the plunge & updated portage, now I'm stuck back in kwin :( Any ideas how to get compiz back (no compiz icon), short of formatting/installing?

Thanks!

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: Pit-falls installing GIMP 2.4.0?

Post by wolfden » Fri Oct 26, 2007 9:56

what exactly are you doing??

emerge portage

will not kill your desktop

are you doing world update or what?

ashley194
Technological Hen
Posts: 321
Joined: Mon Feb 19, 2007 21:54
Location: Manchester, UK.

Re: Pit-falls installing GIMP 2.4.0?

Post by ashley194 » Fri Oct 26, 2007 10:20

Hi wolfden.

I simply did this:

# emerge --pretend portage

These are the packages that would be merged, in order:

Calculating dependencies... done!

[ebuild U ] app-shells/bash-3.2_p17-r1 [3.2_p15-r1] USE="-plugins%"
[ebuild U ] sys-apps/portage-2.1.3.16 [2.1.3.4-r1] LINGUAS="-pl*"
*** Portage will stop merging at this point and reload itself,
then resume the merge.
[ebuild U ] dev-python/pycrypto-2.0.1-r6 [2.0.1-r5]

So took the plunge & emerged portage, rebooting brings me straight into kwin (yuk)

That is all I did, nothing more (I promise) :(

Thanks.

Ron.W
Simple Hen
Posts: 89
Joined: Fri Dec 08, 2006 20:11

Re: Pit-falls installing GIMP 2.4.0?

Post by Ron.W » Fri Oct 26, 2007 11:45

Hello,

well, it worked even worse for me.
First I typed

emerge -sync
layman -S


to get the actual version of gimp presented in portage.

After I've entered "emerge gimp" yesterday, it started installing a new version of dbus automatically... :shock:

After this it stopped giving me a filesize mismatch for python-gentoo-patches-2.5.1-r1-tar.bz
Moreover it demanded a revdep-rebuild, which I typed in.

There were hundreds of broken dependencies in nearly every single package all of a sudden, most of them require libdbus-1.so2, but revdep-sync failed to resolve package order, and told me there was no package to fullfill dependencies for hal, I should try to emerge it manually and rerun revdep-rebuild afterwards. Well, I obeyed and emerged hal manually, which had a block from udev, so I had to emerge udev first, then hal, and after this I hoped that revdep-rebuild -X would work. Far from it!
Suddenly emerge tells me, I would have to emerge a new portage before any other package could be emerged. So I did. And to get rid of the filesize-mismatch-problem I synced portage and overlay again.

To make a long story short:
The new gimp was installed after this, finally, and it works.

BUT: I didn't have any success sorting out these revdep-rebuild problems. Now it keeps stopping with compiler-errors, even when emerging the requested packages one by one manually.

Worse than that: After wlan lost connection to access-point, It was not able to reconnect, since wpa_supplicant wouldn't start any more:
/sbin/wpa_supplicant: error while loading shared libraries: libdbus-1.so.2: cannot open shared object file: No such file or directory.
So I don't have a working internet-connection any longer on this sabayon-machine :shock: , which means: No way to emerge anything.
And I don't dare to swich PC off, since I have the bad feling, it wouldn't even be able to come up after all this.

Anybody around who could give me some advice, what to do best now? Is there a chance to restart wpa_supplicant again?

Any help appreciated, I don't know how I'll come out of this on my own. I write these lines from an old Windows-Machine next-door.

Greetings
Ron

Post Reply