Ati drivers 8.42.3 are in portage

Anything that pertains to Portage

Moderator: Moderators

Ati drivers 8.42.3 are in portage

Postby Lomion » Wed Oct 24, 2007 18:08

I'm glad to see this entry in my daily update!

From ATI's website:
New Features

This release of the ATI Catalystâ„¢ Linux driver introduces the following new features:

* Support for Accelerated Indirect Rendering (AIGLX)
* Support for X.org version 7.3
* Products older than Radeonâ„¢ HD 2x00 are now supported after being enabled only for testing in 8.41.7
* A new 3D user interface is now avaialble in the ATI Catalystâ„¢ Control Center-Linux Edition. The new interface allows for the setting of Anti-Aliasing, Anisotropic Filtering, and VSync. Included on the new 3D interface are static preview images showing the visual effects of the different 3D settings


So will they REALLY work with AIGLX and new Xorg? :twisted: :shock:
Now it's time to download... :lol:
PROUD SABAYON LINUX USER
Image
Lomion
Simple Hen
 
Posts: 60
Joined: Fri May 11, 2007 17:46
Location: Italy

Re: Ati drivers 8.42.3 are in portage

Postby skipb » Thu Oct 25, 2007 4:43

Wahoo! I've been waiting for this.
skipb
Baby Hen
 
Posts: 2
Joined: Thu Oct 25, 2007 4:36
Location: Bristol, VA

Re: Ati drivers 8.42.3 are in portage

Postby Lomion » Thu Oct 25, 2007 9:14

I've seen a lot of users having trouble with Compiz-fusion (me too eheh :lol: ), others have a funny watermark in the lower-right of the screen (the one with AMD logo and "testing purposes only" :shock: ).
Some gets everything working well.

I personally have problems with Compiz, it seems it's missing one OpenGL extension:
Code: Select all
marco@Misha ~ $ compiz --replace
compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0


even if glxinfo shows GLX_EXT_textures_from_pixmap:
Code: Select all
marco@Misha ~ $ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1300XT/X1600Pro Series
OpenGL version string: 2.0.6958 Release
OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_fragment_program,
    GL_ARB_fragment_shader, GL_ARB_multisample, GL_ARB_multitexture,
    GL_ARB_occlusion_query, GL_ARB_point_parameters, GL_ARB_point_sprite,
    GL_ARB_shader_objects, GL_ARB_shading_language_100, GL_ARB_shadow,
    GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
    GL_ARB_texture_float, GL_ARB_texture_mirrored_repeat,
    GL_ARB_texture_rectangle, GL_ARB_transpose_matrix,
    GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_vertex_shader,
    GL_ARB_window_pos, GL_ATI_draw_buffers, GL_ATI_envmap_bumpmap,
    GL_ATI_fragment_shader, GL_ATI_meminfo, GL_ATI_separate_stencil,
    GL_ATI_texture_compression_3dc, GL_ATI_texture_env_combine3,
    GL_ATI_texture_float, GL_EXT_bgra, GL_EXT_blend_color,
    GL_EXT_blend_func_separate, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
    GL_EXT_compiled_vertex_array, GL_EXT_copy_texture,
    GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_object,
    GL_EXT_framebuffer_object, GL_EXT_gpu_program_parameters,
    GL_EXT_multi_draw_arrays, GL_EXT_packed_depth_stencil,
    GL_EXT_packed_pixels, GL_EXT_point_parameters, GL_EXT_rescale_normal,
    GL_EXT_secondary_color, GL_EXT_separate_specular_color,
    GL_EXT_shadow_funcs, GL_EXT_stencil_wrap, GL_EXT_subtexture,
    GL_EXT_texgen_reflection, GL_EXT_texture3D,
    GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod_bias,
    GL_EXT_texture_mirror_clamp, GL_EXT_texture_object,
    GL_EXT_texture_rectangle, GL_EXT_texture_sRGB, GL_EXT_vertex_array,
    GL_KTX_buffer_region, GL_NV_blend_square, GL_NV_texgen_reflection,
    GL_SGIS_generate_mipmap, GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod,
    GL_WIN_swap_hint, WGL_EXT_swap_control


Oh, I also had to symlink /usr/lib/OpenGL.so.1 to Ati's OpenGL.so.1 to have KDM start and glxinfo show information... :?
PROUD SABAYON LINUX USER
Image
Lomion
Simple Hen
 
Posts: 60
Joined: Fri May 11, 2007 17:46
Location: Italy

Re: Ati drivers 8.42.3 are in portage

Postby Lomion » Thu Oct 25, 2007 9:34

Ok I solved all my problems.
Here's what I0ve done since now:

1- Emerged Ati-drivers- 8.42.3
2- eselect set opengl xorg-x11
3- reboot
4- at this point, no kdm session started, I ended up in the console, where I've launched eselect opengl set ati
5- symlink /usr/lib/libGL.so.1 to /usr/lib/opengl/ati/lib/libGL.so.1
6- symlink /usr/lib/libGL.so.1.2 to /usr/lib/opengl/ati/lib/libGL.so.1.2
7- run desktop-acceleration-setup aiglx enable (since the visual helper doesn't recognise AIGLX on Ati-cards)
8- rebooted
9- Compiz is working :D

Hope this help ;)

EDIT: New Desktop-accelerator-helpers 3.0-r8 allow AIGLX for Ati cards also in graphical mode ;)
I'm experiencing a strange behavoir with video files. When reproducing an avi file or mpeg, it looks blinking, some kind of distortion... :?
PROUD SABAYON LINUX USER
Image
Lomion
Simple Hen
 
Posts: 60
Joined: Fri May 11, 2007 17:46
Location: Italy

Re: Ati drivers 8.42.3 are in portage

Postby markiza » Thu Oct 25, 2007 13:44

thanks, i got it!

# emerge --sync
# emerge portage
# layman -S
# emerge ati-drivers
markiza
Baby Hen
 
Posts: 6
Joined: Tue Sep 04, 2007 3:42

Re: Ati drivers 8.42.3 are in portage

Postby anomalizer » Thu Oct 25, 2007 16:12

And for 32 bit apps, do the following:
ln -s /usr/lib32/opengl/ati/lib/libGL.so /usr/lib32/

I think this is a bug that needs to be flied against app-admin/eselect-opengl
anomalizer
Baby Hen
 
Posts: 8
Joined: Wed Aug 15, 2007 14:25

Re: Ati drivers 8.42.3 are in portage

Postby Lomion » Thu Oct 25, 2007 16:51

anomalizer wrote:And for 32 bit apps, do the following:
ln -s /usr/lib32/opengl/ati/lib/libGL.so /usr/lib32/

I think this is a bug that needs to be flied against app-admin/eselect-opengl


Thank you! I hopoe this will fix the problem I have when I start Sauerbraten... It cannot find libGL.
I'm running a 64 bit System, so I have not fixed libGL for 32 bit :D

Anyone else got flikering videos? :?
Another thing I noticed is that Compiz-Fusion cannot start on KDE's startup, but 10 or 20 seconds after via Fusion-Icon (either from terminal or from K menus) it works great! :shock:

I hope 8.43 will work better :D Anyway it's cool to see Ati card working on AIGLX.
PROUD SABAYON LINUX USER
Image
Lomion
Simple Hen
 
Posts: 60
Joined: Fri May 11, 2007 17:46
Location: Italy

Re: Ati drivers 8.42.3 are in portage

Postby gbr » Fri Oct 26, 2007 14:25

I can't get this going.

ati-drivers 8.42
X 1.3.0
Mobility X700

I just get an error about not having texture from pixmap.

I guess I'll wait till the next release of the ati drivers.

Gerald
gbr
Simple Hen
 
Posts: 53
Joined: Wed Jan 24, 2007 18:31

Re: Ati drivers 8.42.3 are in portage

Postby suzani » Fri Oct 26, 2007 21:56

Hi !
After emerging the new ati-driver and reboot I only get a black screen instead of the login screen. Is there any way to remove the new driver, because there´s no way for me to open the console. I don´t want to make a full install of Sabayon. Any hints would be great. :study:
User avatar
suzani
Baby Hen
 
Posts: 7
Joined: Sun Aug 12, 2007 11:04

Re: Ati drivers 8.42.3 are in portage

Postby alcalde » Fri Oct 26, 2007 23:24

This might just be a crazy question from a newbie, but would anyone happen to know why after doing emerge --sync my portage still lists the ati driver available as 8.40.4-r11?
alcalde
Simple Hen
 
Posts: 69
Joined: Sun Jul 29, 2007 18:59

Next

Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests