Plugin uses incompatible Qt library!

Anything that pertains to Portage

Moderator: Moderators

Post Reply
gevard
Baby Hen
Posts: 13
Joined: Fri Dec 08, 2006 17:20

Plugin uses incompatible Qt library!

Post by gevard » Wed Oct 17, 2007 18:42

Hello
I have some trouble using kprinter or kaddprinterwizard. When I strat them I got frezzed windows.
By running them as a command lines I got lot of error like:

Code: Select all

Conflict in /usr/kde/3.5/lib/kde3/plugins/styles/highcolor.so:
  Plugin uses incompatible Qt library!
  expected build key "i686 Linux g++-4 full-config no-opengl", got "i686 Linux g++-4 full-config".
I install last version of QT and GCC, still have the same problem.
Any idea??? Thanks in advance.

User avatar
Necoro
Advanced Hen
Posts: 242
Joined: Mon Apr 23, 2007 22:47
Location: Munich (Germany)
Contact:

Re: Plugin uses incompatible Qt library!

Post by Necoro » Mon Oct 22, 2007 9:49

Could you paste the output of:

Code: Select all

emerge -pv qt:3
?

gevard
Baby Hen
Posts: 13
Joined: Fri Dec 08, 2006 17:20

Re: Plugin uses incompatible Qt library!

Post by gevard » Mon Oct 22, 2007 12:24

Code: Select all

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/qt-3.3.8-r4  USE="cups ipv6 xinerama -debug -doc -examples -firebird -gif -immqt -immqt-bc -mysql -nas -nis -odbc -opengl -postgres -sqlite" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

User avatar
Necoro
Advanced Hen
Posts: 242
Joined: Mon Apr 23, 2007 22:47
Location: Munich (Germany)
Contact:

Re: Plugin uses incompatible Qt library!

Post by Necoro » Mon Oct 22, 2007 12:29

rebuild qt with the opengl useflag set

gevard
Baby Hen
Posts: 13
Joined: Fri Dec 08, 2006 17:20

Re: Plugin uses incompatible Qt library!

Post by gevard » Thu Oct 25, 2007 16:37

Hello
I'm back, I had some trouble with the installation of the QT3, because I did a "emerge --depclean && revdep-rebuild" and I think Sabayon remove the installation of qt3. :| Argh KDE hand.
OK, now I reinstall qt 3 with "emerge =qt-3.3.8-r4", KDE is back, but I still have a problem with "kaddprinterwizard".
When I launch it, I got:

Code: Select all

DCOPClient::attachInternal. Attach failed Could not open network socket
kbuildsycoca running...

Post Reply