updated portage tree and uh oh what have i done -Help

Anything that pertains to Portage

Moderator: Moderators

updated portage tree and uh oh what have i done -Help

Postby mikey0000 » Sun Oct 14, 2007 4:13

i updated the portage tree manually as i cant (as of yet ) use rsync and if i can download and install the update well why not.

now i get this every time i try to install something and another problem

!!! A file is not listed in the Manifest: '/usr/portage/x11-libs/qt/qt-4.2.3-r1.ebuild' i mean i get lines and lines of this
!!! A file is not listed in the Manifest: '/usr/portage/x11-libs/qt/qt-4.2.3-r1.ebuild' also different apps too not just qt
!!! A file is not listed in the Manifest: '/usr/portage/x11-libs/qt/qt-4.2.3-r1.ebuild'
!!! A file is not listed in the Manifest: '/usr/portage/x11-libs/qt/qt-4.2.3-r1.ebuild'
!!! A file is not listed in the Manifest: '/usr/portage/x11-libs/qt/qt-4.2.3-r1.ebuild'

!!! All ebuilds that could satisfy "=x11-libs/qt-4.3.2" have been masked.
!!! One of the following masked packages is required to complete your request:
!!! A file is not listed in the Manifest: '/usr/portage/x11-libs/qt/qt-4.2.3-r1.ebuild'
- x11-libs/qt-4.3.2 (masked by: corruption)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "net-im/skype-1.4.0.118" [ebuild])


heres my rsync issue
ocalhost usr # emerge --sync
>>> Starting rsync with rsync://140.211.166.165/gentoo-portage...
>>> Checking server timestamp ...
bad response from proxy -- HTTP/1.0 403 Forbidden
rsync: failed to connect to proxy.student.otago.ac.nz: Success (0)
rsync error: error in socket IO (code 10) at clientserver.c(104) [receiver=2.6.9]


from what ive managed to find i need to supply the username and password to the proxy (i dont know where nor how)
cheers
triple Booting Mac-osx 10.6, Sabayon Linux and Windows 7

2.5 athlon dual core
DFI infinity mobo
2 gb of DDR2 800 G skill ram 3.3.3.12
nvidia 9600gt
housed in a thermaltake taser III case with 7 fans - all turned off lol
mikey0000
Growing Hen
 
Posts: 159
Joined: Fri Aug 10, 2007 0:33
Location: Dunedin New Zealand

Re: updated portage tree and uh oh what have i done -Help

Postby mikey0000 » Sun Oct 14, 2007 4:49

ive done something im sure is stupid especially for someone who doesnt know what there doing
i deleted all the folders exept local and reinstalled the latest tree which was 2007 11
and its stopped doing it now.
I should probably go look to figure out the skype thing but if anyone knows that would be helpful
also is there a general bugs and security update i can do for sabayon through emerge?
triple Booting Mac-osx 10.6, Sabayon Linux and Windows 7

2.5 athlon dual core
DFI infinity mobo
2 gb of DDR2 800 G skill ram 3.3.3.12
nvidia 9600gt
housed in a thermaltake taser III case with 7 fans - all turned off lol
mikey0000
Growing Hen
 
Posts: 159
Joined: Fri Aug 10, 2007 0:33
Location: Dunedin New Zealand

Re: updated portage tree and uh oh what have i done -Help

Postby wolfden » Sun Oct 14, 2007 17:43

Have you looked at the SL Wiki at all or the gentoo handbook?? This is all covered there. Spend some time getting to read the documents

http://www.gentoo.org/doc/en/security/s ... rt1_chap14
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: updated portage tree and uh oh what have i done -Help

Postby mikey0000 » Sun Oct 14, 2007 23:47

im typically reading things as i need to, Yes i have been reading the gentoo handbook. I have also read some of the sabayon wiki, Im getting there.
triple Booting Mac-osx 10.6, Sabayon Linux and Windows 7

2.5 athlon dual core
DFI infinity mobo
2 gb of DDR2 800 G skill ram 3.3.3.12
nvidia 9600gt
housed in a thermaltake taser III case with 7 fans - all turned off lol
mikey0000
Growing Hen
 
Posts: 159
Joined: Fri Aug 10, 2007 0:33
Location: Dunedin New Zealand

Re: updated portage tree and uh oh what have i done -Help

Postby ssb » Tue Oct 16, 2007 0:05

You could try:
RSYNC_PROXY="rsync://username:[email protected]:portnumber"
which came from:
http://www.gentoo.org/doc/en/faq.xml
You might eventually also need:
HTTP_PROXY="http://username:[email protected]:portnumber"
FTP_PROXY="ftp://username:[email protected]:portnumber"

Hope it helps.
ssb
Baby Hen
 
Posts: 7
Joined: Sat Jan 13, 2007 6:31


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron