Cannot get python-updater to finish!!!!

Anything that pertains to Portage

Moderator: Moderators

Cannot get python-updater to finish!!!!

Postby Jmanfoo » Thu Oct 11, 2007 16:00

I'm running 3.4e x86, and I just did a wipe and reload and I'm trying to run python-updater and when it gets to dev-python/numeric-24.2-r6 it fails out with the compilation error "AttributeError: Extension instance has no attribute 'pyrex_c_in_temp'". I have tried to merge and older version, but it still fails out because python-updater insists on this version. Any ideas?
Jmanfoo
Baby Hen
 
Posts: 5
Joined: Sat Aug 25, 2007 4:28

Re: Cannot get python-updater to finish!!!!

Postby DontPanic » Thu Oct 11, 2007 20:50

The python-updater doesn't seem to get dependencies right. Some things need to be re-merged first, but it doesn't pick up on that.

What I did was 'python-updater -p' for pretend. This gave me a list of packages that it needs to update.

You can then either manually re-emerge all these packages, or try to figure out the one that is giving you the dependency issue, manually re-emerge that one, and re-run python-updater.
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU E6750@ 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM
DontPanic
Old Dear Hen
 
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Re: Cannot get python-updater to finish!!!!

Postby Necoro » Thu Oct 11, 2007 22:14

http://bugs.gentoo.org/show_bug.cgi?id=195466

Just mask pyrex-0.9.6 (or sync, as according to the bug it's been masked in portage today) and downgrade to version 0.9.5.1a
User avatar
Necoro
Advanced Hen
 
Posts: 242
Joined: Mon Apr 23, 2007 22:47
Location: Munich (Germany)

Re: Cannot get python-updater to finish!!!!

Postby Jmanfoo » Fri Oct 12, 2007 15:46

Ok I got most of the dependency issues resolved, but now it's trying to emerge dev-java/antlr-2.7.7 and keeps giving me this error:

Code: Select all
gcc-config error: /usr/bin/fastjar wrapper: Unable to determine executable.
CTARGET=i586-pc-linux-gnu
exec=fastjar


I've remerged jdk, java-config, and java-config-wrapper, all to no avail. I did need to change the gcc-config profile to reflect the updated gcc, and that seems to work fine since I'm able to compile other packages.

Can I just mask and skip this one for now?
Jmanfoo
Baby Hen
 
Posts: 5
Joined: Sat Aug 25, 2007 4:28

Re: Cannot get python-updater to finish!!!!

Postby DontPanic » Fri Oct 12, 2007 16:40

I found this discussion in the Gentoo discussion forums:

http://forums.gentoo.org/viewtopic-t-525845.html

Myself, I'd just rename the file discussed in that topic instead of deleting it.
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU E6750@ 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM
DontPanic
Old Dear Hen
 
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: albfneto and 1 guest