The app-crypt/libgssapi package conflicts with another packa

Anything that pertains to Portage

Moderator: Moderators

The app-crypt/libgssapi package conflicts with another packa

Postby loodi » Thu Oct 11, 2007 9:17

I am a sabayon noob..i found tutorial that suggested i do the following after installing Sabayon 3.4 miniedition and i did:

emerge --sync
emerge portage
dispatch-conf
layman -S

And when i typed this "glsa-check -f all" ..after a while i got this error:


>>> merging net-libs/librpcsecgss-0.16
Calculating dependencies... done!

!!! Error: the app-crypt/libgssapi package conflicts with another package;
!!! the two packages cannot be installed on the same system together.
!!! Please use 'emerge --pretend' to determine blockers.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/h ... =1#blocked
So I try "emerge --pretend" and loko what i get:


localhost .unit # emerge --pretend
emerge: the other white meat (command-line interface to the Portage system)
Usage:
emerge [ options ] [ action ] [ ebuildfile | tbz2file | dependency ] [ ... ]
emerge [ options ] [ action ] < system | world >
emerge < --sync | --metadata | --info >
emerge --resume [ --pretend | --ask | --skipfirst ]
emerge --help [ system | world | --sync ]
Options: -[abBcCdDefgGhkKlnNoOpqPsStuvV] [--oneshot] [--newuse] [--noconfmem]
[ --color < y | n > ] [ --columns ]
[ --reinstall changed-use ] [--nospinner]
[ --deep ] [--with-bdeps < y | n > ]
Actions: [ --clean | --depclean | --prune | --regen | --search | --unmerge ]

For more help try 'emerge --help --verbose' or consult the man page.
loodi
Young Hen
 
Posts: 26
Joined: Wed Apr 11, 2007 16:00

Re: The app-crypt/libgssapi package conflicts with another packa

Postby wolfden » Thu Oct 11, 2007 10:38

Code: Select all
!!! Please use 'emerge --pretend' to determine blockers.


--pretend is a flag you use along with the normal command


example:
Code: Select all
emerge --pretend foo


http://gentoo-wiki.com/MAN_emerge
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: The app-crypt/libgssapi package conflicts with another packa

Postby loodi » Thu Oct 11, 2007 11:25

Thank you... but how is that good to me.. what should i do to "fix" problem I got... Im sorry but im new into all of this... and any help would be appreciated...
loodi
Young Hen
 
Posts: 26
Joined: Wed Apr 11, 2007 16:00

Re: The app-crypt/libgssapi package conflicts with another packa

Postby wolfden » Thu Oct 11, 2007 11:32

:shock:

do as it tells you, to find what is blocking what. Once you see what is blocking what, decide from there. You can either mask what is pulling the packages or uninstall it if you don't need it. All depends on what it is.
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: The app-crypt/libgssapi package conflicts with another packa

Postby loodi » Thu Oct 11, 2007 12:20

Hehe... ok I would like to do what is asking me to do..I was thinking more like "what exactly should I type in console next" :D ?

Thank you for having patience, this is probably silly to you, but a big prob. to me..
loodi
Young Hen
 
Posts: 26
Joined: Wed Apr 11, 2007 16:00

Re: The app-crypt/libgssapi package conflicts with another packa

Postby wolfden » Thu Oct 11, 2007 13:31

I gave you the example up above

Code: Select all
emerge --pretend foo


Code: Select all
!!! Error: the app-crypt/libgssapi package conflicts with another package;
!!! the two packages cannot be installed on the same system together.
!!! Please use 'emerge --pretend' to determine blockers.


what is that saying?

app-crypt/libgssapi package conflicts with another package;

so app-crypt/libgssapi is having a conflict
!!! Please use 'emerge --pretend' to determine blockers.

so this is telling us to use the --pretend to find the conflict with the package app-crypt/libgssapi

so?

Code: Select all
emerge --pretend libgssapi


I think before you go any further you should probably learn the package manager. If you can't get that, you're really gonna be hurting with how to resolve any thing with portage.

http://wiki.sabayonlinux.org/index.php? ... tage_Guide

http://www.gentoo.org/doc/en/ <--hand book and other material
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: The app-crypt/libgssapi package conflicts with another packa

Postby loodi » Thu Oct 11, 2007 15:01

Nope.. I tried but it says:

Calculating dependencies -
emerge: there are no ebuilds to satisfy "libgssapi".
loodi
Young Hen
 
Posts: 26
Joined: Wed Apr 11, 2007 16:00

Re: The app-crypt/libgssapi package conflicts with another packa

Postby wolfden » Thu Oct 11, 2007 15:29

are you sure you have first done


Code: Select all
emerge --sync && layman -S
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: The app-crypt/libgssapi package conflicts with another packa

Postby loodi » Thu Oct 11, 2007 15:36

Yup.. but here I'll try again...

I did in this order as it says here:

Installation
Once you've installed Sabayon, and you'd like to stabilize your package manager (emerge/portage), use the following commands. Open a terminal, and run these commands as root using either su or sudo, depending on your preference.
emerge --sync
After running emerge --sync you will likely need to run emerge portage and then
dispatch-conf
layman -S
glsa-check -f all
dispatch-conf
loodi
Young Hen
 
Posts: 26
Joined: Wed Apr 11, 2007 16:00

Re: The app-crypt/libgssapi package conflicts with another packa

Postby wolfden » Thu Oct 11, 2007 23:16

than try the pretend flag with librpcsecgss and see what it says
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Next

Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest