Problem with blocked packages [Solved]

Anything that pertains to Portage

Moderator: Moderators

Problem with blocked packages [Solved]

Postby rhomp2002 » Sat Oct 06, 2007 20:53

I am getting ready to run the world update and I have a blocked package problem that I can't figure out how to solve.

<media-libs/openexr-1.5.0 (is blocking media-libs/ilmbase-1.0.0)


I looked in google and it appears that when openexr went from 1.4 to 1.5 they split the ilmbase into 4 files. I don't know whether I should emerge -C ilmbase or what I should do with this one. There does not seem to be a solution found other than some paludis codes that I don't know.

I am installing the new mini 3.4 onto an Athlon XP 3000+ using the 32 bit version. I got the rest of the blocked packages resolved except this one. I not that the last 2 ebuilds listed when I did a -up world are:

media-libs/openexr-1.6.0 [1.4.0a] as an update ebuild
and
media=libs/ilmbase-1.0.0 as a new ebuild

and these were the ones bracketing where the the ilm libraries were split up. That is why I cannot figure out if I need to delete one of them or delete the old openexr and let it build new or just what is required.

:?: :?:
Last edited by rhomp2002 on Sun Oct 07, 2007 19:26, edited 1 time in total.
rhomp2002
Simple Hen
 
Posts: 97
Joined: Fri Jan 26, 2007 3:19
Location: jamaica, ny, usa

Re: Problem with blocked packages

Postby wolfden » Sat Oct 06, 2007 21:03

On mine:
[I] media-libs/openexr
Available versions: 1.0.7 1.2.2 1.2.2-r2 1.4.0a (~)1.6.0
Installed versions: 1.6.0(10:39:32 AM 09/18/2007)(-doc -examples)

[I] media-libs/ilmbase
Available versions: (~)1.0.0
Installed versions: 1.0.0(10:37:50 AM 09/18/2007)


I don't know how you are trying to do this, but try just updating openexr by itself first than try ilmbase. Some times you do need to uninstall and than reemerge afterwards.

media-libs/openexr
ILM's OpenEXR high dynamic-range image file format libraries

media-libs/ilmbase
OpenEXR ILM Base libraries
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Problem with blocked packages

Postby rhomp2002 » Sun Oct 07, 2007 0:05

I was trying to do an update world. I ran the -up world and got 3 blockages. I took care of the other 2 but I couldn't see what to do to fix this one before I ran the update world.

I just installed the mini 3.4 and was running the updates to get it caught up to date. That was when I ran into this blockage. I deleted the 1.4 version of openexr and that seemed to take care of the blockage so I will see when it gets to the end if it runs the two modules OK. I wanted to do it using the regular update world in case there were some earlier packages that needed to be run first.
rhomp2002
Simple Hen
 
Posts: 97
Joined: Fri Jan 26, 2007 3:19
Location: jamaica, ny, usa

Re: Problem with blocked packages

Postby rhomp2002 » Sun Oct 07, 2007 19:26

Solved.

I needed to run an emerge -C on the old version of openexr (1.4.0a) and then the two ran with no blockage at all.

That was one of the suggestions on the Paludis problem with this blockage but they never said that it worked or not. It does work.
rhomp2002
Simple Hen
 
Posts: 97
Joined: Fri Jan 26, 2007 3:19
Location: jamaica, ny, usa


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest