emerge update fails on blocked packages...

Anything that pertains to Portage

Moderator: Moderators

Post Reply
Jmanfoo
Baby Hen
Posts: 5
Joined: Sat Aug 25, 2007 4:28

emerge update fails on blocked packages...

Post by Jmanfoo » Thu Oct 04, 2007 17:21

I get the feeling I'm using the wrong ebuild or overlay, any ideas?

trying to do:

Code: Select all

emerge --update --ask world
Results in:

Code: Select all

[blocks B     ] x11-drivers/ati-drivers (is blocking x11-base/xorg-server-1.4-r2
)
[blocks B     ] <net-print/hplip-1.7.4a-r1 (is blocking net-print/cups-1.2.12)
[blocks B     ] x11-misc/xkbdata (is blocking x11-misc/xkeyboard-config-1.1)
[blocks B     ] dev-python/mmpython (is blocking dev-python/kaa-metadata-0.6.1-r
1)
[blocks B     ] <dev-util/portatosourceview-2.16.1-r1 (is blocking x11-libs/gtks
ourceview-1.8.5-r1)
[blocks B     ] x11-drivers/xf86-video-via (is blocking x11-drivers/xf86-video-o
penchrome-9999)
[blocks B     ] <dev-libs/boost-1.34.0 (is blocking dev-util/boost-build-1.34.1)
[blocks B     ] sys-apps/setarch (is blocking sys-apps/util-linux-2.13-r1)
[blocks B     ] x11-misc/xkeyboard-config (is blocking x11-misc/xkbdata-1.0.1)
[blocks B     ] <sys-apps/baselayout-2.0.0_rc (is blocking sys-apps/makedev-3.23
.1)
[blocks B     ] sys-process/schedutils (is blocking sys-apps/util-linux-2.13-r1)
[blocks B     ] app-crypt/libgssapi (is blocking net-libs/libgssglue-0.1)

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

Trying to do:

Code: Select all

emerge --update --ask system
Results in:

Code: Select all

[blocks B     ] >=sys-apps/util-linux-2.13_pre (is blocking sys-process/scheduti                                            ls-1.5.0)
[blocks B     ] <sys-fs/device-mapper-1.02.19-r1 (is blocking sys-fs/udev-115-r1                                            )
[blocks B     ] sys-apps/setarch (is blocking sys-apps/util-linux-2.13-r1)
[blocks B     ] <sys-apps/baselayout-2.0.0_rc (is blocking sys-apps/makedev-3.23                                            .1)
[blocks B     ] sys-process/schedutils (is blocking sys-apps/util-linux-2.13-r1)

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
I don't want to go randomly deleting and unblocking packages, and like I said something tells me the eBuild is wrong...
BTW I'm running 64-bit Sabayon on kernel 2.6.22. I think it's Sabayon 4.1? I don't remember and can't find it on my system.

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: emerge update fails on blocked packages...

Post by wolfden » Thu Oct 04, 2007 17:30

there never was a 4.1

if you're doing a world update you're going to run into bumps like that, listen to what portage is telling you and work through them. If you search the forum you will see others have worked thru em

Jmanfoo
Baby Hen
Posts: 5
Joined: Sat Aug 25, 2007 4:28

Re: emerge update fails on blocked packages...

Post by Jmanfoo » Thu Oct 04, 2007 18:10

Ok good, just wanted to make sure this wasn't unusual and I wasn't going to screw things up by trying to resolve it package by package.

Post Reply