Audacity ebuild wxGTK version problem [3.4mini x86_64]

Anything that pertains to Portage

Moderator: Moderators

Audacity ebuild wxGTK version problem [3.4mini x86_64]

Postby deavik » Tue Sep 25, 2007 22:00

Hello!
I was trying to emerge audacity, and it installed wxGTK-2.8 first. However when it got to emerging audacity it complained that wxgtk was not compiled with unicode support. But My USE flags in /etc/make.conf did include unicode. I also tried

USE="-unicode" emerge audacity
while wxgtk was still there and it complained that I should include gtk in my use flags. My problem is exactly the same as this other sabayon user: http://translate.google.com/translate?h ... n%26sa%3DG But I would like to keep wxgtk-2.8, when it seems like it's a small config problem.

Is this a problem with the ebuild?

I searched and found this http://forums.gentoo.org/viewtopic-t-57 ... a4a5649762 on gentoo forums, but that says using the eclass file from the sabayon overlay fixed the problem over there...

EDIT: The eclass file is over here http://svn.sabayonlinux.org/filedetails ... 2.8.eclass (I am away from my computer now, so I can't compare to what my SL install has, but from the error messages it looks like that's the one).
Last edited by deavik on Tue Sep 25, 2007 23:41, edited 1 time in total.
deavik
Baby Hen
 
Posts: 5
Joined: Sat Sep 01, 2007 5:59

Re: wxGTK-2.8 ebuild unicode flag not set [3.4mini x86_64]

Postby Eden » Tue Sep 25, 2007 22:16

Code: Select all
wx-config --list


it should say something like:

Code: Select all

    Default config is gtk2-unicode-release-2.8

  Default config will be used for output

  Alternate matches:
    gtk2-ansi-release-2.6
    gtk2-ansi-release-2.8
    gtk2-unicode-release-2.6

not if it doesn't say gkt2 or unicode then you need to recompile wxGTK with those flags.
Eden
Growing Hen
 
Posts: 176
Joined: Fri May 18, 2007 16:44
Location: Scotland, UK

Re: wxGTK-2.8 ebuild unicode flag not set [3.4mini x86_64]

Postby deavik » Tue Sep 25, 2007 23:40

Hey Eden,
I ran that and got
Code: Select all
# wx-config --list

    Default config is gtk2-unicode-release-2.8

  Default config will be used for output

  Alternate matches:
    gtk2-ansi-release-2.8


I just noticed that the problem is because Audacity ebuild looks for the 2.6 wxgtk libs:

Code: Select all
>>> Compiling source in /var/tmp/portage/media-sound/audacity-1.3.3/work/audacity-src-1.3.3-beta ...
!!! set-wxconfig: Error:  Can't find normal or debug version:
!!! set-wxconfig:         /usr/lib64/wx/config/gtk2-unicode-release-2.6 not found
!!! set-wxconfig:         /usr/lib64/wx/config/gtk2-unicode-debug-2.6 not found
!!! You need to emerge wxGTK with unicode in your USE


wxgtk was compiled with 2.6 compatibility, any tips?

Thanks
deavik
Baby Hen
 
Posts: 5
Joined: Sat Sep 01, 2007 5:59

Re: Audacity ebuild wxGTK version problem [3.4mini x86_64]

Postby Eden » Tue Sep 25, 2007 23:46

you can emerge multiple versions of wxGTK so just emerge 2.6

Code: Select all
emerge -va =x11-libs/wxGTK-2.6.4.0
Eden
Growing Hen
 
Posts: 176
Joined: Fri May 18, 2007 16:44
Location: Scotland, UK

Re: Audacity ebuild wxGTK version problem [3.4mini x86_64]

Postby wolfden » Wed Sep 26, 2007 0:44

moved to correct forum
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests

cron