Changing profiles (eselect profile)

Anything that pertains to Portage

Moderator: Moderators

gentmixer
Simple Hen
Posts: 60
Joined: Wed Jan 17, 2018 17:21

Re: Changing profiles (eselect profile)

Post by gentmixer » Fri Jan 19, 2018 1:04

I know, the Sabayon is not a simple replica of Gentoo... So: "help yourself" at this moment...

User avatar
albfneto
Sagely Hen
Posts: 1870
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil
Contact:

Re: Changing profiles (eselect profile)

Post by albfneto » Wed Jan 24, 2018 17:41

without changing the profile, my compilations with Sabayon's Portage and GCC 5.4 working in a good manner.
I upgraded my filezilla package.

Today, i'm using my new Sabayon installation. see the latest message in:

viewtopic.php?f=57&t=33768

My other Sabayon installation is working, but not upgradable. is my "job" installation:

viewtopic.php?f=76&t=33866
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE

gentmixer
Simple Hen
Posts: 60
Joined: Wed Jan 17, 2018 17:21

Re: Changing profiles (eselect profile)

Post by gentmixer » Thu Jan 25, 2018 23:10

Yes, gcc-5.4 works in both systems, but in the new Gentoo (with "+pie" and "-pie" alike) it should be gcc-6.4 or higher... Gentoo will be compiled with 17.0 profile... Read the announcement by Andreas K. Huettel: https://www.gentoo.org/support/news-ite ... files.html.
It is not only "pie" question:
"The default C++ language version for applications is now C++14.
This change is mostly relevant to Gentoo developers. It also
means, however, that compilers earlier than GCC 6 are masked
and not supported for use as a system compiler anymore. Feel
free to unmask them if you need them for specific applications."
I have mixed system at this moment so I have to evaluate some consequences of this in the future. How I can retain compatibility of systems?

gentmixer
Simple Hen
Posts: 60
Joined: Wed Jan 17, 2018 17:21

Re: Changing profiles (eselect profile)

Post by gentmixer » Wed Feb 07, 2018 14:21

After last massive upgrade the end of the problem...

Post Reply