Emerge Update Error

Anything that pertains to Portage

Moderator: Moderators

Emerge Update Error

Postby mfrv » Sat Oct 08, 2016 16:46

Hello,
I tried to update my system via portage and got the error below.
Since I am from the newbie corner, some help would be greatly appreciated :D
Code: Select all
emerge -a --update --newuse --deep --with-bdeps=y @world   

These are the packages that would be merged, in order:

Calculating dependencies |

!!! Problem resolving dependencies for dev-libs/liborcus:0 from @selected
... done!

!!! The ebuild selected to satisfy "dev-libs/liborcus:0" has unmet requirements.
- dev-libs/liborcus-0.11.2::gentoo USE="python spreadsheet-model -static-libs -tools" ABI_X86="64" PYTHON_SINGLE_TARGET="-python3_4 -python3_5" PYTHON_TARGETS="python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python? ( exactly-one-of ( python_single_target_python3_4 python_single_target_python3_5 ) )

  The above constraints are a subset of the following complete expression:
    python? ( exactly-one-of ( python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 ) )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
mfrv
Baby Hen
 
Posts: 1
Joined: Sat Oct 08, 2016 16:41

Re: Emerge Update Error

Postby sabayonino » Sat Oct 08, 2016 17:01

Hi , and welcome on sabayonlinux

Sabayon has 2 packages manager but by default it has its own ; Entropy
see Sabayon Wiki to learn how entropy works basically

It's not recommended to use portage to update your system , but you can run it for some package(s)
see Safely_mix_Entropy_and_Portage Wiki

Good luck
User avatar
sabayonino
Sagely Hen
 
Posts: 2914
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Emerge Update Error

Postby svantoviit » Sun Oct 09, 2016 8:42

mfrv wrote:Since I am from the newbie corner, some help would be greatly appreciated :D

Have you ever updated the Portage tree?If you want to learn Portage I would rather suggest you to install Gentoo directly to play with it.
If you ever manage to resolve all the issues which will gradually pop up when you try to update Sabayon using Portage you will with the highest probability end up with a broken system anyway.
In Sabayon just stick with Entropy ;)
svantoviit
Old Dear Hen
 
Posts: 674
Joined: Sun Feb 28, 2010 17:55


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron