Webcam and Compiz-Fusion... No-Go?

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Webcam and Compiz-Fusion... No-Go?

Postby googlymoogly » Thu Jul 19, 2007 17:23

I'm hoping someone can help me with this issue. I can't for the life of me seem to get my webcam working with Compiz-Fusion. I never could get it to work with Beryl either for that matter. It works fine if I revert to Kwin though. I'm using a Logitech Quickcam for Notebooks Pro (2006) with the latest uvcvideo driver and the latest version of luvcview. Like I said, under Kwin it works just dandy, but when Compiz-Fusion is running the window opens like it wants to show me something and then just closes immediately. This is my output from console:

Code: Select all
[email protected] ~ $ luvcview
luvcview version 0.2.1
Video driver: x11
A window manager is available
video /dev/video0
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  142 (XVideo)
  Minor opcode of failed request:  19 ()
  Serial number of failed request:  25
  Current serial number in output stream:  26


Now I know the insufficient resources is BS because I can watch fullscreen video and do all kinds of crap, drag things through expo, rotate cube, all kinds of stuff with no problems.

If I check top I get:

Code: Select all
[email protected] ~ $ top
top - 09:21:44 up 18:07,  1 user,  load average: 0.59, 0.72, 0.94
Tasks: 139 total,   2 running, 136 sleeping,   0 stopped,   1 zombie
Cpu(s): 19.9%us,  5.0%sy,  0.0%ni, 73.8%id,  0.3%wa,  0.3%hi,  0.7%si,  0.0%st
Mem:   2056684k total,  2005664k used,    51020k free,    63004k buffers
Swap:  2144668k total,     3536k used,  2141132k free,  1091176k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
23395 root      20   0  461m 118m 7660 S 12.6  5.9 127:55.33 X
27842 neil      20   0  250m 160m  20m R  2.7  8.0   4:05.15 opera
18324 neil      20   0 30040  18m  13m S  1.7  0.9  11:52.75 superkaramba
13281 neil      20   0  142m 136m 7744 S  1.0  6.8   2:34.48 compiz
  792 neil      20   0  2096 1124  824 R  0.7  0.1   0:00.11 top
 7777 messageb  20   0  2208  940  656 S  0.3  0.0   1:54.94 dbus-daemon
 7860 haldaemo  20   0  4888 3348 2008 S  0.3  0.2   0:23.10 hald
 8751 root      20   0  9988 4900 1116 S  0.3  0.2   0:11.20 hpssd.py
 9076 root      20   0 29300 2012 1696 S  0.3  0.1   0:36.38 NetworkManager
23517 neil      20   0 27944  15m  11m S  0.3  0.8   0:10.06 yakuake
23616 neil      20   0 28940  13m  10m S  0.3  0.7   1:44.02 knetworkmanager
23716 root      20   0  117m  36m  30m S  0.3  1.8  11:01.45 firestarter
    1 root      20   0  1508  528  460 S  0.0  0.0   0:02.50 init
    2 root      RT   0     0    0    0 S  0.0  0.0   0:00.00 migration/0
    3 root      39  19     0    0    0 S  0.0  0.0   0:04.54 ksoftirqd/0
    4 root      15  -5     0    0    0 S  0.0  0.0   0:03.83 events/0


Any suggestions will be appreciated. :wink:
googlymoogly
Baby Hen
 
Posts: 15
Joined: Wed Jul 11, 2007 18:11

Re: Webcam and Compiz-Fusion... No-Go?

Postby erik » Sun Feb 24, 2008 16:35

Hey man, I realise it might be a bit late but I don;t think your web cam DOESNT WORK, it just can't display output on top of compiz, but it does work. Try it by calling someone in skype beta, you will see a white square where your own image output should be, but you can see the other side and they can see you. Compiz just wont support proper playback on top of itself FROM YOU OWN CAM ONLY. Something to do with XV.

In the future post your specs.
erik
Baby Hen
 
Posts: 16
Joined: Wed Jan 02, 2008 0:01


Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 3 guests