Page 1 of 1

How to setup the locales?

Posted: Thu Feb 27, 2020 16:47
by msdobrescu
Hello,

I have updated today and something has happened to the locales.
I have had already set in KDE Regional Settings Plasma translations American English (Default), and Romanian & French as alternatives.
The formats were ro_RO (Romanian/Romania).

Now, KDE (5.18.1) is in English, as expected. Also Firefox.

But Gnome apps are in Romanian, Rigo in Romanian, bash/sh are in Romanian.

This is on two computers.

A desktop:

Code: Select all

locale
LANG=ro_RO.UTF-8
LC_CTYPE="ro_RO.UTF-8"
LC_NUMERIC="ro_RO.UTF-8"
LC_TIME="ro_RO.UTF-8"
LC_COLLATE="ro_RO.UTF-8"
LC_MONETARY="ro_RO.UTF-8"
LC_MESSAGES="ro_RO.UTF-8"
LC_PAPER="ro_RO.UTF-8"
LC_NAME="ro_RO.UTF-8"
LC_ADDRESS="ro_RO.UTF-8"
LC_TELEPHONE="ro_RO.UTF-8"
LC_MEASUREMENT="ro_RO.UTF-8"
LC_IDENTIFICATION="ro_RO.UTF-8"
LC_ALL=
A laptop:

Code: Select all

locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=ro_RO.UTF-8
LC_CTYPE="ro_RO.UTF-8"
LC_NUMERIC="ro_RO.UTF-8"
LC_TIME="ro_RO.UTF-8"
LC_COLLATE="ro_RO.UTF-8"
LC_MONETARY="ro_RO.UTF-8"
LC_MESSAGES="ro_RO.UTF-8"
LC_PAPER="ro_RO.UTF-8"
LC_NAME="ro_RO.UTF-8"
LC_ADDRESS="ro_RO.UTF-8"
LC_TELEPHONE="ro_RO.UTF-8"
LC_MEASUREMENT="ro_RO.UTF-8"
LC_IDENTIFICATION="ro_RO.UTF-8"
LC_ALL=
Also, on the laptop, I see equo/rigo errors:

Code: Select all

/var/tmp/entropy/sys-power/bbswitch-0.8-r2#5.4.0-sabayon/v1g_pun5/portage/sys-power/bbswitch-0.8-r2/temp/environment: line 160: warning: setlocale: LC_CTYPE: cannot change locale (en_US.UTF-8): No such file or directory
/var/tmp/entropy/sys-power/bbswitch-0.8-r2#5.4.0-sabayon/v1g_pun5/portage/sys-power/bbswitch-0.8-r2/temp/environment: line 163: warning: setlocale: LC_MESSAGES: cannot change locale (en_US.UTF-8): No such file or directory
/var/tmp/entropy/sys-power/bbswitch-0.8-r2#5.4.0-sabayon/v1g_pun5/portage/sys-power/bbswitch-0.8-r2/temp/environment: line 166: warning: setlocale: LC_NUMERIC: cannot change locale (en_US.UTF-8): No such file or directory
/var/tmp/entropy/sys-power/bbswitch-0.8-r2#5.4.0-sabayon/v1g_pun5/portage/sys-power/bbswitch-0.8-r2/temp/environment: line 169: warning: setlocale: LC_TIME: cannot change locale (en_US.UTF-8): No such file or directory
and

Code: Select all

/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
>>> Regenerating /etc/ld.so.cache...
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
>>> Regenerating /etc/ld.so.cache...
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
>>> Regenerating /etc/ld.so.cache...
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
>>> Regenerating /etc/ld.so.cache...
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
>>> Regenerating /etc/ld.so.cache...
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
>>> Regenerating /etc/ld.so.cache...
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
>>> Regenerating /etc/ld.so.cache...
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
>>> Regenerating /etc/ld.so.cache...
sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
I'd prefer to have English in the UI and region as Romania (for the timezone) and numbers formats and currency as Romanian.

What are the right steps for that?

Thanks in advance!

Re: How to setup the locales?

Posted: Sat Feb 29, 2020 8:47
by msdobrescu
Hi, I have removed the UI translations for Romanian and French, because I've got random texts in several languages.
As I've set English for default, I would have expected to have English messages everywhere.
But no, KDE was in English only, but shell was once in Romanian, once in French, some messages in English. This is weird at least.
Gnome/GTK apps seems to fall to the region settings...
Too bad if some user needs a different locale than other...