Page 1 of 1

Screen locker issue [Solved]

Posted: Thu Dec 07, 2017 3:04
by bunjee50
I installed from the Live CD.......several times!!
Every time I do I have problems with the screen locking.
I get the message:
"The screen locker is broken and unlocking is not possible anymore.
In order to unlock switch to a virtual terminal (e.g. Ctrl+Alt+F2),
log in and execute the command:
loginctl unlock-sessions
Afterwards switch back to the running session(Ctrl+Alt+F7)."
****************************************************************************************************
The install locks up after awhile because there are so many packages to download and install.
I would love to just install a few at a time. Is that even possible??
Please advise.

Re: Screen locker issue

Posted: Thu Dec 07, 2017 12:13
by sabayonino
moved to new topic.
Please provide more informations about your installation and hardware.

Re: Screen locker issue

Posted: Sat Dec 09, 2017 7:25
by Fitzcarraldo
Have you tried disabling screen locking before starting the Installer?

KDE:
System Settings > Desktop Behaviour > Screen Locking > Activation tab

GNOME:
Applications > System Tools > Settings > Privacy

Re: Screen locker issue

Posted: Mon Feb 26, 2018 19:11
by bunjee50
screen locker issue is resolved

Re: Screen locker issue

Posted: Mon Feb 26, 2018 20:10
by Ryuno-Ki
@bunjee: Please edit the topic and add „[SOLVED]” (without quotation marks) to mark it as such. Thanks.

I'd be interested in the problem + solution for documentation purposes.

Re: Screen locker issue

Posted: Sun Mar 04, 2018 1:56
by anomaly65
kscreensaver doesn't have permission to process/check the password correctly. Upstream kde isssue.

Quick/dirty fix is:

Code: Select all

 chmod u+s /usr/lib64/libexec/kcheckpass 
Should solve the issue if you're still stuck with it :)

Cheers,
andy