oops… Kontact crashed [2017-05-26 update - solved upgrading]

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Post Reply
Tedel
Growing Hen
Posts: 111
Joined: Sun Mar 10, 2013 5:32
Location: Peru
Contact:

oops… Kontact crashed [2017-05-26 update - solved upgrading]

Post by Tedel » Sat May 27, 2017 2:06

Hi guys,

Well, I updated my Sabayon system as usual to KDE apps 17.04.1 but now Kontact is crashing. Details:

kAddressBook crashes Kontact with this message:
org.kde.pim.kontactinterface: "Cannot load library /usr/lib64/qt5/plugins/kaddressbookpart.so: (/usr/lib64/libkaddressbookprivate.so.5: undefined symbol: _ZTIN9PimCommon15PluginInterfaceE)"
libgcc_s.so.1 must be installed for pthread_cancel to work
Akregator crashes Kontact with this message:
akregator: symbol lookup error: /usr/lib64/libakregatorprivate.so.5: undefined symbol: _ZN15WebEngineViewer19CheckPhishingUrlJob6resultENS0_9UrlStatusERK4QUrl
I noticed is that both installed versions are 16.12.3 (kAddressBook and Akregator) while the rest of the Kontact suite is version 17.04.1. This may be the problem, but there isn't version 17.04.1 in the repos (yet).

While that gets solved by our fellow developers, does anyone know about a workaround?
Last edited by Tedel on Sat May 27, 2017 14:36, edited 1 time in total.

joost
Sagely Hen
Posts: 2715
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: oops… Kontact crashed [2017-05-26 update]

Post by joost » Sat May 27, 2017 10:08

Updated in Entropy now.
Image
My blog | Twitter | Please support Sabayon: Image

Tedel
Growing Hen
Posts: 111
Joined: Sun Mar 10, 2013 5:32
Location: Peru
Contact:

Re: oops… Kontact crashed [2017-05-26 update - solved upgrad

Post by Tedel » Sat May 27, 2017 14:36

Thank you so much. :)

Post Reply