start Xmonad Session

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Post Reply
ouchekkir
Baby Hen
Posts: 4
Joined: Sun Aug 28, 2016 1:55

start Xmonad Session

Post by ouchekkir » Mon Feb 20, 2017 18:31

i install xmonad and all packages necessary, but there's no ".xinitrc" config file in home directory .
how i can add "exec xmonad" to the ~/.xinitrc file and then start the session ?
any help ?
(excuse my bad English)
*sabayon xfce*

svantoviit
Old Dear Hen
Posts: 730
Joined: Sun Feb 28, 2010 17:55
Contact:

Re: start Xmonad Session

Post by svantoviit » Sat Feb 25, 2017 20:23

Use your display manager to start Xmonad. Log out of XFCE and on the log in screen you should have the possibility to switch between desktop environments. Simply choose Xmonad and log in again.

ouchekkir
Baby Hen
Posts: 4
Joined: Sun Aug 28, 2016 1:55

Re: start Xmonad Session

Post by ouchekkir » Mon Feb 27, 2017 10:01

No , there is no Xmonad start session on the Menu, there is just Xfce session manager .

svantoviit
Old Dear Hen
Posts: 730
Joined: Sun Feb 28, 2010 17:55
Contact:

Re: start Xmonad Session

Post by svantoviit » Mon Feb 27, 2017 18:09

Post the output of

Code: Select all

equo q installed -vq xmonad
and

Code: Select all

ls -l /etc/systemd/system/display-manager.service

ouchekkir
Baby Hen
Posts: 4
Joined: Sun Aug 28, 2016 1:55

Re: start Xmonad Session

Post by ouchekkir » Tue Feb 28, 2017 23:26

- equo q installed -vq xmonad :
x11-misc/xmonad-log-applet-2.0.0-r301
x11-wm/xmonad-0.12
x11-wm/xmonad-contrib-0.12

- ls -l /etc/systemd/system/display-manager.service :
lrwxrwxrwx 1 root root 41 Oct 28 05:10 /etc/systemd/system/display-manager.service -> /usr/lib64/systemd/system/lightdm.service

svantoviit
Old Dear Hen
Posts: 730
Joined: Sun Feb 28, 2010 17:55
Contact:

Re: start Xmonad Session

Post by svantoviit » Wed Mar 01, 2017 4:39

Code: Select all

dm-tool switch-to-greeter
should get you to the log in screen. Somewhere there should be a menu to change the session.

Or you could try something like

Code: Select all

dm-tool switch-to-user YOURUSERNAME xmonad
Another option is to change the default session in the lightdm config.

PS: I remember having some issues with lightdm so I switched to lxdm instead.

Post Reply