Page 1 of 3

ksmserver issues with Plasma 5.4.1

Posted: Tue Sep 22, 2015 14:53
by fusion809
Hi,

I installed KDE Plasma 5.4.1 with Portage, and I've noticed that occasionally, usually when I'm compiling something using Portage and it's taking a lot of RAM/CPU, Plasma crashes and I'm taken back to the SDDM login screen. When I log back in to Plasma 5 an error pops up, complaining that ksmserver failed to load. When I run

Code: Select all

emerge -a ksmserver
as root, in an effort to repair the ksmserver Portage informs me that Plasma 5.4.1 Workspace conflicts with ksmserver (implying, in my opinion at least, that ksmserver is part of Plasma 4, not Plasma 5). So hence I am here asking, if anyone knows how to solve this problem.

Why don't I install Plasma 5 with Entropy? Because my experience so far is that Plasma 5 installed with Entropy is unstable, while when it is installed with Portage it is (usually, except for this glitch I'm mentioning now) stable.

Thanks for your time,
Brenton

Re: ksmserver issues with Plasma 5.4.1

Posted: Fri Oct 02, 2015 16:53
by denijane
Hi, I got precisely the same error with kmserver just now, while doing some scientific calculations.
Have you found some solution to the problem and if not how often does it occur? Because if plasma does this all the time, then I better go back to KDE.

Re: ksmserver issues with Plasma 5.4.1

Posted: Fri Oct 02, 2015 17:40
by joost
ksmserver is not even in Entropy anymore.

Did you ever use the equo upgrade --purge command to remove unneeded packages? Maybe you should do this to get rid of stuff like this.

Re: ksmserver issues with Plasma 5.4.1

Posted: Fri Oct 02, 2015 19:40
by denijane
Hi joost,
I don't find ksmserver with equo at all. So I suppose it's some kind of bug - in one moment I was doing stuff, in the next, I was back to login screen with a white popup telling me ksmserver couldn't load or something like that. Very weird. But since it's my first use of plasma, I'd really like to know how frequent such errors are, because if they happen on serious system load, well, maybe I'll be back to pure kde.

Re: ksmserver issues with Plasma 5.4.1

Posted: Fri Oct 02, 2015 19:44
by fusion809
equo upgrade --purge won't work for me, as I don't use Entropy to install Plasma 5.4.1.

Re: ksmserver issues with Plasma 5.4.1

Posted: Fri Oct 02, 2015 21:20
by joost
ah. For the record. ksmserver is now part of kde-plasma/plasma-workspace

Re: ksmserver issues with Plasma 5.4.1

Posted: Mon Oct 05, 2015 22:31
by fusion809
I have found a way to make this problem less severe, by switching to Entropy-installed KDE Plasma 5, which is more stable than it used to be. Despite this, seeming to make the problem less severe, KDE Plasma 5 does still crash for me due to ksmserver issues occasionally (usually after >3 hours of continuous use). It is vital that this problem be solved. @joost, if I can help fix this problem by filling a bug report, or w/e, please do tell. This bug needs to be resolved! My poll (results as of 7:20 AM AEST are here) has shown that KDE Plasma 5 is the most loved desktop environment, and while I do like this DE this bug is making the DE more annoying than useful.

Re: ksmserver issues with Plasma 5.4.1

Posted: Tue Oct 06, 2015 7:26
by joost
equo upgrade --purge won't work for me, as I don't use Entropy to install Plasma 5.4.1.


Then do not expect to get support.

Re: ksmserver issues with Plasma 5.4.1

Posted: Tue Oct 06, 2015 9:05
by fusion809
@joost You may not have fully understood what I meant by my last post, I said I removed my Portage installation of KDE Plasma 5 and replaced it with an Entropy installation of KDE Plasma 5. So I think that means I can expect support, here.

Re: ksmserver issues with Plasma 5.4.1

Posted: Tue Oct 06, 2015 11:22
by joost
Then did you purge? :P